PDA

View Full Version : PJ64 Save Files


michaelptrinh
10th September 2009, 04:51 AM
I'm trying to switch to another version of PJ64 from v1.6. Where can I find the save files that the emulator uses to store all the save data? I want to retain all my work.

HatCat
10th September 2009, 05:03 AM
If you know where you have Project64 installed, look there for a "Save" subdirectory.
These files may be copied to other version installations, but save states may not load if you are downgrading to older version.

michaelptrinh
10th September 2009, 06:16 AM
I can't find any Save folders, but I do know that the game is saving. All the folders I see are Docs; 3rd party Plugins, Cheat Codes, Game FAQ, Plugin Specs, RDB, RDX; Lang; and Plugin.

Is the file supposed to be a ".dat" file?

Does the emulator create a different save file for each game I play?

HatCat
10th September 2009, 07:16 AM
I can't find any Save folders, but I do know that the game is saving. All the folders I see are Docs; 3rd party Plugins, Cheat Codes, Game FAQ, Plugin Specs, RDB, RDX; Lang; and Plugin.
$Project64\"Save" is just a default setting.
If there is a custom location where saves are stored you can see these through the "Directories" tab of the options dialogue. To get to that, Options/Settings....
Advanced settings must not have been set to hide upon entering config, (See "Options" tab.) or the "Directories" tab doesn't show.

Also just because I'm not sure what else, make sure that you are checking the current version of Project64 you were using to play and save game progress rather than the one you want to transfer the saves to.

Is the file supposed to be a ".dat" file?
Possible extensions for saving with Project64 include PJ, ZIP, EEP, SRA, FLA, and MPK.

If you are saving via the controller pak then they aren't always stored in a $Project64\"Save" folder.

Does the emulator create a different save file for each game I play?
Each game has its own save, if there is something set to store.

michaelptrinh
10th September 2009, 08:03 AM
Under the settings/directories tab, it states that my N64 auto and instant saves are both stored under $AppPath\Save\, but I don't know how to locate that folder.

I'm not sure if I'm saving using the controller pak. But if I am, are the saves on the controller pak transferable from one version of pj64 to another? Or from pj64 to another emulator? How do I access the controller pak's saves?

Thanks!

HatCat
10th September 2009, 06:17 PM
Controller "memory" pak saves are stored in MPK index files.
Only some games will mention something about a controller pak or some list of saves you can choose from in labels like "pages", "notes", "save-exit", etc.

One consistent way to tell if the game you're playing supports the controller pak is to hold the Start button down before the game gives you the first display, right after you first load the game in an emulator like Project64. If nothing happens, there may be no support for N64 memory pak. Otherwise you might get a screen for managing notes in MPK file.

"$AppPath\Save\"
This is the default setting then. If you could not see a "Save" folder along with the other ones you mentioned, in the folders listing in $AppPath (where you have 1.6), possibly it might be hidden? I'm not sure, I mean it might also not exist if some process deleted it, but no saves were made or games started since then.

There are still other ways of finding the folder no matter what happened to it, though, as long as it exists, is accessible, and has saves stored in it.

Name one game you know you have been saving and successfully loading progress for.

michaelptrinh
11th September 2009, 07:14 PM
Mario Party 2

HatCat
11th September 2009, 10:26 PM
Do a Windows search for this file.
"MarioParty2.eep"

If you get a location result, that is where your Save folder is.
This is the file handing your game progress.

To do a Windows search, ah it depends on your OS, but usually you go through the Start menu and look for a Search option somewhere. Sometimes if you're browsing through Windows Explorer there's also a button for it.

michaelptrinh
12th September 2009, 01:28 AM
Dang it! I tried searching for "Mario Party 2 (U) [!].eep" but nothing came up. I did a localized search in the PJ64 folder and one using the Start menu. I have Vista.

HatCat
12th September 2009, 02:50 AM
Well actually if you use Project64 the file name generated is "MarioParty2.eep", which is different from "Mario Party 2 (U) [!].eep", though it is good to check both.

At least for me, searching for "MarioParty2.eep" gives me one result that is in my "Project64\Save" folder.

Instead if this still doesn't work, try searching for just "*.eep", which should return all EEPROM saves.

I use Vista, too.

michaelptrinh
12th September 2009, 08:38 AM
Still no results for "*.eep" or ".eep". Any way to make the folder unhidden?

HatCat
12th September 2009, 01:00 PM
Since there are no results I am thinking possibilities, you either have no EEPROM save for Mario Party 2, the file itself is hidden or in a Windows system-marked folder, ....

In Windows Vista, it looks like in the Search there is an extender in the upper-right labeled "Advanced Search". Click that for new options to mark such as "Include non-indexed, hidden, and system files (might be slow)".
Now try searching again...also see if you can get results for "*.PJ.ZIP" in case your saves are actually emulator states.
I would also specify the Location drop-down field to your disk drive where you have Project64 stored.

To remove hidden/system attributes from specific files and folders, we need to find the directory first. If you right-click the entire parent folder of where you have Project64 1.6 installed though, if you have gray or semi check boxes in the Hidden or System fields that would suggest that parts in the folder are marked that way, just for evidence.

How have you been saving your game actually? Has the progress been saving automatically as natural, or did you like hit F5 to use Project64 to make a reference point to switch to in order to restore your progress?

michaelptrinh
12th September 2009, 08:36 PM
Okay, I tried the advance search options as you advised with no results.

When I tried right-clicking the folder containing PJ64, only "Read Only" was grayed out and check marked. I can put a check mark by "Hidden" and there's no check mark next to it.

I've been saving with a combination of both. I used F5 to savestate because PJ64 1.6 sometimes crashes with errors when I play. But the game also saves naturally, so I just load the rom to play and not use a savestate to load.

Locating the savestate would do equally well for me too if the system saves are too difficult to find.

HatCat
13th September 2009, 12:18 AM
wow okays first did you also search for "*.PJ.ZIP"? That is the extension for save states used by PJ64 1.6.

If the parent folder's option to decide Hidden attribute is completely unchecked/blank that means the full directory listing is public...or there is a System attribute someone threw in for the PROJEC~1\SAVE folder.

Also from the sound of it, make sure then that the "Hidden" attribute was already unmarked, blank and unchecked when you first opened folder properties. Modify as such, and save changes if that was not already the case.

Otherwise yeah, man I wish I could see for myself.

Try creating a batch file.
Right-click somewhere in the background of the folder where you have Project64 1.6 installed, (I mean inside that folder where the files for it are.) go New and then Text Document.

Open the TXT text file to edit it, and past the following script code in.


%SYSTEMROOT%\SYSTEM32\COMMAND.COM


Rename the extension of the text file from ".TXT" to ".BAT". When you next open the file it is loaded as a DOS batch script.

If you get a new window with a black background, OEM font and command line interface, enter the following text: "CD SAVE".
You will either get a response message "Invalid directory", or you will see the location change with a "...\SAVE" extension added to it, which proves that the default and configured folder for storing your saves does exist.

If this ends up in failure I have another thought left, specific to the fact that we both used Vista. I forgot some directories are virtual, though apparently for me that never was the case.

michaelptrinh
13th September 2009, 01:48 AM
Argh! I can only create a new folder by right-clicking the background. And yes, I did check for the savestate extension.

I uploaded the entire PJ64 folder as it is so you can see firsthand how cheap this is: http://www.megaupload.com/?d=DHOJRJ9K

Can you please look at it and see what the rip is going on?

HatCat
13th September 2009, 02:13 AM
I checked everything about the folder you sent.

I even ran Project64 1.6 from what you gave me, but when I tried playing Mario Party 2 it looks like there was no save data for it.

I can tell you something else.
Right after I started the game, the "Save" folder was created where you didn't have it.

All of this seems to suggest that our folder settings may indeed be different.

I took a screen shot of mine, differences from yours?
http://img40.imageshack.us/img40/9038/dirst.png

It could also just be the fact that you archived it, so try copying your upload to some other location on disk to see if effects are different.

michaelptrinh
13th September 2009, 03:12 AM
No differences in directory paths.

When you said I might have archived it, I immediately moved the PJ64 folder to my desktop from Program Files. I loaded Mario Party 2 and the Save folder was created, but then I seemed to have lost my previous auto save data.

Is there any way to retrieve that auto save data again? And now, I'm confused about where the emulator was pulling the save data when I had the folder in Program Files.

There was save data somewhere in that folder before, so where did it go when I moved the folder?

HatCat
13th September 2009, 03:22 AM
I was able to recall the first mention of Vista's virtual store method.

See these links or this post
http://forum.pj64-emu.com/showpost.php?p=3210

of this thread:
http://forum.pj64-emu.com/showthread.php?t=149

I can't really witness it myself yet for some reason, even though we both use Vista, but I am almost positive this will mean something to you.

michaelptrinh
13th September 2009, 03:46 AM
Wow, I would've never figured that out. I recovered the save files, so thank you for all of your help!

And another question: I keep getting a DirectInput7 error which freezes the emulation. Do you know any way to treat this? I'm hoping it's not a bug with the emulator itself.

HatCat
13th September 2009, 03:56 AM
Yeah I wouldn't have found that out either.

First if this really is, quote for quote, a "DirectInput7" error I haven't read about that before.
For my own reference will you replicate what exactly that error said?

To fix it usually depends on the error you get, but you don't really have to answer as to what it is.
You can just use a new controller plug-in.

N-Rage's DirectInput8 supports way more than Jabo's controller one does.
If you want to give that a shot, go Options/Settings..., and change the controller plug-in to N-Rage's DirectInput8....

Otherwise we need to know the error.

michaelptrinh
13th September 2009, 04:32 AM
The next time (hopefully there won't be a next time with N-rage's DirectInput8) the error pops up during emulation, I'll copy what it says in the box.

But here was what was recorded in the logs:
[7:55:49 PM 12/9/2009] Error 0x80040154 - device creation
[7:55:49 PM 12/9/2009] Error 0x80040154 - device creation
[8:06:25 PM 12/9/2009] Error 0x80040154 - device creation

I don't know if this helps.

HatCat
13th September 2009, 02:39 PM
N-Rage's plugin also has better support for newer devices.
(I noticed from your upload that we don't both use the keyboard; otherwise most plug-ins could work fine.)

michaelptrinh
15th September 2009, 02:31 AM
Hey,

I was wondering if all N64 emulators use .eep format for auto saves? Can I use my auto save from PJ64 on 1964, for example, or any other N64 emulator?

Same question for PJ64 savestates.

HatCat
15th September 2009, 02:48 AM
Good question, no for save states, with the exception of 1964's buggy support for save states made by Project64 1.4.
Save states actually contain quite a portion of the game's binary, but there is still what is unique based on the emulator writing them. You also can't load a save state created with Project64 1.6 on the 1.5 version, but you can do so in the other direction i.e. load save states created by older versions of the emulator.

EEPROM saves (EEP) have a couple main different file sizes, though many N64 games use this format. Other possibilities are SRAM (SRA) and FlashRAM (FLA).
As for the controller/memory pak saves (MPK) those are dependent actually to the controller plug-in we use of course.
The format is decided by the game technically, but the emulator is sometimes configured to force a certain format.

These "battery save" formats however are certainly dependent to the game, but to transfer them for other emulators like 1964 to use, you need to know what the file name of the EEP/SRA/FLA/etcetera save would have been if 1964 had created it. From there, just rename the one Project64 made to the file name 1964 uses, and it will load.

michaelptrinh
15th September 2009, 04:03 AM
I get it. Thanks!

michaelptrinh
20th September 2009, 03:28 AM
I was playing Mario Party 3 and the game crashed like maybe 3 times but worked fine thereafter.

According to the Logs folder, the problem was a Direct3D8 error:
[9/19/2009 6:39:58 PM] SetViewport (scissor) failed 8876086C (0,484,640,-4)

Is there a better plug-in that would prevent this error from occurring?

michaelptrinh
20th September 2009, 03:29 AM
I also have 1964. Is that a more stable emulator or does it depend on my computer?

spencerhasty05
20th September 2009, 04:14 AM
hey im new were do i find downloads

HatCat
20th September 2009, 05:14 PM
The game is fine on 1964. The real concerns in stability are more game-dependent, and pretty much every emulator does something better that another doesn't.

For that issue there are many better plug-ins, but here's a quick restore to the results you got for Project64.

With 1964 you can hit Ctrl+P to change plug-ins.
This reads files from the "1964\Plugin" folder. If you want both emulators to be able to use Jabo's Direct3D8 1.6 (from Project64), find the DLL for that plug-in from "Project64\Plugin", and copy it over.

michaelptrinh
21st September 2009, 02:27 AM
Are you saying that the instability of the game is due to the emulator and not the plug-in? So in this case, using 1964 instead of PJ64 to run MP3 ought to fix the crashes?

And, I don't understand why the same graphics plug-in should be used if there are better ones for this problem. Is there any advantage to switching to a better one?

HatCat
21st September 2009, 05:00 AM
If you want to put time into this like I do, then I would try Glide64.
See if this plug-in works for you.
http://glide64.emuxhaven.net/

By the same plug-in, though, I meant the one you were before using when you used Project64. Using that one while playing on 1964 instead would fix the viewport issues, but it's definitely worth our time to try other plug-ins.

Are you saying that the instability of the game is due to the emulator and not the plug-in? So in this case, using 1964 instead of PJ64 to run MP3 ought to fix the crashes?

Yeah that's also true.
Obviously according to the logs you got though, you could use a newer plug-in.
The default one for 1964 never rocked anyway, and it was known to need a lot of debugging, with messages similar to the one you reported. It's more good if you just want speed.

Getting back to Mario Party 3, though, definitely see if another emulator fixes crashes in main memory where Project64 didn't.

Sorry for that brief post though; I'm used to correctly presuming people just want to solve things quickly. I like to spend time learning on this stuff though.

michaelptrinh
21st September 2009, 05:52 AM
Taking everything you just said, I seem to have three options:

1. Glide64 + PJ64
2. Jabo 1.6 + 1964
3. Glide64 + 1964

I won't actually get to try any of this until next weekend. So which combination would you recommend? Would you say 1964 v1.1 is more stable than PJ64 v1.6 at the moment?

HatCat
21st September 2009, 06:47 AM
It always depends; most emulators fix things the others don't, though sometimes the drawbacks aren't really side effects.

The first thing I would do is see if 1964 fixes those crashes you got with Mario Party 3, since those are more severe.

Has 1964 fixed crashes known to Project64 yep
Has Project64 fixed crashes known to 1964, in the past

Whether you use between Glide64 and Jabo's plug-in, though, shouldn't affect the crash.
If you got those errors because of 1964's default plug-ins though they should be changed.

michaelptrinh
22nd September 2009, 01:12 AM
I got a chance to try stuff out today.

Glide64 crashed with both emulators.

1964 didn't like Jabo1.6 plug-in.

PJ64 didn't crash anymore with MP3. This seems to be a common thing that's going on. The crashes with any game I play with PJ64 occur on the first run through the game. Afterwards, the emulator "gets used to it" and stops crashing due to plug-in errors. Any other errors are just minor ones.

Do you have any other suggestions on how to decrease the number of minor errors or the likelihood of major crashes?

HatCat
22nd September 2009, 01:35 AM
The random crashes could be coincident with the new core issues Vista has with most N64 re-compilers, including the public 1.6 one.
A recent update may have made this more extreme.

When Glide64 crashed, what kind of crash was it? Did you get an error message that time, or was it after boot etc.?

In case this saves future guessing, also try glN64.
http://gln64.emulation64.com/
Once the plug-in issue is out of the way 1964 can be set to use re-compiler and not have the suspected source of crash.

michaelptrinh
22nd September 2009, 02:35 AM
For 1964, the emulator screen turned gray and said something about not being able to drag in windowed mode and I have to alt+enter. And as it happened, fullscreening with Glide64 messed up my computer.

For PJ64, Glide64 just didn't work at all. The emulator just crashed and a window said "Program stopped working..."

HatCat
22nd September 2009, 05:17 AM
You have the same set of issues I did back when I had my FX5200 card.
Actually I still get some instability with Glide64 interface.

The link in that last post I gave was for glN64 (http://gln64.emulation64.com/), a different plug-in.
Try that instead. It is more likely to work for you than a couple greater alternatives for quality, but we'll see about just getting a stable setup first.

It is important to test the in-game stability when first using a plug-in that initializes and then works.

michaelptrinh
23rd September 2009, 06:19 AM
Hmmm...

I didn't get to try the new plug-in yet. But when I was playing around on PJ64, the emulator went black, didn't crash, and was salvageable by exiting and reentering fullscreen mode. My computer had a message on the bottom right-hand corner of the computer stating "gfx driver stopped working and has recovered."

So, could this be a hardware problem?

HatCat
24th September 2009, 12:35 AM
Yeah then I would be worried about that.
If you know your graphics card, you can download an update from manufacturer's site.

I did that a few times, and both times helped.

Then again ever since I've been using Vista, now I also get that namely when I have Winamp running.
I don't think full screen could have modified it though; in that case it was random.

So what is your graphics card?

michaelptrinh
24th September 2009, 01:54 AM
Interesting that you mention Winamp. I don't have it playing any music when I'm playing, but my roommate always told me to close the application anyway.

My gfx device is Intel(R) Graphics Media Accelerator Driver.

HatCat
24th September 2009, 04:40 AM
Interesting that you mention Winamp. I don't have it playing any music when I'm playing, but my roommate always told me to close the application anyway.

My gfx device is Intel(R) Graphics Media Accelerator Driver.

Yeah come to think of it Winamp has had some mysterious effects.
If I let my desktop sit overnight though or something, nothing happened as far as I can tell. Every rare period though when I get stuttering audio and locked up interfaces until I move my mouse, cursor starts moving with it again with Winamp playing music normally without stuttering anymore, I get the driver recovery message.
I can see Winamp's getting all kinds of updates on things like security and bugs...too bad I can't install them on my limited account. :P

I found a driver update page for Intel(R) Graphics Media Accelerator 500.
http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Graphics&ProductLine=Laptop+graphics+controllers&ProductProduct=Intel%C2%AE+Graphics+Media+Accelera tor+500

Actually I'm worried about the "500" part that isn't in the name you gave, but for some reason I haven't been finding any variants.
Just to be safe see if you can get other details about your current drivers.

A couple ways that are handy is one, through Windows go through Start menu, look for a Run command, enter "dxdiag" (case-insensitive), look for Display tab information on that stuff,
and two, if you use Project64's default plug-in for graphics i.e. Jabo's Direct3D, if you go Options/Configure Graphics Plugin... usually there is blue text at the top-left of the dialogue describing your video card.

michaelptrinh
24th September 2009, 07:48 AM
Yep. Both the plug-in and dxdiag show Mobile Intel(R) 945GM Express Chipset Family

HatCat
24th September 2009, 11:45 AM
Go here
http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Internet+Devices&ProductLine=Netbooks&ProductProduct=Mobile+Intel%C2%AE+945GM+Express+Ch ipset+Family
fill in your OS, and install update to your drivers.

Emmett
24th September 2009, 06:59 PM
Are you on a mac by chance? I use a mac and my chipset is something like that. Anyways, stuff works fine for me but I'm using xp. You could be looking at a hardware failure, as already mentioned, or maybe windows is just being buggy. The only way to really test the latter would be to wipe everything out and re-install windows....eeek!

michaelptrinh
24th September 2009, 08:12 PM
I have Vista Home Premium 32-bit version... no updates??? >:|

I'm not on a MAC. But I did reformat my entire computer this summer. I don't know if that eliminates the 2nd possibility or not =/

Emmett
24th September 2009, 08:50 PM
It says the latest drivers for your system would have been version 15.8.3.1504 released 7/3/2008.

Unfortunately, reformatting it over the summer, yesterday, or even earlier today doesn't tell us whether you have a buggy installation. There are a million things that could bug up your install. The only way to know for sure would be to wipe out windows after you run into a problem. But that's not probably something you want to do, and there's no guarantee that it will fix the problem.

HatCat
24th September 2009, 10:42 PM
In case there is still worry over the save files that has been fixed.
The crashes with plug-ins are usually more linked to other setups besides an OS version.

So in this filter, no updates?
http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Internet+Devices&ProductLine=Netbooks&ProductProduct=Mobile+Intel%C2%AE+945GM+Express+Ch ipset+Family
I am seeing four--all of which should be safe while being different versions.

michaelptrinh
25th September 2009, 02:02 AM
Hi--I updated my driver at the site you provided and then played through an entire MP3 game with savestating.

Pretty good! No crashes, errors, or recoveries. The performance is noticeably enhanced and some of the mini games that caused crashes previously no longer do so!

I also had Winamp off just in case.

HatCat
25th September 2009, 06:35 AM
So far as long as I've been careful about pinpointing driver updates, no negative side effects have happened. I didn't expect this time they would be that positive though from the sound of things.

Then let us know if you have some issues again.

michaelptrinh
27th September 2009, 03:22 AM
My roommate has a controller made by Cyvox that doesn't respond sometimes during gameplay while mine always does. Any idea what's going on and how do fix it?

HatCat
27th September 2009, 12:06 PM
Not from me, sorry
I just know from memory there has been frequent concern in product damage or durability, or even if you guys both use the same device some repair might be needed.

Don't take my advice on that though; I'm keyboard all the way.
The only time I was absolutely forced to not use a keyboard to play fair was the Saucer of Peril shooting mini-game in Banjo-Tooie, so I just did some memory compare so that I could hack the two-byte scoring system. I just set my score to 500 via memory editor, sat back and watched the rest of the boring mini-game fly, sit back and watch Banjo like he's on ecstasy.

michaelptrinh
3rd October 2009, 05:59 AM
Hi. I got another error called "Access Violation." It says "While processing graphics data an exception occurred you may need to restart the emulator."

Do you have any idea on how to prevent this "Access Violation" from occurring? Do you know what's causing it?

HatCat
3rd October 2009, 09:56 PM
Access violations are reported from the graphics plug-in. These actually prevent bugs, but the causes of course can be prevented as well.

In your specific case, the first idea I have in mind is save states.
If you have loaded from a save state, use it to save your progress internally so that you can restart Project64 and restore your progress without loading save states.

Fortunately, save states have virtually no chance of permanently destroying your progress, since changed memory is more than likely outside the range used by battery saves; it's just that, while we use save states for our convenience, once in a while we might have temporary disruptions.

kaneda
7th October 2009, 10:02 AM
To you PJ64. I tried downloading Goldeneye but it didn't work!!!!!! Why is this game not working?? Tell me what type of files I require for the PJ64 games to work please.:mad:

HatCat
8th October 2009, 12:12 AM
Emulators.

xst anger
16th October 2009, 07:43 PM
I'm trying to find my save folder for Pj64 so i can move my save game of Zelda Orcarina of Time so I can keep playing it. I originally dled it at school, and just emailed the save game file to myself. I have Windows vista, and the computers at my school run XP and i was able to find the save folder there. Any help would be great =)

HatCat
17th October 2009, 09:11 AM
try something like
C:\Users\[username]\AppData\Local\VirtualStore\Program Files\Project 64\Saves\....

jimmyle333
23rd May 2017, 12:39 PM
how do i find save states on project 64 2.0 i even checked on load files

ExtremeDude2
23rd May 2017, 02:00 PM
o dam that bump

DreadedGhoul575
4th September 2017, 09:08 PM
Anyone got that, fully complete/everything unlocked?

HatCat
4th September 2017, 10:36 PM
http://cxd4.github.io/saves/

ExtremeDude2
5th September 2017, 05:03 PM
thx m8, forgot about that