PDA

View Full Version : Problems with Rice Video plugin -- HELP!


JILost
8th October 2009, 10:16 AM
So I discovered this cool-looking "texture replacement" of Ocarina of Time and wanted to experience it. In the process of learning how to do so, I also discovered one for Legacy of Darkness. I can apparently either use Project64 or 1964 and either Glide64 or mudlord's Rice Video plugin.

Upon trying to load regular Castlevania (not LoD) in mudlord's thing just to test it, I get this:

http://www.purpleguppy.net/graphics/CASTLEVANIA-0.png

And similar in OoT.

Tried Glide64 but the plugin won't load for me, I guess because I never installed OpenGL.

Tried 1964. I got the same problem with Glide64 and the emulator won't even acknowledge the Rice Video thing.

I've tried every option I can think of in the Rice Video plugin to make the textures....make sense, or even have the 3D planes have anything to do with the stage layouts, but it's a no-go. Jabo's video thing gives very good results, but it can't re-texture with the texture packs I spent hours downloading. So the question becomes: a) what other plugin/emulator combo should I try, or b) what the hell is wrong with the Rice Video thing on my system that's causing the unplayable texture randomness and what setting(s) do I change to fix it? I tried the "DX9" version as well, but when I load a game, I get sound but a completely black screen. The only time I get a picture is when I switch to full screen and then hit Esc to switch back -- I get the actual picture for the second between hitting Esc and the screen changing res, but then the PJ64 window is black again afterwards.

It really should not be this hard or this painful to play Castlevania and Zelda. At all.

HatCat
8th October 2009, 03:23 PM
What graphics card, drivers and driver versions are you using?
What version of Windows you use?

Try the 6.1.0c stable version Rice released before?
Did you get an error or something when checking Glide64?
Why doesn't the plug-in show with 1964 now?

JILost
8th October 2009, 05:53 PM
Such obvious questions I didn't answer. I guess that's what happens when one posts something at 6am after not sleeping.

1. ATI Radeon X1800 GTO
2. To the best of my knowledge, whatever drivers came with the card. My friend set the computer up for me.
3. Device Manager says 8.421.0.0, 9/28/2007. Probably ought to update that if possible.
4. XP SP3

5. It didn't occur to me to use an older version of Rice. One or the other of the texture packs said to specifically use that version since it allowed 4x texture size.
6. Yes. First it said glide3x.dll was missing, so I got that from one of those dll download sites. Now, when I try to Configure Graphics Plugin with Glide 64 selected, PJ64 crashes.
7. I'd like the answer to that question as well. It's not even showing in 1964's plugin list, though Glide 64 is and every other plugin shows in both emulators, so they're clearly "seeing" the same folder, etc. Mysterious.

HatCat
8th October 2009, 06:52 PM
In this case there would be a few many more questions before doing this, but indeed updating your drivers is a good idea.
You can do this through support site.
http://support.amd.com/us/Pages/AMDSupportHub.aspx

6.1.0c is uploaded here if you want to try this version. As for the larger textures, possibly those might be in use for the ones you download, yet it's important to trace where any problems lie first.
http://www.emutalk.net/showthread.php?t=26229

GLIDE3X.DLL, the binary of this file you want should be bundled with an official Glide64 archive. You want the file from within the compressed archives that you could download here.
http://glide64.emuxhaven.net/

Hopefully some of this will be off to a start.

squall_leonhart
8th October 2009, 11:22 PM
ugh.... i don't help people who can't fucking read the documentation that comes with plugins.