PDA

View Full Version : PJ64 1.6 Issues with Newer Plugins and Newer FAQs


LReyomeXX
8th October 2008, 08:16 PM
Im having issues with PJ 64 v1.6 being able to recognize the new Glide64 plugin, as well as the latest version of NRage's Direct Input. Everytime I start PJ64 up after I selected Glide64, it gives me errors saying unable to find glide64.dll and glide3x.dll even though they are both in the Plugin folder. It did the same for NRage's Direct Input latest version, even though the DLL is also in the Plugins folder.

Also, the newest PJGameFAQ has 'Unable to display the webpage' all over the place and I cannot seem to fix it.

I don't see how 'reinstalling the program may fix the issue' is going to work unless I am being forced to accept the default ones that came with PJ64 1.6 bundle in the first place.

Smiff_
8th October 2008, 09:57 PM
these plugins need the extra .dlls in the Project64 root folder (alongside Project64.exe)

@zilmar.. could you make the app also check the plugin folder for dlls - or not possible?
this has got to be the #1 support request of all time

for the GameFAQ.. not sure, works ok for me when i just downloaded it.. try resetting your Internet Explorer settings please (Control Panel > Internet Options, security and privacy default, maybe some other settings too, anyone know?)

mudlord
8th October 2008, 10:07 PM
@zilmar.. could you make the app also check the plugin folder for dlls - or not possible?
this has got to be the #1 support request of all time

I honestly don't see the point of zilmar having to handle DLL loading when the Windows DLL loader handles that.

I personally think this issue all comes down to end user stupidity. Either read the plugin's documentation (its all explained in there for Glide64) or.....:rolleyes:

zilmar
8th October 2008, 10:07 PM
I could walk the import table .. see what it links to and if it exists in the plugin dir move it to the .exe dir.

mudlord
8th October 2008, 10:10 PM
Sounds neat, but I really have to wonder: why go to that effort when the end user should know a thing about how Windows expects to load its DLLs (either from

A) application directory
B) paths specified in the PATH environment variable)

zilmar
8th October 2008, 10:40 PM
tho in 1.7 we do not show the error with the missing dll. We just do not show the plugin.

squall_leonhart
8th October 2008, 10:47 PM
Nrage plugin requires MSVC8 runtime files

Smiff_
9th October 2008, 07:12 AM
1.7 has the extra complication of loading plugins from sub-dirs.
i realized after posting this is an OS task not for the app.. but some solution would be really useful for people.. not sure if non-admin accounts could cause moving .dlls to fail.. though we still assume full control of appdir which is whole other can of worms.

how about (on each app start)
1) make list of plugins which failed to load (if none skip rest)
2) check those plugins' dependencies
3) search for that .dll in pj64 app dir + all subdirs
4) prompt user something like "x plugin failed to load. it appears to need y.dll.
- if required .dll was found, offer to copy to appdir
- if required .dll was not found, just tell user y.dll needed. could even send it to google with default browser :p
5) prompt user e.g. "restart app to initialise new plugins"

its kinda nasty, but anyone got better ideas?

squall_leonhart
9th October 2008, 12:54 PM
i was wrong anyway, nrage v2 needs msvc7 runtime which is in .net 1.1, msvc71 is in .net 1.1 SP1, its not easy to find the full run time installer these days, so just install .net 1.1 and it should fix it.

HatCat
11th October 2008, 01:54 AM
The GameFAQ CHM issue relates to legend's not being able to view my older CHM files for a support project, but evidently Project64's CHMs were loaded. Eventually on Windows Vista things got worse, and I made up for that by switching to PowerCHM and compiling with some special settings like the index table generation. The file size bumped to hell but it loaded.

Also the version tag (one to three) of the CHM file might be related?

Smiff_
11th October 2008, 02:00 AM
ugg.. is there an unofficial GameFAQ going around aswell? or is the starter referring to the latest official? i built those files included with PJ with the old microsoft utility HTML Help Workshop, always seemed to work (may not have been this version):
http://www.microsoft.com/downloads/details.aspx?familyid=00535334-c8a6-452f-9aa0-d597d16580cc&displaylang=en

HatCat
11th October 2008, 02:03 AM
Likely not what you have in mind.

There is an online list supporting multiple emulators and a CHM project doing the same but nothing for Project64 in particular or in the same format for what I've seen.

squall_leonhart
12th October 2008, 01:47 AM
ugg.. is there an unofficial GameFAQ going around aswell? or is the starter referring to the latest official? i built those files included with PJ with the old microsoft utility HTML Help Workshop, always seemed to work (may not have been this version):
http://www.microsoft.com/downloads/details.aspx?familyid=00535334-c8a6-452f-9aa0-d597d16580cc&displaylang=en


i am NOT laying claim to that one O.o