PDA

View Full Version : L and R/ Z and R problem


X 7734
11th December 2009, 02:56 PM
In my games, i am unable to perform actions that require the pressing of the z and R buttons simultaneously. Pressing one simply cancels the action of the other. For example, pressing Z and R simultaneously as the land master in starfox should cause it to lift into the air, but instead it simply shuts off the thrusters, such that if i was strafing using R and tried to fly with Z, the R function would simply cease. what is causing this, how do i fix it? it happens in multiple games so i know it isnt the starfox.

Excuse me, I posted this in the wrong section. I dont have the BETA i have the public version. If an administrator could please move this thread , many thanks.

squall_leonhart
12th December 2009, 12:24 PM
Let me guess.

Xbox 360 control.

X 7734
14th December 2009, 03:42 PM
yes i am currently using an xbox 360 controller because when using the keypad, nearly none of the buttons worked in tandem, most specifically "z" and "A" so if your solution is to simply use my keyboard instead, i would be unable to shoot while strafing, unable to jump while blocking, generally unable of movement while defending, and a slew of other incapabilities in every game. so i think it might be easier to just try and deal with z and R not working; one problem is much easier to solve then hundreds.

Furgelnod
14th December 2009, 06:18 PM
When using the Xbox 360 controller with the emulator you're better off to use the XBCD drivers rather than the ones Microsoft installs (this has been mentioned on the forums). MS's driver maps the left and right triggers to the same axis, so holding both triggers makes neither work, also rumble doesn't work in PJ64 unless you use XBCD.

By the way use the link in Squall_Leonhart's signature to get the most recent version.

X 7734
14th December 2009, 07:14 PM
thank you, but windows 7 wont allow xbcd to install because it isn't signed. I have however found another solution, thank you for your help though.

gitech001
31st December 2009, 02:44 PM
What was you're other solution?

squall_leonhart
31st December 2009, 03:01 PM
Failing at life was his solution.

i run xbcd on win7 x64 just fine, by disabling that shitty signing requirement.

gitech001
31st December 2009, 03:24 PM
:D Thanks squall.