PDA

View Full Version : Turok Dinosaur Hunter


Induna
16th October 2008, 01:12 PM
Hi, I was playing Turok using PJ64 v1.6. Great emu but a few problems I've found.

The game was playing flawlessly until it hit level 3 in the game. When I came to a switch guarded by a campaigner that lowers a set of large stone blocks to reveal an underground passage way underneath the temple. The game constantly froze. I tried it numerous times but it always froze at that point. I did however manage to get past by hitting the switch then running away from that area until the large blocks had finished lowering. Have you come accross this before?

Also, when you die (ie. fall off a ledge) the death sequence of Turok falling and screaming to his death fails to kick in and you get a black screen with the sound still playing. This happens now and again but it can be annoying.

Lastly in the hub area of the game with the archways to each level. Level 4 The Ruins doesn't seem to work at all. The screen goes bright white as you enter through the archway but then freezes. Is this a known bug or is there a workaround for it?

System specs if you need them, AthlonXP 2800+, 1.5GB memory, ABIT Siluro FX5900 OTES 128MB (I know, crap).

Thanks.

HatCat
17th October 2008, 12:38 AM
Update the RDB file.
http://www.pj64-emu.com/downloads/project64/updates/

The instability you described obviously refers to the known compatibility issues in the core. If the update doesn't work try:
Right-click the name in the image browser, Edit Game Settings..., set the core style to "Interpreter"

Induna
18th October 2008, 03:01 PM
Hi. Yeah I already installed the update files before I played Turok.

I'm confused about the right-clicking in the image browser you mentioned. Do you mean when you search to the folder with roms in then right-click on the rom you want to play? I didn't see "edit game settings".

HatCat
18th October 2008, 04:00 PM
When you start Project64 there may be a list of games installed.

File > Choose Rom Directory...
Project64 will list all games installed in the folder you choose there. Pressing F5 updates changes in the image browser.

If Turok is listed there you want to right-click that and then choose "Edit Game Settings...".

Induna
20th October 2008, 06:35 PM
Ah, I found it. OK I changed core style to interpreter and no luck, still the same problems. I tried default as well.

Do you get this problem too? You can easily test this by using the cheat menu and try and warp to level 4. All the levels work except 4. I've been playing level 5 and 6. On 5 when you pick up the last key towards the end of the level you get the black screen and when you try to exit level 6 by the end portal it freezes again.

Induna
28th October 2008, 02:07 PM
Well I tried playing this on another pc with a different graphics card. Still cannot access level 4. Can anybody else confirm this? Perhaps it should be mentioned in the compatible list?

next
12th November 2008, 02:39 AM
Well I tried playing this on another pc with a different graphics card. Still cannot access level 4. Can anybody else confirm this? Perhaps it should be mentioned in the compatible list?
you had a misspelling not compatible compatibility list

jasongleonard
18th January 2009, 04:22 PM
I have the same problem. Everything was fine until Lvl 3. I've reloaded from earlier parts and it happens in all different places in lvl 3.

Just freezes up.

I've switched the core mode to Interpreter and it doesn't seem to make a difference.

I'm using the latest version of p64.

HatCat
18th January 2009, 04:55 PM
Sorry for not getting back to this earlier. I will have to find a way through this game, as I'm not familiar with it.

The game simply freezes with display still on screen and no errors printed and the like? In the mean time there is a sign...that if you pause emulation (F2 shortcut works.) and then unpause it (F2 again) this might actually work, but it may just as likely have more to it than that.

squall_leonhart
18th January 2009, 08:11 PM
change counterfactor to 1, set memory to protect and cache.

chri5
11th April 2009, 03:37 PM
Got the same problem here, Turok level 3 freezes up. Tried on a few different PCs but still the same. :(

HatCat
11th April 2009, 07:27 PM
Can you upload a save state so either me or squall can verify the settings? If the prediction was known an update to the RDB file could be made for an immediate download, but neither of us have time on hand to navigate this game.

chri5
12th April 2009, 05:49 PM
If no-one beats me to it, I'll try to get a Turok save state uploaded.

HatCat
12th April 2009, 06:51 PM
Thanks for the time!

If someone can get a save for us please answer again.

chri5
13th April 2009, 09:02 AM
Current Save State for Slot 3: http://drop.io/turoksave3 [This is the one where the game has frozen.]

Current Save State for Slot 2: http://drop.io/turoksave2 [This is the save state about 5 minutes playtime before the freeze.]

HatCat
13th April 2009, 11:57 PM
The first save state you uploaded is perfect.

I have noticed that the counter factor modifier does actually help delay or instantiate the hang in memory, but the only consistent configuration seems to use the interpreter.
No RSP configurations or other factors not disregarded by the main memory interpreter's use (like TLB, memory size, anything else) seem to affect this.

Choose "Settings..." from the menu "Options".
Make sure advanced settings are not hidden (from tab "Options").

If this is applied then right-click the Turok game, and choose option "Edit Game Settings". Set the option "CPU core style" to "Interpreter".

This is as far as the configurations for the public versions go. I will look into some of the new options and the automatic core in the beta emulator shortly and notify if I find anything else new.

The save state given here is rather valuable. This, the save state e-mailed to me about the Perfect Dark inevitable hang (even with the interpreter), and the similarly inevitable crash in loading the "City of Walkways I" level in TWINE 007 are a strong collection. I'm going to nag around a bit in the alpha testing group to see if some one cares.

--Update
This specific case was internally fixed in beta development, so donating would be an alternative preserving the speed lost in interpretation. The other two remain absolute.

chri5
14th April 2009, 11:46 AM
is Level 4 is playable in v1.7? If you open all the portals with the cheats and walk through the Level 4 portal as mentioned earlier in this thread it's just a white screen with noise. (also happens if you play the game properly.)

HatCat
14th April 2009, 09:21 PM
I either need instructions to access level 4 or another save state, but for now the interpreter setting covers the crash problem you sent.
It even helps some effects of cheat risks, but using cheats is always risky. If the later issue you specified still happens without cheats, please send me instructions or an appropriate save, and I will test this also.

Thanks again.

Dan Smith Klaine
27th July 2010, 03:34 AM
I don't know if this thread is still active but i would reply to rswedlow ask about a proper save for test. As you can see, the file "Turok In-Game Save" is the file used by the Memory pak of the N64 system, and the other "Turok - Dinosaur Hunter (U) (V1.0).pj" is the emulator restore point, both are just in the point of the entrance to Level 4 - The Ruins. I got here without any cheats or codes. You just have to go trough the portal, but beyond that the screen will go blank and the sound still can be heared. Of course i changed the option of "Interpreter" at the CPU Core Style, and i went through Level 3 just fine (none crashes).

HatCat
27th July 2010, 04:16 AM
Got the saves archived just in case.

Yeah this game needs the interpreter with Project64.
With 1964 there is a more secure re-compiler setting, but I don't know anyone who's tested the game through on 1964. However it's more secure than memory protection on Project64.

ShaddowT
2nd August 2010, 07:34 AM
I have one and only one complaint (so far) and that is that the camera needs to be move about 10 inches back it wasn't like this on the Nintnendo 64 but you walk up to a wall and you can see your enemies through it or if your clibming a wall and enemies are supposed to surprise you you can see them before you reach the top..through the vines.

squall_leonhart
2nd August 2010, 07:56 AM
it was like that on the 64.

ShaddowT
2nd August 2010, 08:00 AM
really????I never ever ever had that issue I would never see through walls....

HatCat
2nd August 2010, 07:30 PM
Try Direct64 for the graphics plug-in, just to test the walls how you could see through them earlier.
http://www.emutalk.net/showthread.php?t=26677

xlleimsx
19th December 2010, 08:42 PM
I just wanted to give this thread a bump and follow-up since it's the only source of information regarding this particular problem while trying to emulate Turok.

I had the very same problem and got tired of tweaking the preferences of both the Graphic's plugin and the emulator preferences. The problem here is not the emulator, it's the ROM itself. Apparently the American version of this ROM (U) is the very same for each and every single rom site you try to download it from, and unfortunately it is a bad dump.

If you try the European version (E) you won't get stuck anywhere in the game ;).

Hope this helps anyone looking for a solution for the problem :D.

HatCat
19th December 2010, 11:21 PM
I would also change the plugin. Otherwise there is no proof of what kind of dump.