PDA

View Full Version : Graphics problem in Zelda: Ocarina of Time


Brassenaurian
31st October 2008, 02:10 AM
Right, so I'm having a slight problem with the graphics in OoT. It's nothing major, but it's (to me, at least) somewhat irritating. Certain textures like to do a vanishing act when I get close to them. It happens mostly on "road" textures such as the road in Hyrule field and the stone path in the Kakariko graveyard, but it also occasionally happens on climbable walls. It's that last one that's the real problem.

I can (generally) see the texture just fine from a distance, but as soon as I approach, it flickers out. If I use the "L to levitate" cheat and get high enough, I can usually see the textures from above just fine, even if I couldn't see it at all from the ground.

I'm not entirely sure, but it looks like it only happens on textures that are sort of on top of other textures. I say that because the texture of the rest of the area (that is, the surrounding ground or wall) shows up when the other one vanishes. Again, I don't know if that means anything or not.

My computer has a decent graphics card and all the drivers are current, so I don't think that's the problem (though it could be). I've also tried just about every configuration I could think of with the Jabo plugin. I just can't get it to work. I really hope somebody here has an idea of what could be the problem.

If you need any more information, please tell me so that I can find it. I'd really like to get this problem resolved.





EDIT: I forgot to mention this before, but this problem also happens in cutscenes when the camera gets near one of the vanishing textures. That is, when the camera gets to a position similar to the "normal" one.

HatCat
31st October 2008, 05:31 PM
Options > Configure Graphics Plugin...
Will return your supposed graphics drivers name in blue text

In the meantime you can also try using Jabo's Direct3D6.
Options > Settings...
To change plugins e.g. graphics

Brassenaurian
31st October 2008, 05:58 PM
I've tried using several different plugins, including:
Tr64 OpenGL 0.8.8
glNintendo64() 0.4.1
Rice Video plugin 6.1.4
TR64 OpenGL 0.8.8
and the one that I'm currently using,
Jabo's Direct3D 8 1.6

All of them have had issues, and the one that works the best is Jabo's. The older version, which you mentioned, doesn't display the "vanishing" textures at all, no matter where the camera is. I've used the config menu and the advanced settings with all of those; trying dozens of different combinations of settings and all to no avail. I can make the problem worse, but I can't seem to make it better.





Also, this is probably going to sound stupid, but I'm afraid I didn't quite catch what you were getting at when you said:
" Options > Configure Graphics Plugin...
Will return your supposed graphics drivers name in blue text"
Could you please rephrase that?

HatCat
31st October 2008, 06:46 PM
I actually want you to test Jabo's Direct3D6 1.5.2 as opposed to Jabo's Direct3D8 1.6. It's an older version supplied with Project64 1.6 known to work better with older cards...which evidently you have judging by the instances of issues you mentioned. Some of those things were specifically reported by older cards.

In Project64 1.6
Options menu
Choose "Configure Graphics Plugin..."

There should be blue text at the top-left of the dialoge that comes up. This is the label I want...unless it isn't there?

Brassenaurian
31st October 2008, 07:22 PM
The blue text that you're talking about? I'm afraid it's absent.

I believe there's a way to lookup what graphics hardware I have using the System Information function of Windows. However, I'm not entirely sure what I'm looking for. I checked under "Display" and it said something about chipsets, but not graphics cards.
I'm pretty certain that I do indeed have a graphics card, seeing as how one of my computer programs likes to complain about it. Though, I suppose that particular program could have no idea what it's on about.



I tracked down (either I got rid of it at some point or I just plain didn't get it when I got the latest version of the emulator) and tested Jabo's Direct3D6 1.5.2, but it seems to have made the problem worse. Under every config I can think of, one of two things happens:
The texture never shows up at all, no matter where the camera is
or
The ground where the texture is supposed to be flickers for a second, as if the texture is going to appear, but it apparently fails.

Interestingly enough, that plugin DID fix the wall version of the problem. In Jabu-Jabu's Belly particularly, there were quite a few climbable walls that weren't showing up as such. Now, they all seem to be in order. It's just the ground that's out of whack.

HatCat
31st October 2008, 08:45 PM
You probably have an integrated chip.

The older plugin version will support older chips but does have some problems fixed in the Direct3D8 version. For this reason it's more sacrificial.

If you have WinXP you can probably go Start, Run... and enter "dxdiag" to run a DirectX diagnosis. Should give info like your version of DirectX, your graphics drivers, etc.

squall_leonhart
31st October 2008, 09:51 PM
the graphic hardware suchs, thats what the problem is. if the Dx6 plugin doesn't even work, then its a worse pos then can be possibly thought.

HatCat
31st October 2008, 10:13 PM
I forgot in Direct3D6 plugin the text is not blue; it's labeled "Video card". In Direct3D8 plugin it is blue.

I'm guessing you have an Intel graphics card; OpenGL plugins like glN[intendo]64 won't work well with those for the most part.

Brassenaurian
1st November 2008, 01:18 PM
Okay, I found the Video Card text, and it does indeed say "Intel", but I couldn't see most of the name. It trailed off and I couldn't seem to resize the box either.

So, I ran the DirectX Diagnostic. I'm on Vista, but it works the same way as it did on XP. I know this because I've had a couple of DirectX issues in the past. (I'm starting to think this system just really, really sucks from a graphics point of view)

It seems that I've got DirectX 10 and a "Mobile Intel 965 Chipset Family." The "main driver" is something called "igdumd32.dll" and I know it's current, because the first thing I did when I noticed problems was update my drivers.



...It's kinda looking like my hardware just won't do it, isn't it? Well, if that IS the case and there's just no way to fix it with my current setup, is there any way that I could install different hardware that might fix the problem? My computer is a laptop, (well, actually, it's a notebook) which I know might complicate things.

HatCat
1st November 2008, 03:44 PM
That is the easiest and most common response: Update your video hardware. In part I don't like saying it because for one thing I've never worked with hardware...only software. I am happy to find the opportunity to see compatibility on a low-end system.

Now OpenGL is rough so far that I've seen on Intel cards, so instead of glN64 there is a DirectX plugin based on it by the same author. May I direct you to Direct64?

Brassenaurian
1st November 2008, 04:00 PM
I'm more experienced with software than hardware as well (which should tell you just how UNexperienced I am with hardware!) and would also rather find a way to "make it work" than to upgrade the hardware.

Now, I tried the Direct64 plugin and - hallelujah - it seems to be working! Thank you so much! Thank you! I know it was a fairly minor issue, but I'm so pleased to get it resolved!

HatCat
1st November 2008, 04:03 PM
I ought to spend more time getting that to work on older systems using Intel cards then since there's some trouble just loading it.

Glad we could help each other out!

pablovonn
7th November 2008, 08:03 AM
As an aside here as far as compatibility with older systems and integrated graphic chips . . . . .

Ive been using P64 for a while now and randomly I would get these annoying messages saying that the graphics plugin has encountered an exception and that the emulator may need to be restarted.

This sort of thing happened just every now and then . . . . but sometimes would just freeze the system up. So, being internet savvy I came and found this here forum and searched up and found this thread.

Like I said earlier I am running with an integrated vid chip, which I know (from the business Im in) is garbage. After reading this thread, the first thing that I did was change to the older Jabo plugin (from 8 to 6). And so far it is working great.

Ive noticed the quality is not quite as sharp . . . . but I understand that I am limited by hardware. Out of curiousity (and a innate need to tinker with things) what is this other plugin you were talking about? The "Direct64" ?

Anyway, thanks for the help Iconoclast, you solved my issue here before I had the time to make a dedicated thread.

Smiff_
7th November 2008, 08:29 AM
Direct64 is a 3rd party plugin (this means its made for PJ64 but we dont support it)
http://www.emutalk.net/showthread.php?t=26677
you can download it there, this version is approx 3 years old i dont know if there's a newer build?

there is a quote from Clements thats interesting:
"I strongly doubt it will work with that particular Intel video controller. In terms of Intel graphics, Direct64 is only known to work on the very latest GMA variants that have DX9 hardware support."
make of that what you will, sorry i dont have any Intel hardware (except the eee, which runs linux :)) nor do i have time to try 3rd party plugins atm.

Smiff_
7th November 2008, 08:33 AM
just to be clear.. not supported means if you have problems with Direct64 please post over at EmuTalk (where the author is, or was) not here!

pablovonn
7th November 2008, 07:09 PM
Eh, thats fine. Im doing great with the older version of the Jabo plugin. I was just curious.

HatCat
8th November 2008, 12:24 AM
Obviously Clements's doubt doesn't apply here; that's what I thought at first until this thread and trying it out on another Intel.

nationalhonorroll
9th April 2012, 03:13 AM
I'm having the exact same problem and project 64 seems to reject both the direct 64 and glide 64 plugins. any advice? i would very much like to resolve this minor but highly disruptive issue.

Witten
9th April 2012, 06:57 AM
The problem here was with an Intel integrated video card here and may be unrelated.
So create a new thread for your problem and include your computer specs, most important is your video card.