PDA

View Full Version : Frequent stutter


squall_leonhart
8th August 2010, 01:25 PM
noticed this while on the zelda main menu, its less obvious in game when the fps is only 19/20. but yeah, the fps will randomly and frequently dip and stutter, and this is with audio sync enabled.

pj64 is the only emulator i can reproduce this in, it might possibly be thread safety or something jumping between cores, i dunno.

Bino5150
8th August 2010, 04:30 PM
I get this too when playing Zelda OoT on 1.6 and sometimes it will even get so bad for a second that it will bog down a battle... but going to the start menu, and a lot of times talking to people, acquiring new items, cut scenes, etc... will cause the stutter... the rest of the time it's pretty random, however it's pretty consistent in it's occurance.

In the settings, my fps is limited to the speed of the n64, however, the game still seems to be running between 50 and 60 fps according to the meter at the bottom of the emulator window...

I'm also getting a total crash when I go into the weapons shop in the Kakariko village.

Compaq Presario laptop, AMD Mobile Sempron 3000+ 1.8GHz, 512mb, ATI Radeon Xpress 200M, WinXP SP3

Rom version: Legend of Zelda, The - Ocarina of Time (U) (V1.0) [!] from doperoms

P.S.- I'm using the default plugins

EDIT: OK, so I tried the updates... the 1.6.016, and then the emutalk 4.18

It SERIOUSLY helped with the stutter in the game. It runs a lot smoother. Still @60fps, so I'm guessing if it slowed down a bit the the stutter might go away completely. Still have the crash in the weapons shop though... posted in a thread regarding the crash... I don't know about the 1.7 beta, but whatever they changed in those 1.6 updates almost totally fixed the problem.

squall_leonhart
8th August 2010, 06:54 PM
rswedlow, any RDB idea's?

HatCat
8th August 2010, 09:44 PM
Yes right I see it's an RDB issue.

Heh actually at first when testing I forgot to turn off the RSP interpreter, and when the VI/s was like 40-50 the FPS was more dynamically fluctuating. After I set to RSP re-compilation with audio synchronization still in-tact I only had 55-60 range variance of FPS.

Then I set ABL to on, memory protection, use TLB and CF=1.
I've isolated the cause to ABL. Set it to off.

Funny you should mention this cause I just remembered a few months ago I kept getting interrupts against doing vertical interrupts / stutter pauses with this game till I turn off ABL, good to get a reminder of this. It was at the beginning of testing, so I guess I forgot to note it in my RDB findings thread.

Now I remember, if you have ABL on AND protect memory, then this happens. Just don't have both.

squall_leonhart
9th August 2010, 04:31 AM
Protect memory increases the rate, however, the issue seems to be Fixed audio timing.

With it on, the FPS remains at 20 steadily and when it does drop to 19.9 or 19.8 the stutter appears.

with it set to off, the fps fluctuates between 19.4 and 19.9 and no stutter.

Bino5150
9th August 2010, 07:20 AM
I also noticed that if I uncheck the Limit FPS option, it winds up all the way to 80+ fps and the glitchy stutter becomes really bad.

@Squall, how did you scale back the fps to 20? I'm new at this emulator thing, and I don't want to go messing with settings unless I know what I'm doing lol...

squall_leonhart
9th August 2010, 07:58 AM
the fps of zelda is 17 or 20fps by default. the VI's go up to 60.

HatCat
9th August 2010, 06:48 PM
I notice that fixed audio timing keeps the frame rate range down but not any kind of stuttering. Also tried turning on and off some of the other options while still using audio sync and Glide64 yet haven't heard any stuttering in the file select menu.

I guess it might have been a separate system issue.
I noticed for me that ABL turned on somehow conflicts with memory protect here.

squall_leonhart
10th August 2010, 02:46 AM
fixed timing keeps the fps up, not down.

HatCat
10th August 2010, 03:20 AM
Range, one context, isn't a very algorithmic term, in which it refers to the difference between the maximal and minimal extent of a measurement (e.g. FPS).

So basically I said how much the FPS varies, rather than FPS itself.

Bino5150
30th August 2010, 03:07 PM
So how do I adjust the fps?

HatCat
30th August 2010, 04:18 PM
Frame rate is defined by the game.

You can always adjust VI/s measure as a coefficient.

n64mischiefmakers
6th October 2010, 10:35 PM
So has anyone figured out a real resolution to this? I get this same frequent stutter in every game I've tested. It's every few seconds, and its a sudden, sharp FPS drop. Specs aren't possibly the problem, AMD 6000+, 8600GT, 4GB DDR2800, I'm running on Windows 7 32bit Ultimate with PJ64 1.7.0.49. Any help is appreciated, thanks.

HatCat
7th October 2010, 05:20 AM
The stuttering here was caused by advanced block linking with this game. The issue was fixed by turning it off.

Apparently there are also other re-compiler configurations you can set to control it.

squall_leonhart
7th October 2010, 07:25 AM
So has anyone figured out a real resolution to this? I get this same frequent stutter in every game I've tested. It's every few seconds, and its a sudden, sharp FPS drop. Specs aren't possibly the problem, AMD 6000+, 8600GT, 4GB DDR2800, I'm running on Windows 7 32bit Ultimate with PJ64 1.7.0.49. Any help is appreciated, thanks.

its your cpu.

either install the dual core optimiser, set affinity to a single core or set windows to high performance power profile.

n64mischiefmakers
6th January 2011, 12:00 PM
I tried all those, it reduced the stutter very slightly, but its still painfully noticeable and it pretty much happens just enough to completely ruin the overall gameplay. I really hope there is some solution...

HatCat
6th January 2011, 06:55 PM
Meaning you tried the RDB controls (inclusive of ABL modifier), squall's core performance optimizations, and possibly a third-party sound plugin for testing?

n64mischiefmakers
7th January 2011, 11:45 AM
Please explain a little more, this emulator isn't my life. I've tried turning advanced block listing on and off, with three different sound plugin settings. standard jabo, 3rd party, and no sound. As far as squalls performance mods, I installed the dual core optimizer, set to high profile, and I've tried on interpreter, recompiler, and synchronize cores. The results more or less don't matter though. Some settings produce a good frame rate, some don't, but even with the settings on the most optimal, I still get terrible spikes. If it's any help at all the r4300i percentile is spiking pretty bad each time, everything else stays pretty normal. If you can explain what RDB controls are or maybe just what I need to check or uncheck I'm happy to do that as well.

HatCat
7th January 2011, 09:18 PM
standard jabo, 3rd party,

I didn't mean settings for Jabo's sound plugin, just to try others that weren't included.
Did you test Azimer's HLE sound?