PDA

View Full Version : Project 64 1.7 Controller not working


CodeBrain
25th February 2011, 06:19 PM
Well, for some reason on PJ64 1.7, my xbox 360 wired controller doesn't seem to do anything when a rom is loaded. None of the buttons when pressed do anything to the game loaded. However, going into the controller plugin (N-rage 2.0 or something) and setting the actual buttons work just fine (Example, I try to set the A button for the emulator to the A button on the Xbox 360 controller and it recognizes it), and if I go to another emulator, say Mupen64k, the controller works just fine, I can press anything and the game responds.

Using the most updated Project64 1.7 for this.

Edit: Oops, this is meant to be in the Issues forum, not Suggestions, can someone move it? Sorry about that!

HatCat
25th February 2011, 11:05 PM
So are you saying N-Rage's works just fine, just not Jabo's DirectInput?

CodeBrain
26th February 2011, 02:51 AM
Whoops, this is N-Rage I am talking about, I haven't tried Jabo's plugin yet. Ill do that right now.

Edit: I'm getting on Jabo's 1.7 plugin for my 360 controller: "DirectInput: Failure to initialize joystick" and it cannot be selected. Jabo's 1.6 plugin does the exact same thing.

1337
26th February 2011, 03:03 AM
Which version of N-rage are you using?

If you are using the v1.8 or v2.0, click the link in my siggy for the latest version.

CodeBrain
26th February 2011, 03:32 AM
Which version of N-rage are you using?

If you are using the v1.8 or v2.0, click the link in my siggy for the latest version.

Version 2.0 is what I am using.

squall_leonhart
26th February 2011, 06:07 AM
try 2.2.

also is plugged in checked.

CodeBrain
26th February 2011, 06:31 PM
try 2.2.

also is plugged in checked.

Where would version 2.2 be? If your talking about the one in 1337's sig, that's the one I am using. Otherwise I haven't heard of a 2.2 version.

And yes the checkbox for "plugged in" is checked.

Edit: According to the actual link in his sig it looks like it's version 2.0 instead of 2.2, so I don't know...

Natch
26th February 2011, 06:36 PM
Nrage 2.0 V2.20

As found in a earlier thread (http://forum.pj64-emu.com/showthread.php?t=1527)on the same subject.

CodeBrain
26th February 2011, 07:37 PM
With v2.2 it seems to be working now.

The previous versions on 1.7 were working until the last time I tried it, so I have no idea how that happened...

Anyway thanks for the help guys!

HatCat
26th February 2011, 09:49 PM
Might have been configuration settings, though don't know what specifically.

CodeBrain
26th February 2011, 10:29 PM
So, now I have a new problem, has nothing to do with the N-rage plugin this time.

Basically, when I was having this issue earlier, I was playing N64 games using Mupen64 (another N64 emulator, if you never heard of it) and now that I have this issue fixed (thanks to you guys!) I wanted to move back to Project 64 1.7.

Now, when I was playing games using Mupen64, I made some "significant" progress in several games (Mainly Mario Kart 64, Ocarina of Time, and Starfox 64) and I know that both Project 64 and Mupen64 use different save filetypes (Project 64 uses .fla or something and Mupen64 uses .eep)

The question I have is: Is it possible to take a Mupen64 save and turn it into a Project 64 save? I tried just changing the file type of the Mupen64 saves into .fla, and named the save after the games internal name, but that doesn't seem to work. Any idea how I would go around doing this? I really don't want to have to start all over again...

Natch
26th February 2011, 11:31 PM
Are the Save states different? If not you can just use them.

Oh and mupen diaf.

squall_leonhart
27th February 2011, 03:02 AM
savestates are definitely different.

Natch
27th February 2011, 03:02 AM
note taken.

CodeBrain
27th February 2011, 08:20 AM
So let me guess this straight then, it isn't possible to convert the saves then?

dsx_
27th February 2011, 09:39 AM
dont mind them, youre not using savestates

fla and eep are just different types of saves used by different games. the saves are interchangable between mupen and pj64. other save types include sram.

HatCat
27th February 2011, 07:21 PM
Save data is easily ported between both emulators.

You shouldn't have FLA for one game on pj64 and EEP for the same game on Mupen64 though, cause that would mean Project64 was configured to use the wrong save format or something. Just copy the save file over then rename it accordingly.

draumur
4th March 2011, 10:03 AM
i have the free version sooo 1.6 and i have the newest nrage plugin, but when i go to use the xbox's control scheme it doesnt seem to save the setting so when the game starts it has no controls set up. its rather weird to me.. whyy??? im using a madcatz xbox 360 wired controller and its recognized by windows and project64

squall_leonhart
4th March 2011, 12:32 PM
because 1.6 saves to the registry, while nrage 2.x moves the configuration to a settings file.

Natch
4th March 2011, 03:37 PM
you must set the controls yourself, specify that it's an XBOX 360 controller, check plugged, and click save.

1337
4th March 2011, 08:01 PM
If you sure you are using the latest n-rage version, just to be sure click the link in my siggy.

To get the controls caaaaaaaaallllllllllllllllliiiiiiiiiiiiiiiiiiibbbb bbbbbbbbbbbrrrrrrrrrrrrrrraaaaaaaaaaaaattttttttttt ttttttteeeeeeeeeeeeeeeeedddddddddddddd properly, go to the link in my siggy for xinput and select your OS version.

Natch
4th March 2011, 08:33 PM
*twich

did someone say calibrate?

HatCat
5th March 2011, 03:00 AM
Yeah if you're using the 2.2 beta version squall's hosting it should use local INI configuration.

1337
5th March 2011, 04:15 AM
*twich

did someone say calibrate?

I just had to..........

HatCat
6th March 2011, 04:06 AM
IDK man, it looked a lot more like caaaaaaaaallllllllllllllllliiiiiiiiiiiiiiiiiiibbbb bbbbbbbbbbbrrrrrrrrrrrrrrraaaaaaaaaaaaattttttttttt ttttttteeeeeeeeeeeeeeeeedddddddddddddd to me.