PDA

View Full Version : OoT texture problems with Geforce 4


emcee
22nd December 2008, 04:20 AM
I've been working on a a sort of dedicated gaming computer that connects to a TV. It's not really a powerhouse, but it seems like it should be able to do the job, it has 1.6Ghz Duron, a 64mb nVidia Geforce 4 video card and 128mb PC2100 ram. It's running Windows XP Embedded, and all the drivers are up to date.

When I play Zelda: OoT on my computer, which has a 512mb Radeon X1950, it plays just fine, everything looks perfect. However, when I play the exact same rom (OoT, version 1.2), with the exact same versions of PJ64 (1.6), and the exact same video plug-in (Jabo's Direct3D8 1.6), and the same version of Directx (9.0c), I get various graphical issues.

For instance, the word Nintendo that appears when it first starts, appears in a blue box in front of the 3D N, the ground that link rides his horse on in the opening sequence switches randomly from the normal grass texture to a black a gray color, and where the water should be in the rivers, is just blackness.

I tried adjusting the setting on the video plug-in (I'm not really sure what does what, though), and also upped the ram to 256mb. But it didn't help.

So my question is, has anyone else had this problem, and if so were you able to fix it, and how? Or should I just try a different video plugin? And will changing the video plug-in significantly effect compatibility? I specifically only put games on the system that were listed as compatible because I didn't want any hassles once it was up and running (the only form of input is game controllers, so there's no way of making settings adjustment without opening it up).

I've tried several other games and they seem to look ok, although most of them I've never played before, so I'm not sure how they're supposed to look.

RadeonUser
22nd December 2008, 05:21 AM
Is that Geforce 4 an MX?
If it is that's the problem, the MX version of the Geforce 4 is pretty much a rebranded Geforce 2.

squall_leonhart
22nd December 2008, 07:22 AM
Originally when released, the Detonator drivers at the time emulated several pixel/vertex functions on the MX series, though you couldn't enable pixel shaded water in games like Morrowind, it did allow Jabo's D3D8 to work.

You can either go back to Detonator 40, or use the D3D6 plugin.

emcee
22nd December 2008, 10:58 PM
Ah, ok, that explains it.

I tried the D3D6 plugin, and had the same issues, but I also tried the Rice video plugin and there only seemed to be a few minor issues. The opening logo was messed up even worse, a puffs of dust are squares, but the ground and water look ok.

I haven't really had a chance to test any other games yet, though (mainly because "testing" OoT turned into playing through to the second dungeon). Does anyone know if compatibility is significantly worse (or just different), with the Rice versus Jabo plugin? If all else fails try downgrading the video driver, although messing with drivers can sometimes be a real pain on XPe.

When done, this system will be a (late) Christmas present for my sister, so I want to make sure it "just works". Worse case scenario, I'll just remove N64 support. It has 11 other systems built in, and N64 support is intended as an "unlockable" feature.