PDA

View Full Version : Saves states loading problems and solutions


Lebon14
28th December 2008, 10:52 PM
OK. I ran into a save state problem just now with PJ64 1.6.

What did I do to create the problem :
So, I played normally with Banjo Kazooie. After a frustrating death, I save-stated to not lose where I was and what I was doing. I was playing with the gln64 0.4.1 video plugin, the no sound plugin (included) and N-Rage's controller plugin.

So, after the succesful save-state, I closed PJ64. To be sure, I re-opened PJ64 and try to load the save-state. Each time I tried to load the save-states, PJ64 freezes. I started to worry.

The cause of the problem :
The video plugin causes the crash. :confused:

Solution :
Rather simple when you know the source. Change it to another plugin. For Banjo Kazooie's case, changing it to Jabo's Direct3D 6.1.5.2 (or another working one) will make the save-state load just fine.

Also, on a N64 emulator, don't rely too much on save-states. Also, save the game normally! Just in case... ;)

---

I know that happens with Banjo Kazooie. If you know other games that does that thing, post it.

HatCat
28th December 2008, 11:50 PM
This seems to be another instance of a crash in an OpenGL-rendering driver--caused more by murky data in the instant save format Project64 uses.

Even if I use a Direct3D plugin sometimes when I load a save state for Virtual Chess 64 the screen's black, but if I pause and open the menu frame updating begins.

Yet I've never noted this on version 1.6 or before, but if you can try another emulator for the sake of observing this kind of stability? Examples 1964, Mupen64, and Nemu64 just as well use their own format for instant saves.

Lebon14
29th December 2008, 12:04 AM
I never been a fan of other emulators and I don't want to try it out.

That's a good possibility that you make there and thanks for the tip.