PDA

View Full Version : Graphic issues in LoZ: Ocarina of Time


stapler942
4th January 2009, 10:32 AM
Hi there. I was having an issue while playing Ocarina of Time on P64 and I thought I'd stop by to ask about this. Looking through the other threads I noticed at least two other people having a similar issue.

Basically, a lot of textural elements that are supposed to appear on the ground are either missing or keep flickering in and out of existence. This includes paths and shadows (Link's shadow usually can't be seen) and other minor details, but more importantly those little patches of soft soil where you plant the seed are hard to find unless you actually press A while standing near one (then they are visible for a few seconds). I first noticed this when I was in the Lost Woods and the little patch of soil started appearing and disappearing.

It's hard to tell what exactly triggers getting it to appear; it seems to happen sometimes when I walk past the object, near it, or it's only visible when I'm standing on a higher or lower level than the ground it's on (e.g. in the Kakariko graveyard, if I stand on a fence I can see a lot more texture in the ground as well as a patch of soil). It seems that when the other stuff is visible, Link's shadow also becomes visible.

Anyway, does this sound like a hardware problem, a graphics plugin problem, an emulator problem, or a ROM problem? After checking some of the other threads, I tried using some alternative plugins and that seemed to give varying degrees of non-solution (one plugin made all the soil patches visible but made the climbable vines disappear, while the Jabo 1.52 version made it so that ground texture was invisible all the time; Direct64 wouldn't work at all for me, etc.). Solution?

Thanks for your time.

squall_leonhart
4th January 2009, 01:03 PM
Solution 1.
Get a real video card - On the chance that you have integrated video such as a via unichrome of intel extreme graphics / GMA 950 and lower.

Solution 2.
Use the D3D6 1.5.2 plugin.

Solution 3.
Update your video drivers.

HatCat
4th January 2009, 10:03 PM
Apparently for him the 1.5.2 plugin makes things worse as in the other thread I tried with, and the Direct64 plugin won't initialize. That said given his card is much low-end even if in optimism it's an Intel chip the OpenGL renderers don't fare well with that, and Jabo's plugins and Direct64 are major alternatives...so this one is probably out of options.

Things you can do in the mean time:

Try a plugin called Rice's Video Plugin. A simple-to-install version is given here. (https://ricevideo.bountysource.com/downloads)
Try finding out what your graphics card is; at least this will give more information in case no option really is left. If you are using Jabo's Direct3D8 1.6 Options Configure Graphics Plugin will give you the name of the brand. Better is Rice's Video Plugin which will report the driver version the card uses on the DirectX configuration tab.
like squall said video driver updates are often an option if you have an old card from today but first finding out what your brand is is essential and
buying a more modern graphics card or other hardware system, which will easily fix things up

stapler942
5th January 2009, 12:20 AM
Upon checking the config, I found the brand name at least:

Mobile Intel(R) 945GM Express Chipset Family

Will be trying to update drivers, etc. We'll see what happens.

HatCat
5th January 2009, 12:36 AM
Right, I found the brand here on the main Intel site.
http://www.intel.com/Products/Notebook/Chipsets/945GM/945GM-tools.htm

squall_leonhart
5th January 2009, 08:36 AM
oh....

GMA 950 and lower don't have TNL... that would be the reason the Dx6 plugin is screwed.

stapler942
7th January 2009, 01:30 AM
Oh, okay.

Since I'm using a Toshiba laptop it doesn't look like I'll be able to upgrade anytime soon. Thanks for the help though. I'll just have to do without the little details.