PDA

View Full Version : Program called "Good N64"?


Sodori
13th February 2009, 06:46 PM
I'm just gonna let 1 image say my problem, occures upon loading any rom I got (even Mario Party 1-3, that worked before):

http://img16.imageshack.us/img16/1387/erroreq2.jpg

Please help me, love the new betas btw and the fact this is started aigain and all :)

HatCat
14th February 2009, 12:13 AM
Right-click the game title, and choose "Rom Information". Please copy this information so we can verify if the file seems right.

Sodori
14th February 2009, 01:59 AM
http://img88.imageshack.us/img88/8848/errorrq4.jpg

ROM info from a known working one.

And I think I really do have found the issue, does Project 64 have a limit to number of readable roms it can read from a rom directory?

I got a mega collection of over a 1000 ROMs, maybe that's to much for them? Since I made a new folder, put the Mario Party 3 ROM there and then selected that folder as a ROM directory to make that screenie above.

Might have found the issue, now just how do I separate over 1000 ROMs xD Oh well that's my issue, but can you confirm it?

HatCat
14th February 2009, 03:06 AM
You might be right. Our copies have the exact same MD5, and I was able to start the game.

Try hitting F5, and if refreshing like so doesn't work use File:Open to load the game?

Sodori
14th February 2009, 11:07 AM
For some reason it works now and I can't get that error file open no matter what I try xD
Guess I needed to show the program that I was worthy welding it or something...

Issue still remains, and that's the limit in readable ROMs from ROM sirectory. You kinda would prefer to browse your ROMs if you know what I mean :P

I guess it's possible to categorise it by alphabetic, to have all ROMs there :P


EDIT:
I found the issue!

Quobi (www.quobi.com) is the thief!!!

I need to ajust the timer on it a bit more, so it starts a bit after.

Problem solved :) Now just for teh limit in ROMs :P

HatCat
14th February 2009, 05:47 PM
I am not sure there is a limit, but you are saying the game file will load now?
If that is the case what tells you there is a limit of the games in the browser?

Shaun_of_Light
14th February 2009, 07:35 PM
Strange, this worked fine with me. I'm watching this thread...

Sodori
15th February 2009, 01:48 PM
Let's be scientific about it, shall we?

http://img258.imageshack.us/img258/5854/error64pl8.jpg
http://img258.imageshack.us/img258/9290/errorwinyu4.jpg


Notice how they booth are scrolled down to the furthest down possible and that it ends with a "L" in pj64.

And yes I have redone the ROM directory and refreshed it numerous of times with the exact same ending....

fridgey
15th February 2009, 09:22 PM
More science:
http://fridgesworld.com/screenshots/pj64_romlist.jpg
That's the tail-end of the current 3000+ rom GoodN64 set. Just as a guess, perhaps you've got a corrupt file or something along those lines that's causing a break in the PJ64 read process... this would fit well with the error that started the whole thread, especially considering most of the files in the folder you screenshot aren't N64 games.

HatCat
15th February 2009, 10:10 PM
Delete the Project64.cache files. I never use them; I just emptied them to 0 bytes for the 1.6 version and set them to Read Only mode. It possibly got corrupted during a coincident process of writing the downloads, so it was hard to understand what exactly you were referring to since the concept hasn't been seen.

Simply deleting them will signal re-generation of the list completely.

Sodori
16th February 2009, 05:28 AM
@ fridgey:
Hm... I just had a trie with first moving the ROM after in this case LEGO racers, no luck. After that I tried remove Lego racers. That resulted in pj64 stopping on the ROM before LEGO racers lol >.<

@ Iconoclast:
...woot xD
Ehhh, the only cache I can find is theese 2 grrstards;
Project64.zcache
Project64.cache3
Revoming them aint doing the trick.... same goes with that read only.

Sorry, I feel like a newb with this stupid error :-/
I'm gonna record a little video covering all details of this and such, maybe you spot something I miss...

fridgey
16th February 2009, 08:56 AM
If it stopped on the one _before_ lego racers, rather than adding one in its place, that sounds like what I said might be going on. You said you removed the one after lego racers, but was that an N64 game? Make sure you remove all the ones between lego racers and the next actual N64 rom... probably Lode Runner 3D, and maybe even that one, as perhaps its ignoring all the non-n64 games and your copy of Lode Runner is what's botching things up. Or maybe it's something else entirely :D

HatCat
16th February 2009, 11:02 PM
Verify the later files not shown can be loaded via File\Open and that they are in the same folder as the ones that will load.

If that doesn't help log the list generation from refreshing with F5. Logging can be enabled through Debugger\App Logging.
Copy the contents from Project64.log. If this file doesn't exist the debugger is [not] enabled in the advanced settings.