PDA

View Full Version : Quad intersects out of alignment.


squall_leonhart
8th April 2009, 08:39 PM
Black lines appearing in panels made of quads, for example the mario kart 64 character picture on the choose character screen has noticed black lines when the image is accelerated. The problem is not present when the image is drawn in software.

HatCat
9th April 2009, 01:44 AM
When the image is 'accelerated'?

Unless you're referring to the common texture mapping glitch (which is fixed only with RGB rasterization rendering as included or RiceVideo's alternative texture mapping algorithm) a screenshot to make sure just in case?

In the findings of all plug-ins, the issue I am perceiving here is found as a common stick to the Direct3D/OpenGL renderers.

Lenneth
9th April 2009, 02:04 AM
Here it is.

squall_leonhart
9th April 2009, 02:54 AM
Indeed, Its definitely fixable though.

HatCat
10th April 2009, 12:19 AM
Fascinating as it seems none of the plug-in authors really demonstrate how.
All that's been said is one thing that could be changed is internal to those APIs.

Hopefully luck serves though, as this glitch has been known inclusively by Jabo for some time.

squall_leonhart
17th April 2009, 08:59 AM
If the Software render can do it properly (D3D Raster) then it can be fixed in hardware mode.

HatCat
20th April 2009, 11:20 PM
Peh, RGB rasterizing has to do it properly. Everything is grouped into pixel blocks.

squall_leonhart
21st April 2009, 02:06 AM
Me and brad took a good look at the differences between the screenshots, and its either.

1. Negative lod (going by the sharp difference between the 2 images)
2. Texture alignment issue