PDA

View Full Version : Some Errors and any plug-ins to fix them?


jday
11th April 2009, 08:18 PM
I have some errors in these games and I was wondering if there are any plug-ins I can use to fix them. I have Rice's Daedelus 5.1.0 but don't use it. Here are the games that I have errors with;
Perfect Dark (U) (V1.1) [video] missing lens effects

Indian Jones and the Infernal Machine (geez does this game work for anybody?) Needs Video Plug-in [video] unsupported (W/Rice's Dadelus the game starts but its black with a few white dots, music plays)

Kirby 64 and the Crystal Shards (U) [video] error(s):health_bar,misc. (No health/powerups appear)

Donkey Kong 64 (U) [video] primary_framebuffer:pause (Main Problem is DK Rap. Words don't appear with the song. Other cutscenes do the same. Oh yes, and stretching textures)

If anyone could help me with these that would be greatly appreciated, as I am sure I am not the only one with these problems
Thanks ;)
P.S. These are all .Z64 files

HatCat
11th April 2009, 11:38 PM
Most pre-testing information is found here.
http://bmgcl.emuxhaven.net/n64mgcl/N64ConfigList.htm

Indiana Jones and the Infernal Machine is another deviated microcode game. You need an LLE RDP. If you are familiar into installing plug-ins and changing them you can either grab z64 Graphics from EmuTalk or donate for an LLE implementation of the graphics and RSP code in Project64's beta plug-ins.
http://www.emutalk.net/showthread.php?t=40640

The RiceVideo system of plug-ins as you have found will also boot the game using experimental attempts, but the custom microcodes are not really emulated--which is why there is never geometry in those tries.

jday
12th April 2009, 12:56 AM
Is there any way I can learn to do this stuff? If you are wondering, I am not that slow at learning this kinda stuff

HatCat
12th April 2009, 03:16 AM
What exactly?

Can you install plug-ins and change them?

jday
12th April 2009, 05:02 AM
I know how to install them but I dont know how to change them

HatCat
12th April 2009, 06:48 PM
Install z64 from here.
http://www.emutalk.net/showthread.php?t=40640

Change plug-ins by the dialoge summoned after choosing "Settings..." from menu "Options".

jday
12th April 2009, 08:23 PM
OOOOHhhhhhhhhhhh. When you said change them I thought you meant change the plug-in itself, not change it for the emulator. I know how to change it in the emulator

jday
12th April 2009, 08:58 PM
I downloaded them and put glew32 in core folder and the other files in plug-in and it didn't really do anything. I think I may have done something wrong but I don't know

HatCat
12th April 2009, 09:26 PM
When does nothing happen, in the scene you had expected a result? Does the plug-in not initialize when you set Project64 to use it?

There is a known issue with Project64 1.6 to use this plug-in. You can also change the RSP plug-in if you can use 1964 or Mupen64.

jday
13th April 2009, 03:52 AM
Well, it was really laggy. Thats what the problem was. I was better off using Jabo

HatCat
13th April 2009, 09:55 PM
z64 doesn't run on Project64 1.6 because of the pre-set RSP engine, which must be replaced by the version co-operating with the RDP one. If you managed to get this plug-in to work, it does not succeed Jabo's plug-in in appearances of results because it is an LLE revolutionary design for graphics accuracy.

But Jabo's plug-in, which in your case is HLE, will not start the Indiana Jones game. That's where this plug-in must then be used.