PDA

View Full Version : Mario Party 3 (U, good dump) sometimes malfunctions in PJ64


GamerXYZ
16th May 2009, 02:57 PM
I play MP3 on PJ64 1.6 with the Trust GM-1520 controller (actually a Playstation controller but it's still easier than using the keyboard). Actually, I play all my games with it. I've played MP3 for years (though not with the controller, but I've still played enough games with the controller).

Anyway, a week ago I pressed some random buttons when I was playing MP3. The start menu kept popping up and going away. I first thought I had accidentally turned Turbo on (it has two buttons that have such a function), or Macro, but all three turned out to be false. The manual didn't help either. But even after turning back to the keyboard and disconnecting my controller, MP3 stayed glitched. And it was only MP3 (and really everywhere start has a function in MP3), all other games weren't glitched.

I downloaded MP3 again (a good dump, a different link) and things went fine. Until today. I was just playing the game, pressing no random buttons etcetera, but the glitch returned in turn 12 of another board. And again, everywhere no matter if I restart the emulator, unplug my controller, etcetera.

Does anyone know what's causing this?

HatCat
17th May 2009, 12:38 AM
Describe the glitch so we can judge what to do.
Where and when might this occur?

GamerXYZ
17th May 2009, 10:58 AM
:confused: Like I described, the start menu keeps popping up: the game acts as if I continiously press the Start button (because when I restart, it automatically continues on parts you can continue with the Start button). While I'm 100% sure I haven't activated Turbo Mode on my controller (pressed turbo, unplugged controller, restarted without controller...).

It happens randomly. Both times it randomly happened when playing a board in MP3.

HatCat
17th May 2009, 10:11 PM
While you're in a mini-game, try not just disconnecting the controller but disabling emulation.

Choose "Configure Controller Plugin..." from the menu "Options", and uncheck the option for emulating controller 1. Do this at some stage in the game where you have witnessed automatic pausing. Unfortunately some parts of the game may pause automatically as instructed where the controller would be active....

If by these means you cannot reproduce this glitch, more likely there is something about your controller settings.

GamerXYZ
18th May 2009, 10:52 AM
The automatic pausing is literally everywhere in MP3. Well, everywhere where start can be pressed, start's function gets used (which, in a board's case, is pausing and going out etcetera).

I think I found what the problem is, though. There seems to be something wrong with my USB port in general, which maybe is the cause for this (maybe it kept sending the same command even after unplugging??? I don't know. Anyway, when I deleted something from an USB stick in that port it deleted fine, then I kept getting an error I couldn't delete the file because it didn't exist anymore (duh)). I've tried what you said after switching port, and it didn't happen. I'll post in this topic again when the problem's back.

Thanks for the help.