PDA

View Full Version : New error message (lol)


kiiyara
26th May 2009, 07:41 PM
So the tips I was offered last time seemed to work. But then I bought this thing called a 3 in 1 magic joy box (plugs into USB port and can plug in a PS/PS2, GC or XBOX controller into it), so that I could use my GC controller rather than the crappy one from Microsoft I had been using. I'm not sure if it's not fully compatable with P64 because now the freezes are more frequent and I get a new error message "Unhandled R4300i OpCode at: 800043C4 Unknown 04 04 04 05 Stoping Emulation!". I've restarted the emu and restarted my PC as well, doesn't seem to help? any thoughts?

HatCat
26th May 2009, 10:13 PM
What game does this happen with?

Unless something in your setup is automatically re-writing the RDB configurations file, your PC might be below specs for compatibility with Project64. This is an unusual element though.

When you have given any new information I have something for you to try.

kiiyara
27th May 2009, 12:55 AM
Banjo-Tooie and Pokemon Snap, those are the only two roms I have at the moment as well. I'm pretty sure it's comptatable with my laptop though to be honest I'm not really too computer savy and I'm not 100% sure where I would check this out. This error started showing up when I tried to use my Game Cube controller and the freezing is now about... every 15 minutes or so.

HatCat
27th May 2009, 01:22 AM
Choose "Settings..." from the menu "Options".
From the "Options" tab disable the option to hide some advanced settings.
Apply changes.

In Project64's browser, right-click those games, and choose setting "Edit Game Settings".
First try to upload a screen capture of the current settings for either game so that I can see more just how likely it may be your hardware causes this.
Now set the "CPU core style" to "Interpreter".

Once you apply changes the game will be slower, but see if this prevents the crash from happening next time.

squall_leonhart
27th May 2009, 04:28 AM
pokemon snap is 100% pj64 compatible, i'd say its hardware related, meaning interpretor will make it worse.

kiiyara
27th May 2009, 06:51 PM
http://i14.photobucket.com/albums/a341/rexfactor/banjotooie.jpg

http://i14.photobucket.com/albums/a341/rexfactor/pokemonsnap.jpg

The other roms for BK and Mario I haven't really played long enough yet to find out if I have the same issue with them. and as for Pokemon snap, I do get the freezes but another problem as well, you can't really see the pictures you take, they flash for a second then it's just random colours. But that doesn't bother me as much as all the freezes.

HatCat
28th May 2009, 12:32 AM
Settings match. Once you have set the field for "CPU core style" to "Interpreter" let us know of the performance as far as stability.

Try also to give us some information on your hardware. You can get some information if you right-click an item labeled something like "My Computer" from your Windows Start menu and then choose "Properties".

The other roms for BK and Mario I haven't really played long enough yet to find out if I have the same issue with them. and as for Pokemon snap, I do get the freezes but another problem as well, you can't really see the pictures you take, they flash for a second then it's just random colours. But that doesn't bother me as much as all the freezes.

If you ever need to see the pictures there is another option that will also slow down speed.

Choose "Configure Graphics Plugin..." from the menu "Options".
Advanced settings should not be hidden.
There is an "Advanced" tab in this configuration.
From there set on "Copy framebuffer to RDRAM".

kiiyara
29th May 2009, 01:11 AM
http://i14.photobucket.com/albums/a341/rexfactor/system.jpg

Hope that's what you meant, lol. And when I switched it to interpreter no freezing just much lower FPS, from about 60 to about 25 or so.

I'll try the tip for pokemon snap later on to see if it helps. I can kind of see the pictures they just flash really quickly.

HatCat
29th May 2009, 03:03 AM
In the game settings then try experimenting with these one-at-a-time.


Self-modifying code Method: "Protect Memory"
Advanced Block Linking: "Off"
Register Caching: disabled

If even all-at-once this does not work, the issue lies in the main re-compiler most likely.

kiiyara
2nd June 2009, 08:18 PM
I will give all that a shot! :D thanks for the help