PDA

View Full Version : Good Evening Gents


Shadud
29th May 2009, 11:21 PM
(This is a life-story post, if you want to skip all the boring garbage hop on down to the bottom marked in bold lettering.)

Other than my introductory post this is also an investigation into a certain set of troubles I'm having.

Well the troubles are minor at best because it has really nothing to do with Project 64 itself, rather, I make videos. A lot of videos, videos everywhere! And a very recent project of mine has lead me to the N64, good ole N64.

I've been using Project 64 for god knows how long and I've also fiddled around with other emulators of this type. The best experience thus far (as far as errors, random crashes, random freezing goes) is through Project 64. Quite impressive I must say. Now here's where my issue starts; some of you fellows may know of FRAPS the recording program meant to capture in-play video games. I've been using FRAPS for quite a while as well, however, when I decided to align the two together I ran into a bit of a snag. FRAPS does not play well with Project 64. A massive frame rate drop pulling the game down to crippling speeds as soon as recording begins. So in an attempt to work around this I tried hunting down another screen capturing program that would be as good yet play nice. Suffice it to say, I've turned up nothing. (Now you may be thinking "Well how can this be?! There's tons of them! That is true, and they all pale in comparison to FRAPS in regards to quality and general frame rate.)

So, rather annoyed by this I moved about from recorder to recorder some fairly good, some completely terrible, then I bounced from emulator to emulator as well, some fairly good, others... well, not so good. Amongst one of the several I tried I pulled a good 30 minutes of recording off of. Quite impressive I thought! However, though the emulator in question performed admirably it failed me as soon as I tried to next segment of video freezing and crashing less than 5 minutes into game play. So the point is, I'd love to stick with Project 64 as my main emulator-of-choice and I'd like to know if anyone knows of a program that will run as well as FRAPS and play friendly with Project 64 or if there's a way to get Project 64 to play nicely with FRAPS.

HatCat
30th May 2009, 03:20 AM
The main concern lies in your video hardware and the graphics plug-in you use.
Can you get some info on your system specs?

Shadud
30th May 2009, 03:30 AM
Not a problem. If you have any more questions don't hesitate to ask, being that you're trying to help me I am grateful.

Processor:
Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz (4 CPUs), ~2.4GHz
Memory:
8192MB RAM DDR2 800Mhz
Hard Drive:
500GB Samsung Spinpoint 7200RPM SATAII
Video Card:
NVIDIA GeForce GTX 260 Core 216 Driver version 182.50
Sound Card:
Creative Sounblaster X-Fi Titanium 7.1 Sound Card
Operating System:
Windows Vista™ Ultimate 64-bit
Motherboard:
EVGA nForce 780i SLI 775 A1 Version

Shadud
30th May 2009, 03:39 AM
You know what, I apologize for the double post and I apologize for even wasting your time. I don't know how to explain this without sounding absolutely retarded so I'm not going to.

HatCat
30th May 2009, 03:46 AM
Nice hardware!

What game have you been trying to record?
Describe the stage in the game where you have tried to begin the recording?

The game itself then might have an unusually fast internal frame rate at that stage--raising the intensity for FRAPS--but what is also likely is Project64 itself being slow.
There should be a "FPS" counter at the bottom-right of Project64. At this point in the game, how far off is this away from sixty (full speed)?
edit--
Oh sorry to take. I would like to know for my information though?

Shadud
30th May 2009, 03:54 AM
I honestly think I'm going brain-dead. I so clearly recall trying every single plug-in and getting a frame rate dip down to lower than 15FPS.

And it is at all stages of the game that the FPS is dropped, the game in question is the lovely Ocarina of Time. A classic, yes.

I did all sorts of crazy crap trying to solve the issue, even just earlier today I was goofing around in Left 4 Dead doing a bunch of test recordings and I happened upon one of the settings in the game for multi-core rendering (better for multi-core CPUs) and whilst trying to record (using fraps) I was getting the telltale frame dips that made the recording absolutely atrocious as opposed to several older recordings of mine where the game was operating at well above 60FPS so I decided that maybe if I set core affinity I'd get the issue to be fixed, well that didn't work but that just goes to show you how desperate I was to fix the issue and of all the stupid things...

I changed the plug-in.

And I'm laughing my ass off because of it.

Edit: And thanks on the hardware comment. It's about as good as it's going to get for a long while unless I get lucky and find another job real quick like.

Edit2: Though if it makes me seem any less retarded when I tried Jabo's Plug-in in a different emulator there was no frame dip.

HatCat
30th May 2009, 04:01 AM
Hm, well I did kind of, temporarily skip around the concern of the graphics plug-in in use, knowing that I am probably as of yet undergoing some kind of criticism for thinking too much about plug-ins. Again all they do is divide it's like

Damn man you sure seem like you've earned that stuff. You do some work.
What plug-in were you using then? I didn't think this would constitute for hardware like that, but I gotta ask.

Shadud
30th May 2009, 04:10 AM
Normally I'd use Jabo's Direct3D8 v1.6 but this time I tried Mudlords Rice Video Plug-in, the one you recommended in the other thread for Gauntlet Legends. To my dismay it worked beautifully.

I'm still slamming my head against the desk though wondering how I could've skipped that. I'm certain I tried several different plug-ins, in fact, I downloaded like 10.

HatCat
30th May 2009, 10:13 PM
Sounds like a frame buffer or other rendering applied for the game, or maybe RiceVideo just simply doesn't work well with FRAPS as far as I could understand.

If I can get into a situation where I can actually use FRAPS again I might be able to see for myself.

Shadud
1st June 2009, 08:57 PM
I figured it out. By default the framebuffer emulation for the RiceVideo plug-in is set to none, during trials with Gauntlet Legends to see how I can get the best performance I changed the framebuffer emulation which explains why previous attempts with FRAPS and PJ64 did not work, however, what I did not realize is that I had changed the setting and that's why all of a sudden it worked.

So from what I can tell almost any other setting for N64 Frame Buffer emulation except for none works well with FRAPS.