PDA

View Full Version : Texturing- Jabo's not loading all textures.


SaxCatz
20th June 2009, 10:17 PM
I'm having a bit of a problem with the latest version of Jabo's and it's texture pack support. While I am able to load texture packs, some of the included textures are still not loading and the originals are displayed.

http://forum.pj64-emu.com/attachment.php?attachmentid=174&stc=1&d=1245535472
Above is an example that is easy to illustrate: missing heart containers in Djipi's cell shaded texture pack for OoT.

http://forum.pj64-emu.com/attachment.php?attachmentid=175&stc=1&d=1245535472
As you can see, although most textures are loading, some, like the heart containers above, are not loading.

http://forum.pj64-emu.com/attachment.php?attachmentid=176&stc=1&d=1245535472
This is the texture file from the texture pack.

http://forum.pj64-emu.com/attachment.php?attachmentid=177&stc=1&d=1245535472
This is the texture that is dumped after loading the ROM with the texture pack.

I compared the dump with the texture pack and the file name for both textures is 8CF296C18F14E38F26A74986580EDBB7.png.
I also tried several versions of the ROM (1.0, 1.2, etc) and, each time, the results are the same.
Is this an known issue? If so, is there a workaround?
If not a known issue, is there any additional information that I could provide the developers to help track down the problem for future releases?
Thanks again!

squall_leonhart
20th June 2009, 11:52 PM
the texture packs are based on old versions and not all of the textures may have the right identifiers,

Federelli's pack works fine in jabo's.

SaxCatz
21st June 2009, 01:41 AM
I understand that the packs may not be the most updated.
However, I checked the filename in the pack against the file name in the dump and they match. Technically, should it not load that texture?

SaxCatz
21st June 2009, 01:46 AM
BTW Squall,
Do you know where you can download a Jabo compatible version of Federelli's pack?
Thank you in advance!

squall_leonhart
21st June 2009, 02:38 AM
http://www.pj64-emu.com/index.php?option=beta_files&task=Package_get&PackageID=97

sorry, its kmans pack, but i think its got some of Fed's stuff in it.