Project64 Forums

Project64 Forums (
-   Project 64 - v2.x - Issues (
-   -   Mayflash Gamecube adapter not working with DK64 (

RagePlutia 9th August 2016 09:39 PM

Mayflash Gamecube adapter not working with DK64
I don't get it. It worked with all games fine before I had to reinstall Windows 10. Now it works with games but with DK64 it has major problems, the axis and A B buttons work fine, Start works fine, but the C Buttons nor the D-Pad will work. I can't play and I've tried everything, from switching graphic plugins, to reconfiguring the button placement. I am using Glide 64 and N-Rage's direct input on Project 64 2.2.:mad:

retroben 9th August 2016 11:39 PM

Joypad driver issues would most likely be the cause in standard gamepads on Windows 10.

I found some info about it not working correctly/at all on Windows 10 from issues making it no longer work until a fix/workaround is done after every Win10 update.

After searching,some program called "zadig" is used to make it appear correctly in device manager after uninstalling the driver,rebooting,running zadig,then rebooting again.
The big problem is yours partially works,so I don't know if this will fix your problem or just make things worse.

Go to Device Manager and look through the list of USB stuff for one with a yellow caution icon on it,and that should likely be your Mayflash adapter having problems with Windows 10.

RagePlutia 10th August 2016 12:56 AM

So I looked in my Device Manager to see if there was a caution sign like you stated, and there wasn't, so is the drivers installed correctly? I then went on to test it on programs like Steam and Dolphin and and the controller works absolutely fine on them. I just can't get it to work on Project 64. I also installed Zadig again and it still doesn't work, just the same as before. I don't know if the controls are inverted or I need to use another plugin. I also tested and configured it again to get the C buttons to work, but now the L and R buttons won't work.

RagePlutia 10th August 2016 10:04 PM

Actually nevermind. It was a simple fix that I didn't even need to post about on here. All I did was get my older third-party GC controller instead of the official Smash one, and it worked just fine. Have no idea why but it works. Thanks for your help, I really appreciate it.

All times are GMT. The time now is 09:26 PM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.