Project64 Forums

Project64 Forums (
-   Project 64 - v1.6 (
-   -   Controller won't work? (

romanceinslowdance 17th October 2010 02:14 PM

Controller won't work?
Hello theree! :)
I am trying to play Project 64 version 1.6 with an Axis Pad Playstation controller, but it is made for the PC. When I plug it into my computer, it recognizes it and downloaded the drivers and whatnott, but when I go to set the controls for it directly on Project 64, it won't work. :/
When I have the controller plugin set to Jabo's, the only thing that will work is the D-pad; none of the buttons, triggers, or analog sticks will register. However, when I set the controller plugin to N-Rage, the D-pad, buttons, and triggers work, but still not the analog sticks.
I know for a fact that the analog sticks are not broken. I went to my boyfriend's house and set the controller on his Project 64 (Same version, with Jabo's plugin) and it worked completely fine, including the analog sticks. When I open other emulators, such as Desmume, the analog sticks will also set for controls.

Does anyone have suggestions for what I should do? I'm not sure exactly which Axis Pad controller I have; I bought it at a yardsale with just the contoller.

I have just found out through a bit of Googleing that I have the AxisPad Colors GGE900 Blue PC USB Game Controller. I'm not too sure if this will help any though. :/

HatCat 17th October 2010 05:55 PM

Have you tried the 2.2 beta version of N-Rage's?

If that doesn't work there is a compatibility version here.

romanceinslowdance 18th October 2010 02:29 AM

Well this is gonna sound kinda amaturish, but what do I do with the things I download from those pages? I'm still relatively new to emulators and plugins and whatnot so I'm not sure what to do hahaha.

HatCat 18th October 2010 02:39 AM

If you choose the first link (newest version, hardest to get to work), look for Extract the contents of the ZIP archive to the "Plugin" subdirectory of where you have Project64 installed.

If you choose the second link, just download that DLL file to the "Plugin" subdirectory of where you have Project64 installed.

Whichever you choose, if you follow my instruction, you install a new version of N-Rage DirectInput to test to see if it gives you better results with your controller configuration. Change to a newly installed plugin as you have been doing, via Options > Settings....

romanceinslowdance 18th October 2010 09:11 PM

Ohhhhhhh! I understand what you're saying. Thank you soo much! :) I'll try those and then checkback and see if it worked.

romanceinslowdance 18th October 2010 09:37 PM

Well I downloaded the first one, and it didn't fix anything. :/
I downloaded the second one, and now when I run Project 64 and press Settings, two error messages appear.
The first says:
"The program can't start because MSVCR70.dll is missing from your computer."
The second pops up after you close the first, and it says:
"Failed to load plugin: C:/Users/Kris/Desktop/Project 64 1.6/Plugin/NRage_DInput8_V2_2200.dll"

I understand the second message, because it means it can't run the plugin without whatevurr is missing in the first message. However, I didn't delete anything from my computer inbetween downloading the second thing and running Project 64.

HatCat 19th October 2010 12:47 AM

You can get MSVCR70.DLL from here.

Extract the file from the ZIP archive to the same folder where you have Project64 installed (not in the Plugin subfolder of that directory).

Okay, so this should get the plugin to work, but I'm thinking it might not help with your controller issue. Honestly all I've ever used is a keyboard and sometimes my mouse, but I find it interesting that you find the functionality you need on your friend's PC or with other emulators on your own PC--just not with N-Rage's DirectInput on Project64.

romanceinslowdance 19th October 2010 08:21 PM

Yeahh it is pretty strange. I have a hard time playing games with the joystick with a keyboard. I mean, I could do it, but I figured since I got the controller then what the heck? You know? Hahaha. I really figured it didn't work on my computer because it's an old controller but I know it doesn't work. It's just soo odd.

HatCat 19th October 2010 09:49 PM

Maybe it's to do with the drivers installed on your local machine, since you were able to get different functionality on a different computer?

romanceinslowdance 19th October 2010 11:17 PM

That's a very good point, actually. I'm going to find out what drivers are installed on the other computer that aren't on mine and try to find out if that is why it doesn't work. Thank you soo much for your help. :)

All times are GMT. The time now is 06:58 PM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.