Project64 Forums

Project64 Forums (http://forum.pj64-emu.com/index.php)
-   Open Discussion (http://forum.pj64-emu.com/forumdisplay.php?f=9)
-   -   Kaillera netplay with more than one local player (http://forum.pj64-emu.com/showthread.php?t=4157)

KG7 1st November 2013 11:35 AM

Kaillera netplay with more than one local player
 
This isn't really the right forum to post this seeing as I'm not using Project64, but on the first page is a discussion about God, so...:p

Anyway, what I'm trying to do is use Mupen64++ Beta 0.1.3.12 to play multiplayer games (ie. Mario Party 2) over the Kaillera client with my friend over in Spain. We've tested this already; it works perfectly, no desyncs occur, everyone is happy!

Now you see, all I want to do is actually pretty simple in theory -- have a second player (my girlfriend) who is physically with me in the same room on the same PC, be able to play with myself and said friend from Spain. But for the life of me it just refuses to work.

I've tried N-rage's input plugin as well as Jabo's DirectInput plugin; both have exactly the same results. I'm using two Xbox 360 wireless controllers, both of which are functioning perfectly when I'm simply playing locally on the emulator itself. However, as soon as I enable Kaillera in order to play over the internet, the second controller refuses to work, so I hazarded a guess that perhaps Kaillera itself only allows the very first controller to work, for whatever reason.

Fair enough, but what if I simply open the emulator a second time? This is where it just gets WEIRD.

I copied and pasted the entire emulator folder to another location (another hard drive, in fact) just to make sure there is absolutely no synchronisation of configuration files and whatnot between each emulator. However, as soon as I configure each controller for their own separate emulator (ie. one controller is player 1 on one emulator, the other controller is also player 1 but on the OTHER emulator), the other emulator automatically selects the same controller. What I mean by this is that both plugins clearly define each controller as separate with their own configurations, yet as soon as I save the settings in one emulator, the other emulator automatically selects the same controller as the first emulator, so I get exactly the same result over Kaillera; only the very first controller works, for both emulators.

The same thing happens with my network settings. Once I've saved my Nickname and Connection type in Kaillera, the other emulator has exactly the same options selected.

Can anyone explain how on earth these two emulators are having identical settings despite being in completely different hard drives with separate settings? Do plugins communicate in a way that I'm completely unaware of or something? :confused:

Marcelo_20xx 1st November 2013 03:49 PM

Maybe because the emulator shares a common config folder? I remember Mupen64++ stores its cfg files, specially the binding layouts in your "document and settings\user's..." folder

Also other plugins save their configuration on the registry

HatCat 1st November 2013 04:30 PM

Quote:

Originally Posted by KG7 (Post 50769)
This isn't really the right forum to post this seeing as I'm not using Project64, but on the first page is a discussion about God, so...:p

LOL! Sorry about that.
Not really a discussion these years, just something I bumped to troll atheists/non-atheists/kinda everyone.




The rest of what you were saying sounds a lot like the input plugin overlock issues that happen when the hacked Project64k NetPlay solution applies the same controller plugin for all parties (or was it different? been too long, can't remember).

So I know you said you've swapped between Jabo and N-Rage, but only simultaneously for both you and your girlfriend, or only in adversity to the plugin used on the other computer.

KG7 2nd November 2013 08:48 AM

Both of you make a lot of sense...I even tried using the N-rage plugin on one emulator and Jabo's on the other, but the exact same issue happened...If it's true that these Kaillera branches all synchronise the control plugins in order to prevent desyncs, then that makes complete sense to me!

So, even if the emulators didn't save all their settings to registry / to a common location, it's actually an intended feature for it to work this way. I understand now, it's just a shame that I couldn't find a workaround! AH WELL

I just clicked on the last page of the God thread and all I see is this:

http://community.us.playstation.com/...v=mpbl-1&px=-1

Weirdly appropriate reaction for me.

HatCat 2nd November 2013 04:03 PM

Well I have to say of all the time I have played Super Smash Bros. online using Mupen64++ I have never once encountered this issue?

I just find it weird. I've seen what you described reported loads of times with Project64k, though.

Are you sure maybe a clean install of Mupen64++ without changing any settings where unnecessary for both of you wouldn't help? Just set the ROM directory, and that should be enough to start. Use a connection type of "Good", etc..

Also the keyboard plugin I wrote is always non-raw input, so it might solve some problems with Kaillera although in this case it's not as likely. I'm sure you guys aren't keyboard masochists like me anyway. :p

irrelevant_pelican 25th November 2013 11:59 PM

I tried the instructions in this thread and it got it to work for me.


All times are GMT. The time now is 09:52 PM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.