Project64 Forums

Project64 Forums (http://forum.pj64-emu.com/index.php)
-   Project 64 - v2.x - Issues (http://forum.pj64-emu.com/forumdisplay.php?f=2)
-   -   Massive Stuttering (http://forum.pj64-emu.com/showthread.php?t=8082)

KayJay 27th June 2017 07:01 PM

Massive Stuttering
 
https://www.youtube.com/watch?v=tDmZ...ature=youtu.be

The emulator tells me that its around 60 FPS while it stutters like 40fps in both Glide64 and Jabo's Direct3D Plugin. Happens in every game.

I'm out of ideas since I tried everything I could think of, (various compatibility modes, Nvidia control panel options, plugin options).

I think this issue started since my rig is on Windows 10 but it's been a long time so I'm not quite sure.

Specs:

OS: Windows 10

CPU: Intel Core i7 - 4790k, 4.60GHz OC

GPU: Gigabyte GTX 970

RAM: 16GB

retroben 28th June 2017 02:37 AM

Most likely the common Windows DWM issue/s or Desktop Composition (no longer possible to disable due to being removed from the list of advanced performance options) which got worse with Windows 10.
There is supposedly one risky solution involving completely disabling the problem-causing setting which requires you to remove the password from your computer since it uses the visual effects as well.

What kind of monitor do you have and what is its refresh rate?
I would suggest looking into a 120Hz monitor to make things smoother if you can afford one. (I wish I had one myself)

Frank74 28th June 2017 03:21 PM

I added a hidden setting to combat this problem which I had on Windows 8.1.

Open Project64\Config\Project64.cfg with notepad.

Under the [default] section, add CN64TimeCritical=1.

Save changes and restart Project64.

Does it help?

KayJay 28th June 2017 05:16 PM

Quote:

Originally Posted by retroben (Post 70703)
What kind of monitor do you have and what is its refresh rate?
I would suggest looking into a 120Hz monitor to make things smoother if you can afford one. (I wish I had one myself)

Samsung SyncMaster S27B550V
1080p @60Hz


Quote:

Originally Posted by Frank74 (Post 70708)
I added a hidden setting to combat this problem which I had on Windows 8.1.

Open Project64\Config\Project64.cfg with notepad.

Under the [default] section, add CN64TimeCritical=1.

Save changes and restart Project64.

Does it help?

Tried it, it didn't help.

retroben 28th June 2017 06:29 PM

To add from earlier,there is also 144Hz monitors too,but I don't know if those work even better.

I wonder,does your monitor have settings for changing more than brightness,contrast,and colors?
If it happens to have such an extra setting like frame smoothing or something similar,you may be able to work around the problem with it.

theboy181 29th June 2017 03:10 AM

What I have been doing is setting up vsync for the video plugin then turning off frame limit.

This makes things silky smooth

:)

theboy181 29th June 2017 03:13 AM

@frank74

CN64TimeCritical=1

what does that do? this seems to make things better for me on this end too.

:)

Frank74 29th June 2017 02:16 PM

Quote:

Originally Posted by theboy181 (Post 70714)
@frank74

CN64TimeCritical=1

what does that do? this seems to make things better for me on this end too.

:)

It gives the render window a thread priority that's static/constant. Windows processes cannot lower it and take away performance. CN64System thread uses the most CPU cycles.

Some more info about what I did here:
https://github.com/project64/project...ment-146767273

theboy181 29th June 2017 03:12 PM

It seems to work well with OpenGL plugins, however DD7 still has issues for me. Thanks for pointing this out, and how to enable it.

Frank74 29th June 2017 03:34 PM

Quote:

Originally Posted by theboy181 (Post 70718)
It seems to work well with OpenGL plugins, however DD7 still has issues for me. Thanks for pointing this out, and how to enable it.

I used a program called Process Hacker to change/set the priority of the processes being run by Project64.exe. Found a good setting and added it into Project64.

I couldn't alter the Dsound and DirectX priorities through Project64. But you can with Process Hacker. Process Hacker is just a very advanced Task Manager. You can choose to replace task manager with it. It's a very useful tool.

KayJay 29th June 2017 06:18 PM

Quote:

Originally Posted by theboy181 (Post 70713)
turning off frame limit.

This actually worked kind of.

Turning off frame limit in the System tab gets rid of the stuttering, but the music will be sped up in some game menus so I thought setting "Sync game to audio" would correct this, but then the same stuttering reappears.

As of now I'll rather deal with sped up bgm in menus.

Is there a way to save the setting for turning off frame limit?
Each time I boot up the emulator & a game, it's automatically activated again.

Frank74 29th June 2017 06:37 PM

Quote:

Originally Posted by KayJay (Post 70722)
Turning off frame limit in the System tab gets rid of the stuttering, but the music will be sped up in some game menus so I thought setting "Sync game to audio" would correct this, but then the same stuttering reappears.

You need to enable or force VSync in your driver settings, or set VSync in the plugin options if your drivers are set to software controlled.

Then the game will stay at 60VI/s, instead of speeding up with frame limiter off.

There's no way to turn off the frame limiter permanently unfortunately, you have to press F4 or use the menu to turn it off.

Edit: Try my build of Azimer's latest audio plugin, leave it at default settings and it will stay synced to 60VI/s with frame limiter off.

https://www.dropbox.com/s/4atheo4vus...ioNEW.zip?dl=1

zilmar 29th June 2017 11:09 PM

I can not notice it, but that is just likely my eyes, I can not tell the difference between 20fps or 60fps.

The game maybe running 60 vi/sec, but that is not necessarily and most likely not 60 fps. I know some work has been done recently to allow overclocking, more still to be done with it. That allows some games more easily to be able to increase there FPS, other games require cheat code for it.

So maybe some of that work will help here

theboy181 30th June 2017 05:13 AM

I tested this this again frank74 and now its not working.. I wonder why. . I guess I will stick with vsync and FL = off

KayJay 26th July 2017 04:59 PM

I completely fixed the Windows 10 DWM stuttering by setting both Desktop Refresh Rate & Project64 Refresh rate to 59Hz (which is 59.94Hz) instead of 60Hz.
No microstuttering at all on 60 FPS games like F-Zero X.

Wally123 28th July 2017 03:22 AM

Quote:

Originally Posted by KayJay (Post 70702)
https://www.youtube.com/watch?v=tDmZ...ature=youtu.be

The emulator tells me that its around 60 FPS while it stutters like 40fps in both Glide64 and Jabo's Direct3D Plugin. Happens in every game.

I'm out of ideas since I tried everything I could think of, (various compatibility modes, Nvidia control panel options, plugin options).

I think this issue started since my rig is on Windows 10 but it's been a long time so I'm not quite sure.

Specs:

OS: Windows 10

CPU: Intel Core i7 - 4790k, 4.60GHz OC

GPU: Gigabyte GTX 970

RAM: 16GB

The game's count factor needs to be set to 1...right-click on the game, select "Edit Game Settings" to access those options. Also, one thing I have been actively doing is setting all the games to 8 Megabytes in memory size.

KayJay 29th July 2017 12:41 AM

Quote:

Originally Posted by Wally123 (Post 71054)
The game's count factor needs to be set to 1...right-click on the game, select "Edit Game Settings" to access those options. Also, one thing I have been actively doing is setting all the games to 8 Megabytes in memory size.

Read my post above yours.


All times are GMT. The time now is 11:02 AM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.