Project64 Forums

Project64 Forums (
-   Project 64 - v1.6 (
-   -   Zelda Ocarina of time crashes (

alx3400 20th October 2009 10:19 AM

Zelda Ocarina of time crashes

I am at the point where you have to get the water out of the fountain by playing the song of storms. During the sequence where the water sinks down, the game just stops, music keeps on playing and there is nothing you can do anymore.

I already tried another rom, but the same crash keeps happening.

Hope you got an idea

HatCat 20th October 2009 01:09 PM

Actually this has been a reported issue, but it was back in time before support was around to verify it.

So I know what you mean, but it would be beneficial to both of us if you upload a save state of the area you're in, ready to play (or like finish) the Song of Storms to get the cinema and then the crash.

You can write save states through Project64 by hitting F5; then the PJ.ZIP file named after the game is stored in "$Project64\Save".

Upload this somehow, like or attachments system here with the forum should work fine.

alx3400 20th October 2009 01:23 PM

1 Attachment(s)
Alright, here it is. I hope this is what you wanted. I played the song of storms and that movie piece started. Then i pressed F5 some seconds before it crashes.

HatCat 20th October 2009 04:32 PM

1 Attachment(s)
It seems you are using the 1.0 PAL version, just in case others want to check this.

For some reason, I didn't get the crash.
I'm going to send a save state back to you by recreating the file from your scene, so see if it still crashes for you.
Download this to where your Save folder is, (You may rename your old one as a backup if you still need it or something.) and you can just hit F7 to load it.


alx3400 20th October 2009 04:53 PM

It really worked with that file. Your computer must have some kind of healing power ;)

Thanks a lot for the help and I will be back at you of something like it happens again.

HatCat 20th October 2009 05:35 PM

Sure surprised's a shame I didn't get a chance to see it for myself so that I could trace the cause through some configurations.

Sometimes though, some of the controls are saved into memory with a save state, so there might have been some complication that reset what you had when I loaded it before I made that change permanent. An RDB update might have resolved the issue.

Anyway yeah tell us if anything like that happens again.

xRapidDavex 24th November 2009 12:14 AM

Ocarina of Time Song of Storms Crash
1 Attachment(s)
I'm having the exact same issue using project64 v1.6 with default settings. The save I'm uploading is kid link at the shadow temple graveyard. Just run to the windmill and play the song of storms for the crash to happen.

xRapidDavex 24th November 2009 04:32 AM

Ok, so I tried a couple of different things at once and I'm not sure which one fixed the issue.

First, I loaded my profile like normal and then realized I needed to use F7 to restore my quick save (pressed F5 after playing nocturne of shadow). When I loaded my profile I was kid link in my old Kokiri Forest hut (no clue why I started there since I did a hard save in the Temple of Time).

Then I decided to swap out whatever I was carrying to some new things. My final setup was Ocarina left C, Deku Sticks bottom C, Slingshot Right C.

Since both times the game crashed was at night, I decided to play the Sun's song to make it day and this time when I played the Song of Storms it didn't crash.

My best guess is that loading a quicksave is what fixes the issue since that is the only thing I have in common with the guy who posted above me. However, I have no clue if that's right. Hopefully this works for anyone else researching this issue.

HatCat 24th November 2009 07:43 AM

xRapidDavex, you are right.

There may be some sort of machine-dependent reoptimization going on here, but for certain, playing the Sun's Song is the in-game procedure that fixes this.

In the case of the save state you have sent, the crash happened at night. The GameFAQ notes user reports of this being during the day instead; either way whatever was going on, the Sun's Song clears it.

I have an automatic fix for you, too. This looks like another case of self-modifying code at work, and I found that "Change Memory & Cache" (and not "Check Memory Advance") defaults to fix this issue.

So does this help you.
  1. From program settings "Options/Settings...", in the main options disable "Hide Advanced Settings" if it is not already disabled; save changes.
  2. If you have Project64 set to organize installed games in a browser, right-click the label where you see it for Zelda Ocarina of Time, and choose "Edit Game Settings".
  3. Changing the "self-modifying code method" setting to either "Change Memory & Cache" or "Protect Memory" should help stop the hanging here, the later option being more stable but slow and not always needed.
As for what I thought before, well I wasn't sure what to think; like I said something reoptimized itself or something when I regenerated the save state on my end. (Maybe the original tester had a different interference causing the internal hang.)

It happened for me a bit with your save state as well at first, except immediately with yours on the first try I witnessed the report come true for the first time. After I completely changed the game's configuration preset to as stable as possible, I found that there was some change in settings that could fix this, but the next time I loaded your save state after turning everything back to what I had before, I couldn't get the hang to happen again. I re-installed your original state that I had derived from and reproduced it again, so that was the end of that.

squall_leonhart 24th November 2009 09:11 AM


First, I loaded my profile like normal and then realized I needed to use F7 to restore my quick save (pressed F5 after playing nocturne of shadow). When I loaded my profile I was kid link in my old Kokiri Forest hut (no clue why I started there since I did a hard save in the Temple of Time).
only adult link starts in the temple of time.

bican55 5th February 2010 01:12 PM

lens of truth
hi :D if u want the lens of truth on project64 and this bug comes out just press system--->cheats--->have--->lens of truth
tick the box next to it and there u go :D

DennisBDk 19th February 2010 12:48 PM

1 Attachment(s)
:confused:Help the games is just black:confused:

tatsuyamajo 20th February 2010 08:24 PM

I'm also getting a crash/bug.

I'm trying to enter Kakariko Village after completing the Water Temple but when I try and enter from Hyrule Field, the FPS drops from 50 to 5, making it impossible to continue.

In addition, when I enter from the Death Mountain Trail area, I get an error message saying something along the lines of "unhandled exception, emulation stopped".

Any help?

HatCat 20th February 2010 10:01 PM

Try re-installing the RDB file for Project64.

There is an official download for the Project64.rdb file on the Public Downloads section of the main site.

tatsuyamajo 20th February 2010 11:28 PM


Originally Posted by rswedlow (Post 12309)
Try re-installing the RDB file for Project64.

There is an official download for the Project64.rdb file on the Public Downloads section of the main site.

Still nothing. Updated the RDB file, and still get an FPS drop upon trying to enter Kakariko Village.

Edit: After trying it out, the FPS drop also happens when I try and warp anywhere (Temple of Time, Death Mountain Crater etc), so it must be a "loading area" problem.

Any solution?

Second edit: Now I can enter Kakariko Village from Death Mountain, but as soon as I do I get an error message saying

"Unhandled R4300i OpCode at: 801EE290 tnei t0, 0x37A

Stoping Emulation !"

Third edit: Turned off the levitation cheat, and its fine now.

dsx_ 20th February 2010 11:44 PM

Try another graphics plugin.

riotranger 17th June 2012 03:16 PM

1 Attachment(s)
My game just crashed as well, it happened when i entered a house in Kakariko as adult link. I can still hear the music with this black screen and made a save state, but I'm not sure what to do here... it would suck to have to restart all that stuff :/

HatCat 25th September 2012 10:30 PM

That had to do with the Bazaar if you had Advanced Block Linking turned on I believe, so the solution was to disable it so it would not crash.

hunterrockzoom4 30th November 2014 12:23 AM

Didn't work
the save didn't work it said "State save does not appear to match the running ROM."help?:confused:

letsz614 23rd January 2015 03:13 AM

Help please..
I'm having the same problem..when i enter the ganon's castle it works fine, but when I'm going to enter the room where ganondorf is it plays until link is going to look at the mark on his hand and BOOM. It freezes. I save a state before entering the room but to get in when i always try to get freezes on the same please i really want to finish this game.

By the way i'm playing in my phone and i'm using n64oid app..

ExtremeDude2 23rd January 2015 06:21 PM

That has absolutely nothing to do with pj64...

Tv.Johnny 14th November 2015 07:58 PM

My zelda oot crashed at the windmill too... after playing song of storm
1 Attachment(s)
Does anyone think they can save my game save file like they did the other guys and then save it to after the cutscene is done? i really want to continue from my save point..

ZenStarwalker 26th October 2016 09:23 AM


ZenStarwalker 26th October 2016 09:34 AM

oh this is an .sra file, i need a .fla file. lost my save right as i ran into the village on fire after the water temple :S

HatCat 29th October 2016 12:36 AM

There are no .sra files in this thread as far as I can see, nor is a .fla save file going to be usable to OOT in pj64.

geanes 27th January 2017 09:23 AM

Having the same issue here. As soon as I learn the Nocturne of Shadow and Sheik leaves, the game will freeze if I perform any action or wait a small amount of time. Music still plays, just the image is frozen. After being frozen for a bit it will crash and say 'unknown save function, emulation stopped'.

I have a save file from right as I'm learning the Nocturne of Shadow.

Any idea what to do? I'm still trying to apply what I've read ITT, but no luck as of yet.

HatCat 28th January 2017 04:26 AM

Switch to the interpreter in the RDB settings, but it might be too late for that to work if you're testing from a saved state file.

All times are GMT. The time now is 09:44 AM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.