Project64 Forums

Project64 Forums (
-   Open Discussion (
-   -   project 64 2.0 and rogue squadron (

filenotfound 5th April 2013 03:00 AM

project 64 2.0 and rogue squadron
(LOL to myself as i can just imagine everyones first thought when reading this thread title, i bet i get a few automated rogue squadron replies w/o people even reading thread)

Im wondering why the game was able to work in 1.7 and not 2.0?
(yes im fully aware its like impossible to emulate factor5 games in HLE, and that its just a game that never works and etc)

Im using the same plugins, same plugin settings ( RSP plugin), same rom settings, yet on 2.0 it doesnt work and on 1.7 it does.

On v1.7
using jabos d3d8n v5 (even tried the one bundled with 1.7, even tho they appear to be the same)
sound/controller didnt really matter RSP

Then turning off HLE gfx in the plugin settings for the game or in general.
Then changing it to use interpreter rather then recompilier in the game settings and leaving all the other settings on default.

Using the above combination was able to get SW:RS to be fully playable
(tho the minimap was like unusable, the draw distance was kind messed up, it was alittle slow even with a 3.0ghz i5, and the audio was completely messed up) But other then that, it was fully playable lol.

Copying pretty much the exact same settings into the 2.0, it seems to not even get past the logo screen.

So im wondering whats up with it? XD

Im not like begging for you to make the game work or anything, but i was just curious to know why it worked on 1.7 and not 2.0, and/or what other settings need to be changed in 2.0 to get it atleast "playable".

squall_leonhart 5th April 2013 08:05 AM

This game was only ever bootable using the interpreter in 1.7

you can use recompiler once the game has started though.

LLE graphics is regressed in the build 57(Alpha) plugin,
the build 56 version displays more of it, but this game has only ever been really playable with Z64.

Register caching causes geometry issues in 2.0
ad z64 doesn't seem to render the menu's anymore :\

filenotfound 5th April 2013 08:10 AM


Originally Posted by squall_leonhart (Post 44915)
This game was only ever bootable using the interpreter in 1.7

you can use recompiler once the game has started though.

Ya ive seen you post that before, but switching back to the recompilier always crashes me, and ive tried lots of times (on mission select, on ship select, and in the mission), all yield the same result.

A crash with the message

CN64System::LoadFileImage - Exception caught
File: D:\My Programs\Emulation\Project64\Source\Project64\N64 System\N64 Class.cpp
Line: 372

and i dont even have a hdd with a D: label, nor that directory.

SO i always left it on interpreter.
But either way, running the same set up in 2.0 as 1.7, it doesnt get past the logo screen.

Well i tried using the plugins from 1.7 (the ones that were used on 1.7 and they worked).
Also ive explored the Z64 plugin, and i believe that didnt work either, i cant remember the specifics as it was awhile ago.

squall_leonhart 5th April 2013 08:40 AM

i have just found a bug in 2.0 that causes it to not find the z64.conf file.

to resolve this, place it in \screenshots\plugin

and remember to uncomment the rogue squadron lines otherwise you'll just get a blank menu.

for the rom settings, you simply need to untick use HLEGFX and Register Caching

As for Interpreter, the CPU Core Style is not what you need to change.

you need to enable the Debug menu and set the 'RSP > CPU Method' to Interpreter

Generate Log Files=0

or set

CPU Method=0

All times are GMT. The time now is 10:45 AM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.