Project64 Forums

Project64 Forums (http://forum.pj64-emu.com/index.php)
-   Project 64 - v1.6 (http://forum.pj64-emu.com/forumdisplay.php?f=6)
-   -   Rice Video Plugin Errors (http://forum.pj64-emu.com/showthread.php?t=569)

aagame 5th March 2009 10:52 PM

Rice Video Plugin Errors
 
Hey guys, first time post :)
I'm trying to get the Rice Video plugin working so I can play some hi res games, however I'm having a problem when I open the Settings options.

I've placed the "bmglib.dll" file in the core folder, and the "RiceVideo6.1.3DX9.dll" and "RiceVideo.dll" files in the Plugin folder. When I open up Settings, I receive the following errors:

1. This application has failed to start because MSVCP71.dll was not found. Re-installing the application may fix this problem.
2. Failed to load plugin: C:\Program Files\Project64 1.6/Plugin/RiceVideo.dll
3. This application has failed to start because d3dx9_34.dll was not found.
4. Failed to load plugin: c:\Program Files\Project64 1.6/Plugin/RiceVideo6.1.3DX9.dll

Phew. After I click through those, the normal Settings menu pops up with the Jabo plugins there. Can anyone help me with this? I'm not a big Windows user so I'm not too sure what those errors mean.

I've searched the forum and couldn't find someone asking this question already. Sorry if someone has. Many thanks in advance! :)

HatCat 5th March 2009 11:14 PM

MSVCP71.DLL is one of the runtime binaries you can find a dump of through http://www.dll-host.com/. Download this file to where Project64 is stored.

The other library is only needed for the retexturing version that mudlord had improved but can be found through the same way.

aagame 5th March 2009 11:30 PM

Thanks! Works perfectly now.

KefkaticFanatic 19th March 2009 02:50 AM

Hi, I have the same issue, except that when I download this file to the system32 folder or project64 folder it still doesn't work and gives me the same error string. I have found that the d3dx9 file comes with the latest DirectX update, and I'm fairly sure that the other file comes from the C++ Runtime through Microsoft, but I'm not totally sure and am hoping I can use this without having to install it.

EDIT: Wait no, I'm just an idiot and downloaded MSVCP71 when it told me that I was missing MSVCR71.

D:

squall_leonhart 19th March 2009 10:37 AM

the MSVC7 and 71 files are only included with .net 1.0 and 1.0 sp3

nispio 15th April 2010 02:27 AM

Quote:

Originally Posted by Squall_Leonhart (Post 6975)
the MSVC7 and 71 files are only included with .net 1.0 and 1.0 sp3

I just finished installing .net 1.0, and .net 1.0 sp3, and msvcp71.dll did not appear. Are you sure about this?

squall_leonhart 15th April 2010 10:20 AM

oh sorry, 71 is with .net 1.1

lil_alex 18th September 2010 12:31 AM

rswedlow can you help with my project 64 i download it and it says direct 3d failed to initialize
your HAL device make sure you have a properly configured 3d grafics card
compatable with direct3D 6.0!!
default or select video is missing or invalid!! i tried everything but nothing

Experiment #150 18th September 2010 12:37 AM

The select video is invalid or missing, it's not a metaphor.

HatCat 18th September 2010 12:54 AM

heh don't you mean it is a metaphor?

^^lil_alex can you say what your graphics card is? if not try Start Menu > Run > "dxdiag" if you can initialize that then it will tell you info about your graphics processing technology


All times are GMT. The time now is 07:38 PM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.