Project64 Forums

Project64 Forums (http://forum.pj64-emu.com/index.php)
-   Site News (http://forum.pj64-emu.com/forumdisplay.php?f=5)
-   -   Pj64 vs Windows (http://forum.pj64-emu.com/showthread.php?t=66)

Anonymous 24th April 2007 08:20 PM

written by Me
 
Instead or working with no Nt Systems why don't you start working in a linux version? windows98SE, milenium, 95, they are all dead.

Anonymous 25th April 2007 12:46 AM

written by Your grasp of English < a 3rd grader
 
I think you guys should make people pass a grammar/spelling test before allowing them to post.

That said, fuck Win 98. The narcissistic bastards that want you to cater to their needs at the cost of everybody else can go fuck a pig (while admiring themselves in a mirror).

Anonymous 25th April 2007 08:45 AM

written by xiphi
 
I think only XP and Vista(x64 and x86) should be supported. Anyone running earlier versions is just asking for trouble since MS no longer supports Win2k/98/ME.

Also, for those who are confused about Vista's drm, directsound and such...

The DirectSound was removed from hardware to reduce the amount of system crashes due to bad drivers. Now all sound is rendered in software. The only way sound can be rendered through hardware is to have an OpenAL supported soundcard.

As far as DRM in Vista goes, DRM only allows you to PLAY DRM protected content. It does not prevent you from playing your current collection of movies/music/videos.

Driver support has so far proven to be good in Vista, from me and my friends experiences. The same can be said about application support. With that said, not all applications will work on Vista.

In the end, I do hope that DirectX10 can help better PJ64.

pz

Anonymous 25th April 2007 11:33 AM

written by Luppus
 
I agree with xiphi
XP is now becoming old but 98 and older versions are getting archaic
PJ64 should only be compatible with vista and XP and we're all fine

Anonymous 25th April 2007 02:21 PM

written by Sebastián
 
Well, I think that a Linux port would be excellent, but better it would be if ALL of the source code would be released. Maybe someone with some of time would port it to another platforms, and not limited to Linux only. And if to drop or not to drop Win 9x support, well my opinion is do what ever you want. By the way, from Win 9x to Vista those (can I say operating systems?) things are just crap.

Anonymous 25th April 2007 10:01 PM

written by ko
 
first i'd like to say great job on p64 and i wish the best.

if dropping 98/2k/etc support results in more resources that could make p64 better then it should happen. for the long term it's the best.

i'd hate to see supporters of older OSes whine and convince you guys to put the effort to support the older OSes because later it'll come back to haunt you when they upgrade in the future and then complain about why things don't work in Vista.

Anonymous 26th April 2007 01:06 PM

written by Jackson
 
I know we've already been told to stop talking about Linux, but I think a lot of people really would be ecstatic about a Linux version of Project 64. I'm one of them.

Anonymous 27th April 2007 07:36 PM

written by Nekurakami
 
Vista is agendaware with no substantial improvement over XP. It looks better. OOOHH! WOW! What a compelling reason to buy an unfinished, DRM-infested, broken, bloated OS for a totally unreasonable price. Windows 2000 and 98 on the other hand are legitimate operating systems that people still use. I used Windows 98 until about 2004 because I couldn't stand all the useless bullshit stuffed into XP (dog in search bar, stupid GUI, inflated start menu, unnecessary services that run by default like Portable Media Serial Number, Automatic Updates, Indexing Service, Remote Registry, PSMP, IMAPI, BITS, Error Reporting, Fast User Switching, Telnet (who even uses telnet anymore when there's ssh?), etc.).

Vista contains an inordinate amount of unnecessary BS (~10GB worth), is horribly buggy, DRM/TC-ridden, and DX10 does not support a lot of good things that DX9 did in order to more effectively enforce DRM (i.e. no more hardware accelerated audio). Vista forces you to use Microsoft's proprietary filesystems and I could go on for about a week about other reasons why I'm never in my life going to use vista. I'd rather use Fedora Core, SUSE, Windows 2000/98 or even (god forbid) ME. I'd take a bash prompt any day over an overpriced corporate agenda conglomeration with Aero slapped on top of it.

I'd very much appreciate continued support of Windows 2000/98 along with, or better yet instead of support for Vista. Vista was a failure from conception, or as the FSF has aptly said, "Defective by Design".

Thanks a lot and keep up the excellent work. On my next pay check, I'm planning on donating something in the area of $100 to this project (I'm not rich, either :-/).

Cheers, Nekurakami

Anonymous 27th April 2007 08:14 PM

written by .:b{X}s:.CQ
 
Can someone explain to me where the debate is now so I don't have to read all the post above :)

Anonymous 27th April 2007 08:47 PM

written by Nekurakami
 
I know i'm beating a dead horse and I've probably already said more than my share about this topic, but honestly more people use Linux than Vista, and Vista hasn't exactly been an astonishing success. I just don't see the reasoning behind putting hours into making PJ64 vista compatible when it's quite an inconsequential matter considering how many people actually use it and how there are more important things the time could go to (netplay, variable framerates for games, whatever). It's your project obviously and you will do with it what you want. Like ko said, if dropping 98 support will lead to more time spent on more important things, sure go for it. Oh well. Unlike ko said though, there are a whole lot of people who are utterly unimpressed by vista and have no intention of "up"grading until they are absolutely forced to. Adding vista support is a waste of time. Using vista at all is a waste of time and other resources. I did install a copy (I didn't wast money on) on a Athlon X2 5200 with a 7900GT and 1GB of DDR2-800. It still managed to run things slowly. It also took about an hour to install the 10 to 11 GB of shit I'll never use or see the justification of.
And to clarify:
Yes, I've used Vista. I'm not impressed and many people share my sentiments.
Yes I know those unnecessary services can be shut down. It's still ridiculous.

No, I'm not trashing Windows XP. It's much more stable than 98 and below and supports a lot more devices. It's all around "better". Unfortunately, if you can't even use the damn thing without constantly being accosted by asinine animated vermin and asked inane questions like "Do you want to search Windows Update for the driver?" (yeah, right) with the choices of "Not now", "Yes", and "always" (where the hell is "never"?), it becomes more of a pain to use than something that has a Christmas light effect if one program crashes.

Yes I know that the DRM in vista allows you to play DRM'd files and doesn't restrict other files. Part of the problem is that the more mainstream support DRM gets, the more incentive there is to use it.

What I'm more worried about is the Trusted Computing garbage that vista was designed from the ground up to support. My computers take orders from ME. Not some asshat in a suit at Microsoft or any other corporation or entity. While they will always try to pass it off as a way to ensure more "security", it's actually an enormous opportunity to lock out undersirable (from MS's standpoint, not yours) software.

I've said enough and gone horribly off-topic. My main point is that from all of my experience with vista and the literature I've read about it, my conclusion is that Vista is simply an operating system without any legitimate purpose. It's the obligatory new windows from Microsoft that everybody's just expected to eventually adopt. That's it. My opinion is that there are more productive things that can be done with PJ64. And as for the DX10 argument, although I'm no expert on graphics APIs, it seems to me that even DirectX 8 is overkill for N64 graphics. There's only so much you can actually do with the models, lighting and textures that are built into the game, am I right?

If adding Vista support really isn't a problem, go for it. I'd just hate to see 1.7 delayed further in the name of supporting a trash OS. Considering that there's a whole topic about support for operating systems though, I'm assuming a lot would have to go into it.

Anonymous 29th April 2007 12:14 PM

written by xiphi
 
I'm sorry Nekurakami, but many don't feel the same way you do. Many are already using Vista. Anyone who has actually USED it have returned positive results. Unlike the nix and mac fan boys, who just take any chance to bash another os just cause they don't like it. If you don't like it, that's fine. But you get no respect by stating false information. Just like on the system you claimed to have installed Vista on, a pc like that should have installed in 15-20 minutes. I would know, because I have a pc that has an amd x2 3800 and vista installs in 20 minutes.

Take your propaganda back to FSF and keep it there. No one wants to hear it.

Anonymous 29th April 2007 01:09 PM

written by Nekurakami
 
You have obviously never installed Vista then, or installed a much more compact/crippled version. I wasn't using a superfast hard drive at the time, but even so, I can transfer 10-11GB to that drive in a lot less time than it took to install vista. It was Vista Ultimate 64 bit. 15-20 minutes is ridiculous. Oh and BTW, PLENTY of people who have used vista don't like it.

http://hardware.slashdot.org/article.pl?sid=07/04/19/202251
http://slashdot.org/article.pl?sid=07/04/04/1717237
http://it.slashdot.org/article.pl?sid=07/03/31/2317222

To make a comment like, "Anyone who has actually USED it have returned positive results." is not only a naive generalization, but absolutely false, as even one person using it and not liking is means that statement is wrong. I'm not interested in turning this discussion in to a flamewar or anything, but as far as false information goes, you really don't have a leg to stand on. I'll at least admit I have a bias.

Anonymous 29th April 2007 01:19 PM

written by Finnish Enthusiast
 
I suggest that you only support Win 2K/XP/Vista for the time being. I'd like to see what fun you can do with DX10 or latest OpenGL.

Win 95/98/ME is dead. You have perfect PJ64 1.6 for those last 98SE flag wavers. So spare yourselves from the wasted effort of supporting those OS:es.

Linux on the other hand is so light and great for every one, be it older or newer system. Ubuntu is collecting users faster than Vista. So I'd suggest you put a lot of effor to Linux version. (Free hint: Make one quick)

Smiff_ 29th April 2007 02:43 PM

Nekurakami, i don't have time to read everything now, but it's not that we like Vista, it's because Vista is very easy to support when we already support XP (the only reason Vista briefly didn't work was because jabo had a bug which Vista actually helped us to find! it appears to be stricter in some cases) and because PJ64 has always been a Windows emulator. porting to Linux would be a major task. it's possible but the less time spent on non-emulation coding the better at the moment imho.

i will go through these comments and tally up the results when i get time soon.

Anonymous 29th April 2007 03:55 PM

written by Nekurakami
 
Hey, sorry to be a pain

Anonymous 29th April 2007 03:58 PM

written by hey!!!!!! dont drop windows 2000
 
i know Windows 2000 is a buiseness OS but,
windows 2000 is much like xp and it is run on NT just like xp. i think you should drop support for the MSDOS operated systems though like 98,98se, and the worst ME(gag) >:( :( :(. last time i checked 98 wasnt supported by microsoft and im sure that me will be the next to go if microsoft didnt drop it already.if you drop any of them keep the NT systems but drop the MSDOS SYSTEMS,
ME(gag)

Anonymous 29th April 2007 04:08 PM

written by JasonKnight
 
Well, I currently have 2 Computers hooked up right now.

One computer is a Windows 2000 Machine and the other is a Vista Home Premium machine. My Windows 2000 Machine is hooked up to my TV and that is where all of my emulation runs from. As you can see here

http://i68.photobucket.com/albums/i27/JasonKnight298/Vista_CLone.jpg

I understand that screenshot looks like Vista, but its not... its really WIndows 2000 using a program called Aston Shell to make it look like vista.

Anyway, I would love continued support for this Operatoing system since I have already tryed installing XP on this system and it causes nothing but problems while playing heavy 3D games (Project 64 included) but I experence no such problems with Windows 2000.

Anonymous 30th April 2007 12:12 AM

written by Gayman
 
I suggest dropping 98,me,2000,ect. Keep XP, Vista, maybe 2000 but screw me 98 and say fuck 95.

Anonymous 30th April 2007 12:54 AM

written by PgtTurbo
 
Most computers that are running Windows 2000 and higher are most likly going to have the required system requirements to run the emulator. Where as Windows 95 and 98 where mostly used during the time of Processors being below 1.0GHz and when we were still using slow ass SD-RAM. Drop WIN95/98/ME and stick with Win2kPro, XP (all Editions) Vista (all editions)

Anonymous 30th April 2007 07:38 AM

written by jean945
 
I think you should support XP/Vista and 2000 not to sure cause it's not that one half of the world uses 2000. Now everyone uses XP. Making it compatible to 2000 could take more time to make the 1.7 release. ;D The only thing is that it has to run in 128mb RAM computers!

Anonymous 30th April 2007 10:32 AM

written by slimshady007
 
keep Windows 2000 (many computers from '99 through XP's release run Windows 2000 better than XP but still have good enough hardware), XP, and (of course) add Vista

Anonymous 30th April 2007 02:44 PM

written by Kenichi340
 
Keep supporting Windows 2000, XP and add Vista.

Anonymous 30th April 2007 03:30 PM

written by deke
 
mmm these older os is really underated i was a xp user but pc crashed ...got windowsa me and ill never go back to xp now.but i dont program on it do what you want.here would be a os i would use when its complete for a xp subsitute called reactos.

Anonymous 30th April 2007 03:33 PM

written by deke
 
by the way isnt 2000 xp the same in a nut shell ? like 98 me?

Anonymous 30th April 2007 04:00 PM

written by deke
 
another comment jabos jnes is really great!!

AlwaysMC2 30th April 2007 04:16 PM

XP and Vista. That's all that matters.

Anonymous 1st May 2007 06:17 AM

written by Sebastián
 
Well, days ago I wrote about Linux support and became open source. I found something interesting: http://en.wikipedia.org/wiki/List_of_Nintendo_64_games
Now I think that the challenge should be make a checklist of all of the 396 games released for the Nintendo 64 and then try to support all of them (Trying to work perfectly). Later decide about the rest, Linux port, to Vista or not to Vista, Mac or not.
What do you think guys?

Anonymous 2nd May 2007 10:38 PM

written by advenT
 
I use windows 2000, and don't have any plans to change to XP currently... It's a very stable version of windows and uses very little resources in comparison to XP/Vista... also viruses are no longer extensively directed toward it. I would appreciate it if you guys continued to support 2k in your next releases. :)

Anonymous 3rd May 2007 01:05 AM

written by kHound
 
I'd actually suggest keeping support for Win98,98SE and ME: this is because N64 was an old unit and a fair number of the folks into emulation use, they use older OS's.. I can't justify Win95 though....

though I'd prefer Linux support over 9x if that choice had to be made.

Anonymous 4th May 2007 04:02 AM

written by Zyan
 
I think you should drop support for the Win98/ME, but not for Win2000.

I can guess the difficulty, but a Linux/Mac port would be very appreciated!
Wine couldn't be helpful in this case, because PJ64 uses DirectX.. so only Cedega can execute the emulator. Am I right?

Anonymous 4th May 2007 09:52 AM

written by DJ MindPhreak
 
Dont Drop 2000, its still a good os and is actually the best for running PJ

Anonymous 4th May 2007 03:39 PM

written by pog
 
will vista support the Nintendo 64 controlers

Anonymous 5th May 2007 11:51 PM

written by Majin Vegeta
 
Yes, I think too:
You should make the Emulator Win2k compatible, but the older systems are too old to keep the compability.
So...
You should support:
Windows 2000
Windows XP
and Vista

Anonymous 7th May 2007 09:44 AM

written by Andrew
 
First of all you have a really great program, with an easy to use interface.
I Think that Windows 9x probably should be dropped due to functionality issues, but keep 2k and later.
Also Linux would be awesome.

Anonymous 7th May 2007 09:40 PM

written by Mahv
 
Honestly, most people already dislike Vista. I know a lot of people who, when they get their new computers are going to delete Vista and install 2000. Dropping support for 200 would be a major upset and you would lose a lot of different customers. Personally, I don;t like windows at all. I use a mac, but I read up on things like this and in my opinion it would be the worst move you could make to drop support for 2000 and possibly 98. Besides, if you could ever get around to installing pj64 on vista because of all the secruity warnings, you would probably end up having to stop your game 5 minutes in because your computer would ask "you have pushed "up arrow key" for more than 5 seconds, is this correct?". lol. Anyways, that;s an outsiders opinion.

-Mahvimcoo

Anonymous 8th May 2007 11:14 PM

written by lion10
 
Really great, Smiff why you (or one other of the pj64 team) haven't inform the public about your Win9x/ME/2k drop plans a little bit earlier? Since Dez 2006 I and several others worked intensively with rabiddeity to make the completely revised NRage Input-Plugin Unicode and Win9x/ME ready... (http://www.emutalk.net/showthread.php?t=36135) Now well, if the legacy Win32 support needs really so much of work and time then drop it, if it's not such a complex thing then let it be!

Anonymous 9th May 2007 12:50 AM

written by Chris
 
Vista (32-bit, 64-bit), XP (32-bit, 64-bit), Xp media center, win2k.

You should start considering linux versions - linux is on the rise.

Anonymous 12th May 2007 08:54 AM

written by chugger1992
 
I think you should keep Win2k support, but drop 9x support. If your computer is old enough to have those OS's, you probably won't be unning an EMULATOR on them ;)

Anonymous 12th May 2007 11:36 AM

written by everton
 
Is possible migrate code for pj64 for LINUX UBUNTU?

I like play this emulator in linux (not using wine).

thanks.

Anonymous 14th May 2007 12:04 AM

written by Danno
 
Hey, here's an idea - since there are a lot of people who want a linux version (I'm no exception!), maybe you could release the source code to another devteam and let them do the work? The code for PJ64 is probably highly proprietary, so it would likely need work (especially for plugins), but hey! Lots of people are whining about it, so let them (us?) fix our own problem! Just an idea...


All times are GMT. The time now is 03:04 AM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.