Project64 Forums

Project64 Forums (http://forum.pj64-emu.com/index.php)
-   Project 64 - v1.6 (http://forum.pj64-emu.com/forumdisplay.php?f=6)
-   -   Jabo's Direct3D8 v1.7.0.57-ver5 for Project64 v1.6 (http://forum.pj64-emu.com/showthread.php?t=3607)

shunyuan 11th April 2013 07:49 PM

Jabo's Direct3D8 v1.7.0.57-ver5 for Project64 v1.6
 
2 Attachment(s)
GfxWrapper v1.0
--
GfxWrapper is a graphic plugin wrapper to let Project64 v1.6 (only) can use Jabo's Direct3D8 v1.7.0.57-ver5 video plugin. To use GfxWrapper, just copy GfxWrapper.dll and Gfx.dat to the plugin folder then selct Jabo's Direct3D8 plugin v1.7.0.57 (wrap) as your video plugin.


Author:
--
Jabo's Direct3D8 plugin is written by Jabo for Project64 v2.0 and
GfxWrapper is written by shunyuan (shunyuan.chou@gmail.com).


File descriptions:
--
GfxWrapper.dll - GfxWrapper plugin
Audio.dat - Jabo's Direct3D8 v1.7.0.57 plugin


Notice
------
GfxWrapper is compiled with vs2012 and need vs2012 c-runtime to work.


Now we can see the video of Resident Evil 2 on Project64 v1.6.

-----------------
my other plugins:
-----------------
HleAudio: Auido plugin with XAudio2 + DirectSound driver support
SoftGraphic: graphics plugin use mess rdp software rendering
InputWrapper: to use Jabo's Input Plugin v1.7.0.12 for Porject64 1.6

HatCat 11th April 2013 08:01 PM

Now, this, is the kind of thing we could use.

We need a way to use Jabo's D3D8 1.7.x on other emulators because his 1.6.1 etc. plugins had no LLE gfx. We need to test the RDP in LLE sometimes, maybe even outside of pj 2.0.

But the Jabo's DSound 1.7 wrapper? We didn't need that. :D 1.6.1 was better.

ExtremeDude2 11th April 2013 08:12 PM

Nice work :D

shunyuan 11th April 2013 08:25 PM

1 Attachment(s)
Quote:

Originally Posted by FatCat (Post 45232)
Now, this, is the kind of thing we could use.

We need a way to use Jabo's D3D8 1.7.x on other emulators because his 1.6.1 etc. plugins had no LLE gfx. We need to test the RDP in LLE sometimes, maybe even outside of pj 2.0.

But the Jabo's DSound 1.7 wrapper? We didn't need that. :D 1.6.1 was better.

GfxWrapper doesn't support other N64 emulators only for Project64 v1.6. :rolleyes:

I don't want to hack Jabo's D3D8 1.7.x except the emulator checking and I am happy with Project64 v1.6 can run Jabo's D3D8 1.7.x. :D

squall_leonhart 11th April 2013 09:13 PM

make it work for build 56, that'd be useful

shunyuan 11th April 2013 09:33 PM

Quote:

Originally Posted by squall_leonhart (Post 45240)
make it work for build 56, that'd be useful

What's the special for build 56?

HatCat 11th April 2013 09:37 PM

Quote:

Originally Posted by squall_leonhart (Post 45240)
make it work for build 56, that'd be useful

lol, tell me you're not the one assisting this kid.

Respecting Jabo's legacy while turning over it and helping the unstable versions of his plugins get working on the 1.6 EXE?
Don't be so two-faced! :D

It's obvious that the result is shit. The only thing useful is the D3D8 LLE gfx plugin wrapper he made.

Don't assist amateur programmers with naive goals plz k thx bai.

shunyuan 12th April 2013 01:16 AM

Quote:

Originally Posted by FatCat (Post 45247)
It's obvious that the result is shit. The only thing useful is the D3D8 LLE gfx plugin wrapper he made.

I don't agree with what you said. I think let project64 v1.6 and other N64 emulators can use new Jabo's Direct Input Controller and new RSP plugin is not a bad thing. Not to mention the new Jabo's Direct3D8 plugin fixed several graphic issues of good N64 games, such as Resident Evil 2.

Only you need the LLE gfx rendering for debugging purpose, but that doesn't mean except LLE gfx the other stuffs are shit. It is rude to say that.:cool:

The Jabo's Direct Sound Plugin v1.7 is more sophisticated than v1.6.1 and has some options to tweak without UI, I bet you didn't know that.:rolleyes:

shunyuan 12th April 2013 01:19 AM

Quote:

Originally Posted by squall_leonhart (Post 45240)
make it work for build 56, that'd be useful

I just work with GfxWrapper, no changes need. And don't answer my question, since someone question your motivation.;)

HatCat 12th April 2013 01:42 AM

Quote:

Originally Posted by suanyuan (Post 45254)
Not to mention the new Jabo's Direct3D8 plugin fixed several graphic issues of good N64 games, such as Resident Evil 2.

You can download the upgrade Jabo's Direct3D8 here (fixes Resident Evil 2, problems left behind in 1.7.x plugins).

Thank you; please come again.

Quote:

Originally Posted by suanyuan (Post 45254)
The Jabo's Direct Sound Plugin v1.7 is more sophisticated than v1.6.1 and has some options to tweak without UI, I bet you didn't know that.:rolleyes:

You can download the upgrade Jabo's DirectSound 1.6.1 here (fixes hung/unreachable config code stuck in the 1.7.x plugins).

Thank you; please come again.

Quote:

Originally Posted by suanyuan (Post 45254)
Only you need the LLE gfx rendering for debugging purpose, but that doesn't mean except LLE gfx the other stuffs are shit. It is rude to say that.

LLE gfx is the only thing introduced via the use of your wrapper.
Everything else is bugs in the 1.7.x plugins Jabo ended up going back to fix later.

You can download the updated plugins here.
http://www.jabosoft.com/articles/115

"Shit", is the only thing that flies around here.
"Crap", "stuff", "crack", "weed" is all that vulgar stuff!!

Thank you; please come again. :D

Quote:

Originally Posted by suanyuan (Post 45255)
And don't answer my question, since someone question your motivation.;)

Questioning motivations is normal.

We don't take kindly to people around here who don't question motivations! :mad:

I wish I could get people to question my motivations.
But noooooooo, everyone just sits back and says yaaaaaaay, "icono's doing all the work". Pretty much nobody has argued about my work except zilmar I guess.


All times are GMT. The time now is 10:41 AM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.