Project64 Forums

Project64 Forums (
-   Project 64 - v2.x - Issues (
-   -   Crazy Fast Beetle Adventure Racing (

nathanson 1st February 2014 10:04 PM

Crazy Fast Beetle Adventure Racing
Hey I am trying to get Beetle Adventure racing to work, presently it is crazy fast and glitchy with all types of ROMs. There are some old posts (4 years) where the issues were brought up but none where they were solved. Any ideas?

-Computer is plenty fast enough
-Have tried several of the plugin's that were already loaded
-Messed about with fix frame rate to audio

All with no luck, thanks for any help!

retroben 3rd February 2014 10:05 PM

Explain what part is fast.
Is the Audio fast,or is the video fast.

I have it running perfectly with the provided Glide64 plugin.

nathanson 8th February 2014 04:32 PM

The video and audio were both fast, in my impression roughly twice as fast as the actual game with some slowdowns. My VI/s jumped from 100 to 20 every five to ten seconds.

I did have better luck with the glide plugin in terms of graphics but the audio was still slow and the VI/s were still jumping.

What audio plugin are you using?
Have you changed any of the other settings? Advanced settings? Graphic settings? Audio settings?
My computer is good, well beyond the required specs for PJ64 but nothing crazy, is your computer amazing?
What rom are you using? I have tried the (USA) version, the (Europe version) and the .z64 version all with roughly the same outcome.

Thanks for the help and giving me hope!

retroben 8th February 2014 07:18 PM

I can't try anything right now,but here is two audio plugin names.

Azimer's HLE Audio

Shunyuan's HLE audio plugin v1.0

The Shunyuan plugin is on this forum in open discussion.

Here is where to get the latest Azimer's HLE audio plugin update.
Located at the emucr site.


Just edit out the red letters.
Blame the forum rules for the link posting problem.

HatCat 8th February 2014 08:18 PM

Azimer's Audio 0.56 WIP 2 with "Emulate/Simulate AI" unchecked, preferably in Project64 1.6. :p
You could probably do the same on Project64 2.x, maybe with Azimer's new 0.6 release.

0.56 release can easily be obtained from EmuTalk.

nathanson 9th February 2014 04:28 AM

Whelp, I tried Shunyuan's HLE audio plugin v1.8 (couldn't find v1.0) and AziAudio in both PJ1.6 and PJ2.1 and in each case the intro video was crazy fast and then racing was laggy.

Glide is definitely the best looking, but using the default plugins in PJ1.6 made it run best, though with no textures on cars and slow downs happening several times per lap still.

Am I doing something wrong or is this just the nature of playing emulator racing games?

Thanks again!

retroben 9th February 2014 05:39 PM

Try messing with the VI refresh rate in the "edit settings" option in the context menu.
Just right click the game in the game list of PJ64.

Thanks to HatCat for giving me this idea.

I think he once said to set it to a low number like 235 in another thread.

Edit:just tried 225 with a crappy slow speed at 60VI,try using numbers from 1000-2000.

retroben 9th February 2014 10:19 PM

Could someone answer me this?

What is the equivalent of 60FPS/VI in the refresh rate box on PJ64?

The numbers are 1300-2200,which precise value is exactly 60FPS/VI related?

Edit:I just ran Banjo-Tooie perfectly in PJ64 with the No Frameskip code with an insane 6000 on the refresh rate box!

For those interested...

Banjo-Tooie (U)

No Frameskip
8007913C 0080

EDIT:Now I ran Banjo-Tooie with a sadisticly unreasonable 9999 refresh rate value with HailFire Peaks (Icy Side) at 50VI!

retroben 11th February 2014 01:43 AM

I forgot about these...
One bad thing about 2.1 is that the speed limit F4 feature is stupidly considered debug related,forcing you to enable the debugger in order to use it.
Go and do that,then try pressing F4 during a race.

I should have thought of this before,after setting the Game Setting refresh rate back to normal or 2000,try pressing the minus key several times to see if it brings down your speed.
It is the minus key above the qwerty part,not the one on the numpad.

Since your computer way good enough,try enabling VSync in a video plugin that has it.

I hope one of these finally fixes it for you.

All times are GMT. The time now is 07:27 PM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.