Project64 Forums

Project64 Forums (
-   Open Discussion (
-   -   Graphic issues with some games. (

Fangzero 5th April 2009 09:06 PM

Graphic issues with some games.
1 Attachment(s)

I seem to have issues with graphics in some games. I was going through several plug-ins to get the video to work, RiceVideo Plug-in seems to work the best for me as most games I play work fine with it. But some games (Pokemon stadium, vigilante 8) Still have graphic issues. Pokemon stadium plays but the selection graphics are Garbaged up and on vigilante 8 You can't see anything at all, but you can hear sound. Is there any better graphics plug-in or settings i should Adjust? I attached a Screenshot of what I'm talking about for Graphics issues.

My machine is a custom made if that helps any.
-Pentium IV 1.6ghz
-512mb Ram
-32mb nvidia MX 100/200 Graphics card

Currently I'm using for plug-ins are:
-MudLord's Rice video build 6.1.4 for Graphics
-Azimer's HLE Audio v0.56 WIP 2 for Audio
-and N-Rage's Direct input8 V2 1.83 for Controller.

Thanks in Advance.

omegadox 5th April 2009 10:10 PM

Hmm, have you try enabling any "Copy Framebuffer to RDRAM", it looks the game is drawing textures copied from something, but that something is empty.

Fangzero 5th April 2009 10:15 PM

I do not see that option with the Plug-in I listed.

Fangzero 5th April 2009 10:26 PM

Well i think i solved the pokemon Stadium Problem, I changed Rendering to texture from Defualt(None) To Basic Render to Texture. I'll have to test it with the other games. It Works on Pokemon Stadium at least. Now i got to figure out why my Pokemon Red Rom for GB shows up as ?????? when picking it on Stadium. hehe

HatCat 6th April 2009 02:08 AM

Glad you have learned a bit about the configuration yourself.

The following is set for mudlord's RiceVideo bundle.


Which means the basic rendering-to-texture I already had set. The CRCs or regional code of your copy did not match what was in the header here.

Fangzero 6th April 2009 02:25 AM

Well I apprently get the hang of things quick. I fixed the issue with the ????? when using the Transfer pak with a save file, I had to export it from visual boy advance rather then just copying the save. Also works with rockboy on rockbox if anyone uses that.
Vigilante 8 Still won't work even with the changes i did.(Like i did with Pokemon Stadium) I can hear the music but Nothing ever shows up on that game.
Back to the Stadium, I'm assuming because it isn't implemented yet in Project64 but the game freezes when going the the GB Tower on Pokemon Stadium. Any idea how that works?

Thanks for the advice i have been given so far. I usually find what i'm looking for without posting. but it's all good. :)

HatCat 6th April 2009 02:29 AM

The best that can be done with Vigilante 8 is use Jabo's Direct3D plug-in. Change those plug-ins using setting "Settings..." from the menu "Options".

Try doing this for Pokemon Stadium 2 just to see if the game freeze is caused by the graphics plug-in or Project64.

Fangzero 6th April 2009 02:37 AM

Pokemon Stadium 2 also Feezes when going to the GB tower. On both Jabo's and Mudlord's

Vigilante 8 runs at 9fps during game play. When using Jabo's, "Copy Framebuffer to RDRAM" just makes it slower overall but more stuff appears.

HatCat 6th April 2009 02:58 AM

Make sure advanced settings are not hidden (Options:Settings...).
Right-click your installation of Pokemon Stadium 2, and try changing some settings here. First test the self-modifying code method option descending from the setting "Protect Memory". You might also need to see if changing cores from the re-compiler to the interpreter is needed to bypass this hang.

Vigilante 8 has known issues and is probably better off without frame buffer emulation attempts.

Fangzero 6th April 2009 03:40 AM

Ok This what happen at each setting:

-Defualt = Project 64 Crashes
-None = Loops intro
-Cache = Loops Twice then Crashes
-Protect Memory = Hangs at GB tower
-Check Memory & Cache = Crashes
-Change Memory & Cache = Crashes
-Check Memory Advance = Crashes

-Defualt = Hangs at GB tower
-None = Hangs at GB tower
-Cache = Hangs at GB tower
-Protect Memory = Hangs at GB tower
-Check Memory & Cache = Hangs at GB tower
-Change Memory & Cache = Hangs at GB tower
-Check Memory Advance = Hangs at GB tower

Looks Like it might just be Project 64. Maybe it needs some help emulating GB within a N64 Game or something?

omegadox 6th April 2009 12:48 PM


Originally Posted by Fangzero (Post 7358)
Pokemon Stadium 2 also Feezes when going to the GB tower. On both Jabo's and Mudlord's

Vigilante 8 runs at 9fps during game play. When using Jabo's, "Copy Framebuffer to RDRAM" just makes it slower overall but more stuff appears.

"Copy Framebuffer to RDRAM" is a slow option because its copying the whole FB into RAM every frame. It sounds to me, it is optimized, Dolphin has the same kind of option. "Copy EFB to RAM", it barley slows down the game, I wonder if Jabo's plugin doesn't use any fragement shaders to do it, it uses all of CPU power for the copy process ?

HatCat 6th April 2009 05:31 PM

It probably is a known issue, but there may be other memory settings not disregarded by the interpreter that might reveal more.
I can test the settings in the changed beta and other emulators. Can you upload a save state of the area before the crash or hang would happen?

The F5 key creates a zipped save image named after the game in "Project64\Save". Upload this file preferrably either as an attachment to a post in this forum or by using

I want to do some extensive testing on this case.

Fangzero 6th April 2009 08:12 PM

1 Attachment(s)
Alright, I can try. Do you need the GB rom and Save too?

Here is What you asked for i Think.

HatCat 8th April 2009 12:49 AM

I don't think so.

Okay so I loaded this save state in Project64, and the very first time the screen came up black. (This is more natural because of the setting.) I can still exit with the B button, see the screen updated to the select screen, and re-enter the GB tower section. I haven't yet found a way to reproduce any hanging.

Do you still get sound?
Are you sure this happens with both plug-ins? There are ways to simulate hanging with conflicting RiceVideo configurations; it can be a real trick to collect an optimal configurations set for some games.

squall_leonhart 8th April 2009 01:15 AM

frick, using a Geforce 2

Fangzero 8th April 2009 01:19 AM

I know for sure it hangs on Jabo's with the settings I listed earlier. I'll have to test mudlords with the same setting differences.

Fangzero 8th April 2009 01:31 AM

Ok I actually got a little farther in mudlord's, I got a screen with an X on the first controller, when the cpu is an interpreter and self modifying code is cached.

Fangzero 8th April 2009 01:37 AM

1 Attachment(s)
Ok any caching on the self modifying code modes with the interpreter CPU setting show the following on my screen.

squall_leonhart 8th April 2009 01:37 AM

use Jabo's D3D6 1.5.2, it'll work fine for pokemon stadium.

Fangzero 8th April 2009 01:41 AM

1 Attachment(s)
Hahaha, Used what squall said and now I get an error about the transfer pak. any clues for that one?

squall_leonhart 8th April 2009 01:42 AM

the black outline can be fixed by forcing D3D clear mode, or force alpha.

the transfer pack message can be fixed using nrage v2

HatCat 8th April 2009 02:09 AM

Let me know if might not have tested your save state properly.

The transfer pak can be emulated whichever graphics plug-in you use, but if you want to switch controller plug-ins to something that supports emulating that device you can change those and other plug-ins via choosing "Settings..." from the menu "Options".

Fangzero 8th April 2009 02:22 AM

When I first posted this i listed the current Plug-ins I had. that Ngage was the the one i listed for controllers. first just copying the save state from VBA to Project64 gave me a cartridge with a ?????? name, then I used VBA's Export function and got the actual name and ID. But now I get past where I hung, and i get that transfer error.

On the Graphics thing, I can only get past the hang by using the save state. On both of Jabo's and Mudlord's.

squall_leonhart 8th April 2009 02:25 AM

its probably an incompatible rom.

use nrage v2 2.0, its available in the emutalk plugins board.

squall_leonhart 8th April 2009 02:26 AM

btw.. nrage can't read zipped roms.

Fangzero 8th April 2009 02:27 AM

It's unzipped. i know that part.

All times are GMT. The time now is 06:57 AM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.