Project64 Forums

Project64 Forums (http://forum.pj64-emu.com/index.php)
-   Project 64 - v1.6 (http://forum.pj64-emu.com/forumdisplay.php?f=6)
-   -   Gamecube Controller not working... (http://forum.pj64-emu.com/showthread.php?t=3283)

marioman15 23rd September 2012 08:10 AM

Gamecube Controller not working...
 
I recently just bought a gc to pc adapter to use with project 64, as I love the comfort of that controller. I went with the mayflash dual adapter.. mainly out of pricing, but it seemed it would work ok. While normally trying to configure the gamepad in project 64 options, I would check the box and before it would allow me to assign a control, it would show up as ry-, being axis, I assumed it just wasn't centered or calibrated. I found out how to calibrate a controller on windows, following their steps, and it still was out of control during the testing, and same problem during configuration would occur inside of pj64. I tried downloading someone elses default set, and tried loading mario 64, but right after playing, it would show the zoomed in c-camera, not allowing me to move or control the game at all. I have tried two controllers, and the same problem on both of them. They are wavebirds... not positive if thats the problem, as I'm sure it supports wavebirds. The adapter itself was listed as a plug n play, meaning there was no driver to download. I'm pretty new to attempting a controller on an emulator, and was hoping someone here could help me out and possibly give me instructions on how to set this up properly, as I've searched for a couple hours with nothing that really helps. Thanks!
-Payton

ExtremeDude2 23rd September 2012 10:59 AM

Does it work with other programs such as computer games?

marioman15 24th September 2012 12:21 AM

So I got the controller to kind of work, but am not able to calibrate the c stick at all. What I did was downloaded a saved button config, to help with the joystick axit up, down, left and right, and then set my windows config to default, and if i went to calibrate in pj64, set the dead zone to 100%, it wouldnt pick up whatever the ry-, zx+ would be, and I was able to change my jump to a, dive to b and so forth. I then recalibrated in windows so it wasn't default. So i can pretty much play mario 64, without c buttons. I'm not able to use it to change the zoom properly, and when trying to configure, before it gives you the 6 seconds to press a button it automatically selects rx+. It might have something to do with the L and R buttons, as I press that and it kind of acts as one of the axis, especially when testing. Anyone know how to configure the c stick properly while fixing the L and R slider/axis or whatever the computer registers it as?

marioman15 26th September 2012 02:02 AM

has anyone ever experienced gc controllers on pj64?

HatCat 26th September 2012 02:09 AM

I haven't, although I have heard many complaints about the Mayflash adapters and them always having some sort of issue, probably due to poor driver quality.

Did you try both Jabo's DirectInput as well as N-Rage's?

marioman15 26th September 2012 05:58 AM

Yeah I should've researched a bit more which adapter to buy, I saw this one worked with wavebirds and was cheap so I went for it. I did try both of those and was experiencing similar problems.. trying to select a button for each direction is extremelly difficult, and even if you get it to work, the same problem of a button always being pressed occurs. I think I'll just have to invest in a better adapter..

HatCat 26th September 2012 02:23 PM

Unless maybe there is some software upgradeable like the drivers for the Mayflash device, that might be available online somewhere? Then yeah I don't see any other way then to check for a higher-quality product. It's a shame cause I see a lot of negative feedback about it, yet it seems to be one of the most commonly purchased due to its low price.

But if you do get it to work somehow or find a better deal, feel free to tell.

gcman 29th September 2012 02:55 AM

Im having problems with the mayflash devices too, I have a 3 in 1 magic joy box with a gamecube pad and works fine all the way, but when I choose "raw" in the rumble pack the game works like 2 minutes and then get freeze, I think the drivers have a very poor quality and make the force feedback crash. In your case try to not use the adapter in a USB 2.0 port because it doesnt work at all or it will give you some trouble like the one you have!!


All times are GMT. The time now is 03:11 AM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.