View Single Post
  #39  
Old 5th April 2017, 05:06 PM
Frank74's Avatar
Frank74 Frank74 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Aug 2013
Location: UK
Posts: 828
Default

Quote:
Originally Posted by retroben View Post
If "Protect Memory" is on,try disabling that on 2.4,as 1.7 defaults to it being off and that option kills ASM code access for some reason.

Otherwise,try Interpreter to see if anything looks different,or I assume you are already on Interpreter because of the collision issues this game's emulation is known for.

Edit: I am able to activate/deactivate it in real-time via memory viewer on 1.7 when on Recompiler by changing one of the 04s to 08 and back again,so its seems to most likely be another case of Protect Memory being on.
Protect Memory is off by default in 2.4.

I'm not using Interpreter as game is 99.99% perfect collision with GLideN64 since about 3 weeks (Interpreter never helped anyway). I got upto America level without any problems with collision detection. Get the latest WIP here, and it's finally fully playable. No more collision detection problems.
https://github.com/gonetz/GLideN64/i...ment-291160301

The only option I've changed is FAT off. I'm using my own build of Azimer's new audio code with an added option to disable audio thread sleep, which really helps the 60fps hacks be much smoother video with Intel graphics. I check all options in audio plugin. You can try my build here. FAT must be off for body harvest.
https://www.dropbox.com/s/czgzz9z14e...Audio.dll?dl=1

Last edited by Frank74; 5th April 2017 at 05:26 PM.
Reply With Quote