View Single Post
  #3  
Old 17th January 2010, 02:46 AM
in3rtia in3rtia is offline
Junior Member
 
Join Date: Jan 2010
Posts: 1
Default

I just had this same exact problem...
using a authentic n64 controller with a generic usb adapter, for which there are no drivers.
the controller seemed to work fine in XP but i installed windows 7 a few days ago and reinstalled p64, and i had the same problem as you.

but, I fixed it by doing the following (well, not so much a fix but a work-around):

- open up P64
- Go to Options > Settings
- for Input (controller) plugin, instead of Jabo's, select N-Rage's Direct-Input8 V2 1.80a and click OK
- Go back to Options > then Configure Controller Plugin
- Stay under the Controller 1 tab, but switch to the Devices tab
- in the right panel, select your gamepad in the dropdown under Gamepad Devices.
- then go back to the controls tab, and you should be able to map all your buttons - at least, mine worked.

you may want to calibrate the controller in windows before doing this.
For windows 7:
Start > Devices and Printers > right click the gamepad icon > Game Controller Settings > select your gamepad from the list and click properties.

hope this all wasn't terribly obvious information and i hope it helps. good luck