View Single Post
  #105  
Old 20th April 2013, 11:21 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

Quote:
Originally Posted by nintendo1889 View Post
If the MLE version isn't super-accurate as you said, what would be an RSP plugin that I can use with Glide 64 and Jabo's DSound plugin? I know one is HLE and the other is LLE (I think), I probably chose the worst of the bunch to use for testing....sorry for reporting useless info on the tests, seeing as I used the wrong plugin and all

Aw dammit.
HLE can be more accurate than LLE, but generally speaking this is never possible in cases where the LLE is completed.

To play with Glide64 and Jabo's DSound, you do indeed use the `rsp_mle.dll`, so you are using the correct DLL.

However, Glide64 is not a LLE graphics plugin. I cannot control what is sent to the RDP because `rsp_mle.dll` lets a HLE graphics plugin simulate the ucode.
So I am less responsible for what happens.

However, I would not say that means you are testing the wrong file.
suanyuan proved that I had a bug with my HLE support...you could be doing the right thing by testing LLE audio only (plus other rare types) and HLE gfx unlike most people who are using the fully LLE version of my plugin.

[edit] Also, since zilmar cannot remember why he clears the DPC_STATUS_FREEZE bit in the RDP status register for HLE gfx tasks, in the next version I upload I might need your help testing HLE gfx with my MLE plugin.

Last edited by HatCat; 20th April 2013 at 11:23 PM.
Reply With Quote