View Single Post
  #108  
Old 21st April 2013, 12:54 AM
the_randomizer's Avatar
the_randomizer the_randomizer is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Sep 2008
Location: USA
Posts: 1,136
Default

Quote:
Originally Posted by FatCat View Post
Hmm it seems that your understanding is approximate.

MLE means that there is a hybrid of HLE and LLE.
rsp_mle.dll and rsp_lle.dll are both MLE plugins, which is somewhat confusing.
rsp_mle is MLE because the GPU plugin must be HLE; the SPU plugin must be LLE.
rsp_lle.dll is MLE because the GPU must be in LLE; the SPU must be HLE.
They both mix HLE and LLE graphics/audio plugins, just that which one gets inverted.



The thing about Jabo's 1.7, is that it can use either HLE **or** LLE.
It will use, whatever the RSP commands it.
That's why checking "Use high level GFX ?" in Project64 settings makes Jabo's Direct3D run in HLE, whereas leaving it unchecked tells Jabo to do LLE.

Either rsp_lle.dll (HLE audio but LLE gfx) or rsp.dll (LLE every single thing) will do LLE gfx and use the feature.

Um, Jabo's Direct3D8 1.6.1, has no LLE.
Jabo couldn't backport his LLE graphics emulator from 1.7 to his final plugin release for graphics. It might be in part because zilmar upgraded the plugin specs in pj64 1.7 and pj64 1.6 couldn't support those features.



Jabo's sound plugin has always been a LLE sound plugin to my knowledge?

So if you use my `rsp_lle.dll` (again, misleading ... the GPU plugin must be LLE but the audio is done in HLE) with Jabo's LLE audio emulator, you get no sound.
There is no sound when using a HLE RSP with a LLE audio emulator, or vice versa....

So my RSP plugin forces nothing, just relies on the correct graphics and audio plugins to be set in the emulator config, with respect to the correct rsp dll.
Wasn't too sure on the 1.6.1 GPU plugin, but it makes sense now. For LLE, I definitely have the CPU power to do it, so I can try that as well. Unfortunately, Bomberman 64 has some seriously broken audio, so not sure how properly test the game with HLE or LLE audio and the RSP. AI is 40 and VI is at 1400. Would it help to post an audio sample?
__________________
My rig:
CPU: Intel Core i7 4470 3.4 GHz to 3.9 GHz
Video card:: MSI nVidia GTX 970 4 GB GDDR5
OS: Windows 7 Professional 64-bit
RAM: 16 GB DDR3 SDRAM 10600
HDD: 2 x Western Digital 1 TB HDDs
Monitor: 23" Asus Full HD LED

Oh, and Snes9x > Zsnes in every way

Last edited by the_randomizer; 21st April 2013 at 12:59 AM.
Reply With Quote