#1  
Old 24th June 2011, 12:25 AM
Backlash Backlash is offline
Project Supporter
Junior Member
 
Join Date: Jun 2011
Posts: 13
Default Problem with Jabo's Direct Input 1.7.0.11

So I've been using an Xbox 360 controller lately with project 64, and until I tried the latest DirectInput plugin, it had been working perfectly. However, with the recent update, I notice that the d-pad no longer works. I'm unsure if there's a more specific issue, but I thought this would be worth pointing out for future revisions.
Reply With Quote
  #2  
Old 24th June 2011, 02:41 AM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,256
Default

Does the build just before that one work fine (list of builds of the DINPUT plugin via the "View All Files" link)? Also there is a more recent release that might or might not have anything to do with it, but it's an alpha file and might not show up on the list unless the person is in the group for testing alpha files.
Reply With Quote
  #3  
Old 24th June 2011, 02:49 AM
Natch's Avatar
Natch Natch is offline
Project Supporter
Senior Member
 
Join Date: Jan 2011
Location: Nowhere near you.
Posts: 5,075
Default

Is the 360 controller wireless?
__________________
Reply With Quote
  #4  
Old 24th June 2011, 06:43 PM
Jabo's Avatar
Jabo Jabo is offline
Core Team
Alpha Tester
Project Supporter
Project64 Team
 
Join Date: Aug 2005
Posts: 183
Default

can you let me know which version of DirectInput 1.7 worked? specifically which build?

build 11 didn't change much I really don't understand why that wouldn't work.

Additionally build 12 has a ton of changes and I didn't realize that wasn't released, I have to get to that this weekend.
__________________
Project64 Developer
HP Laptop, Intel P7540 with GMA4500, Windows 7
Reply With Quote
  #5  
Old 24th June 2011, 07:05 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,256
Default

Heh...over here, it's already the weekend XD, which means hopefully approximately by the time this guy gets back he'll be able to access the newest version.

Alright so it probably wasn't build 10 that worked if build 11 didn't. Looks like there is a ton of difference between builds 8 and 10 though.
Reply With Quote
  #6  
Old 29th June 2011, 10:31 PM
Backlash Backlash is offline
Project Supporter
Junior Member
 
Join Date: Jun 2011
Posts: 13
Default

Every other build I've used works fine. Currently I'm using 1.7.0.10. And I am using wireless controllers.

Last edited by Backlash; 29th June 2011 at 10:33 PM.
Reply With Quote
  #7  
Old 29th June 2011, 11:10 PM
Backlash Backlash is offline
Project Supporter
Junior Member
 
Join Date: Jun 2011
Posts: 13
Default

I just tried out 1.7.0.12 and it seems to be working correctly now
Reply With Quote
  #8  
Old 30th June 2011, 03:30 AM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,256
Default

Okay so just a temporarily introduced issue. Definitely device support was improved in that newer version you were using. Sounds like it was just particular to builds 10 and 11 then.
Reply With Quote
  #9  
Old 30th June 2011, 04:56 PM
Jabo's Avatar
Jabo Jabo is offline
Core Team
Alpha Tester
Project Supporter
Project64 Team
 
Join Date: Aug 2005
Posts: 183
Default

Quote:
Originally Posted by Backlash View Post
I just tried out 1.7.0.12 and it seems to be working correctly now
totally awesome thanks!
__________________
Project64 Developer
HP Laptop, Intel P7540 with GMA4500, Windows 7
Reply With Quote
  #10  
Old 30th June 2011, 07:50 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,256
Default

nice

malware thread in 1.6 forum

terminate plz

I've been using build 12 all this time of course without issues here as well.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 07:38 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.