Go Back   Project64 Forums > Public Version > Project 64 - v1.6

 
 
Thread Tools Display Modes
  #1  
Old 4th July 2012, 12:38 PM
Sgt.Stedenko Sgt.Stedenko is offline
Junior Member
 
Join Date: Jul 2012
Posts: 4
Default P64 1.6 N-Rage 2.3b Shortcut problem

Hi!
I have a serious problem and looking days for an answer.

Im using a dualshock 3 joystick emulated in a XBox360 controller (motionjoy).

Plugged is selected, Xinput is not
I can use my shortcut keys to change from mempak to rumble when I start a game but I dont feel any vibration in the game.

Plugged and Xinput are selected
I can start Project 64 and play games but my shortcut keys wont work (for changing mempak to rumble). I have to go the shortcut menu and just select save or anything and then it works. Is there a way that it will work whenever i start the game without going to that menu first?


Thanks in advance
  #2  
Old 4th July 2012, 03:21 PM
ExtremeDude2's Avatar
ExtremeDude2 ExtremeDude2 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Apr 2010
Location: USA
Posts: 3,109
Default

Well you set up is bound to have problems, have you tried looking for windows drivers for your PS3 controller?
__________________
Quote:
Originally Posted by dsx! View Post
are you american or something
  #3  
Old 4th July 2012, 06:39 PM
Sgt.Stedenko Sgt.Stedenko is offline
Junior Member
 
Join Date: Jul 2012
Posts: 4
Default

hi, thanks for your response

I think its a problem with motionjoy. When i select only Xinput it doenst recognize a controller (it works with Nulldc when i select Xinput).

Again thanks for the reply
  #4  
Old 5th July 2012, 09:28 AM
squall_leonhart's Avatar
squall_leonhart squall_leonhart is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Mar 2007
Location: Sydney, Australia
Posts: 2,918
Default

nrage doesn't support xinput rumble, so don't use the driver in 360 mode.
__________________

CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
Monitor:ROG PG279Q, BenQ BL2211, Sound:Creative XFI Titanium Fatal1ty Pro
SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX300 1000
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
  #5  
Old 5th July 2012, 11:53 AM
Sgt.Stedenko Sgt.Stedenko is offline
Junior Member
 
Join Date: Jul 2012
Posts: 4
Default

Quote:
Originally Posted by squall_leonhart View Post
nrage doesn't support xinput rumble, so don't use the driver in 360 mode.
Are you sure about that?

I installed new drivers for my DS3 and a vibration file 32 bit for Motionjoy.
Now when I select "plugged" i dont have any rumble but if I select "Xinput" i have rumble . (I now can swith to rumble and mempak in game)

I need this 360 controller emulation because of my other emulators. They all work with vibration (Nulldc, Pcsx2, Dolphin) exept for Epsxe but thats another story . (And im using Mediabrowser for launching games within Media center so changing controller settings each time for each emulator I dont wanne do)

Thanks for your reply!
  #6  
Old 5th July 2012, 02:44 PM
Sgt.Stedenko Sgt.Stedenko is offline
Junior Member
 
Join Date: Jul 2012
Posts: 4
Default

Well I found the problem.

In controller 1 i have to select "Plugged" and "Xinput".
In controller 2 i have to select "Plugged".

Then i can switch to rumble and mempak and it the rumble works
  #7  
Old 9th July 2012, 09:19 AM
squall_leonhart's Avatar
squall_leonhart squall_leonhart is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Mar 2007
Location: Sydney, Australia
Posts: 2,918
Default

im very sure about it. there is no code for xinput rumble in the plugin what so ever.
__________________

CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
Monitor:ROG PG279Q, BenQ BL2211, Sound:Creative XFI Titanium Fatal1ty Pro
SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX300 1000
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 05:48 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.