#1  
Old 17th July 2017, 03:50 AM
jsttu jsttu is offline
Junior Member
 
Join Date: Jul 2017
Posts: 1
Default New to PJ64, Controller isnt recognized

I'm new to the emulation scene, and am trying to figure out how to play banjo tooie on this platform. It didnt automatically recognize my Logitech Gamepad F310 Wired xbox controller, so i explored a bit and set the controller plugin to xinput like i saw other posts advise, and even set the configuration for what each button does. That said, the game doesnt recognize anything is attached, controller or keyboard or anything. I've tried creating controller profiles and loading them, i've tried clicking save or use, nothing changes. Can someone help?
Reply With Quote
  #2  
Old 20th July 2017, 07:40 PM
Wally123's Avatar
Wally123 Wally123 is offline
Senior Member
 
Join Date: Jul 2013
Location: Freedonia
Posts: 155
Lightbulb

If you are using n-Rages' controller plugin, you have to make sure that the "Xinput" box is checked if you are using an Xinput compliant device such as an XBox360 controller. I would also check to see that the controller itself is working....

In Windows 10, there are several way this can happen:
Click on the search button, and type "Controllers"..a control panel icon should show up called "Set up USB Game Controllers"...open it...
The device isn't there, you will have to jack around with the power settings by preventing Windows from turning off your USB devices to conserve power...Instructions are in the link below. If the device is there, you need to test the device itself to make sure it is working properly. I have an F310 and I always had to turn on the device's analog capabilities for it to work...test it using the control panel you opened up by clicking on the device and clicking the Properties button

If the device is there, and working properly while PJ64 is not running, the Windows 10 Game Bar is interfering with it while PJ64 is running. To get around this, you have to turn off the Windows Game Bar either by logging into XBox Live on you PC and changing your settings there (making sure that all streaming, dvr, and hotkey settings are disabled), and in Windows 10 Creators Edition, you have to also go to "Start>Settings (its that gear icon to the left)> Gaming" and turn off every setting there (you don't need "Game Mode").

Here is the link for the power settings trick..It involves using Device manager and does not prevent your PC from shutting down...just be careful:

http://helpdeskgeek.com/windows-xp-t...ff-usb-device/
__________________
"I find television very educating. Every time somebody turns on the set, I go into the other room and read a book."

~Groucho Marx
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 04:54 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.