Go Back   Project64 Forums > Public Version > Project 64 - v1.6

 
 
Thread Tools Display Modes
  #1  
Old 8th September 2011, 11:48 PM
TheDiabeetle TheDiabeetle is offline
Junior Member
 
Join Date: Sep 2011
Location: I wish I knew so I could finally go home...
Posts: 6
Question N64 controller Analog stick problems

Hi, i ordered a Mayflash USB N64 adaptor, a popularly used one as far as i can tell, a few days ago and just started using it with my snazzy clear purple controller (the stick is barely even loose after years of use). I came on here looking around to see how to configure it, and if i need to update the plug ins for what pj64 1.6 comes with. Which ive done, upgrading nrage to 1.83. Anyways, after setting the controls up i went to play Banjo-Kazooie to test it out.. Every button works as it should, except that the buttons seem to feel like they are being mashed repeatedly (ex: Banjo would jump when i pressed A, but instantly turned into the hover jump [double A]. The only solution i found was press lightly and fast, a hard task to master for playing a game... I also have another problem that might be connected to this, my control stick doesnt respond the way it should. Up is up, down is down, ect. but it only lasts for a second (Banjo will turn the desired direction, but not walk or run).

Any ideas?? I can't be the only person who has ever had this problem. At least i hope not... And I am dreadfully sorry if this is a frequently asked question.
__________________
We are the music makers, and we are the dreamers of dreams - Willy Wonka
  #2  
Old 9th September 2011, 12:27 AM
TheDiabeetle TheDiabeetle is offline
Junior Member
 
Join Date: Sep 2011
Location: I wish I knew so I could finally go home...
Posts: 6
Default

Oh, forgot to mention, im running this on WINE, if that matters.
__________________
We are the music makers, and we are the dreamers of dreams - Willy Wonka
  #3  
Old 9th September 2011, 02:23 AM
Natch's Avatar
Natch Natch is offline
Project Supporter
Senior Member
 
Join Date: Jan 2011
Location: Nowhere near you.
Posts: 5,075
Default

WINE being a windows emulator, yes? We don't really support that, but the only reason that would stop us from being able to help is if that was the problem (which it most likely is.)

1.83 is the latest version that was created by the original designer AFAIK. A dood named Rabiddeity and our very own Squall_leonhart created a newer version, which you can download here.

Go ahead and install that, and make sure that the controller is calibrated.
__________________
  #4  
Old 9th September 2011, 02:48 AM
TheDiabeetle TheDiabeetle is offline
Junior Member
 
Join Date: Sep 2011
Location: I wish I knew so I could finally go home...
Posts: 6
Default

Yea, well WINE doesnt "emulate", but thats basically the idea. Idt WINE is the problem, just thought I should say just to be sure. Thanks for the nrage download though! I hope that I just calibrated it wrong.
__________________
We are the music makers, and we are the dreamers of dreams - Willy Wonka
  #5  
Old 9th September 2011, 08:55 AM
dsx_ dsx_ is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2010
Location: Australia
Posts: 1,105
Default

the mayflash adapters are sometimes unpredictable though
  #6  
Old 10th September 2011, 12:21 AM
TheDiabeetle TheDiabeetle is offline
Junior Member
 
Join Date: Sep 2011
Location: I wish I knew so I could finally go home...
Posts: 6
Default

How so? Because it appears in the pj64 config settings, it just doesn't work 100% correctly in the actual games.
__________________
We are the music makers, and we are the dreamers of dreams - Willy Wonka
  #7  
Old 10th September 2011, 11:34 AM
squall_leonhart's Avatar
squall_leonhart squall_leonhart is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Mar 2007
Location: Sydney, Australia
Posts: 2,917
Default

WINE IS AN EMULATOR
regardless of what those faggot winerdevs say.
__________________

CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
Monitor:ROG PG279Q, BenQ BL2211, Sound:Creative XFI Titanium Fatal1ty Pro
SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX300 1000
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
  #8  
Old 10th September 2011, 05:44 PM
TheDiabeetle TheDiabeetle is offline
Junior Member
 
Join Date: Sep 2011
Location: I wish I knew so I could finally go home...
Posts: 6
Default

I suppose it is, but not in the way others are. Converts most stuff to unix, at least as far as I understand it. I think that technically doesn't make it an emu, but it does the same thing so for most people its interchangeable, unless you are doing something like really complicated on it.
__________________
We are the music makers, and we are the dreamers of dreams - Willy Wonka
  #9  
Old 12th September 2011, 02:13 AM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

Well there are different devices an emulator uses; for example it doesn't always have to act as a virtual machine for a completely different system.

Semantically though, we get to exclude a most common context and use that to say it's not an emulator.

Don't know the details though quite honestly since I haven't used it.
  #10  
Old 6th June 2012, 01:00 AM
TheDiabeetle TheDiabeetle is offline
Junior Member
 
Join Date: Sep 2011
Location: I wish I knew so I could finally go home...
Posts: 6
Default

Its been a while since i posted this so idk if anyone will notice, but in hoping that someone does...

I am no longer using Linux on my computer, and so I wanted to try at this emulator business again. You guys said that WINE was most likely the problem, so I assumed it would work this time. Thing is, I have the same problem that I did before. Anything else I could try?
__________________
We are the music makers, and we are the dreamers of dreams - Willy Wonka
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 03:34 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.