Go Back   Project64 Forums > Public Version > Project 64 - v2.x - Suggestions

Reply
 
Thread Tools Display Modes
  #1  
Old 10th May 2011, 08:02 PM
Biff Tanner Biff Tanner is offline
Junior Member
 
Join Date: May 2011
Posts: 6
Default Conkers BFD 4 Player controller fix

Hi there.

Used to use PF64 many years ago with friends playing multiplayer games, many happy memories but one game I do remember that didnt work properly unfortunately was conkers bfd when playing with 4 player.
When playing the beach MP game when you have 4 players, for the right 2 players the camera constantly pans left so it is unplayable for those 2 players.

Downloaded 1.6 to see if it was something that was fixed with newer versions but unfortunately it was not, so thought I'd stick this here to beg and see if it could be something that could be fixed when the public version of 1.7 is released, as its the one game I still yearn to play on the N64 that isnt possible.
If this has already been fixed in the beta version of 1.7 my apologies.
Reply With Quote
  #2  
Old 10th May 2011, 08:26 PM
Natch's Avatar
Natch Natch is offline
Project Supporter
Senior Member
 
Join Date: Jan 2011
Location: Nowhere near you.
Posts: 5,075
Default

You could always try a different graphics plugin, via settings.
__________________
Reply With Quote
  #3  
Old 11th May 2011, 12:51 AM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

I'm not sure, as I'm not familiar with the game. Testing has had better results for many with Glide64 if you want to try that plugin and switch like natnatertatertot suggested.
Reply With Quote
  #4  
Old 11th May 2011, 05:38 PM
Biff Tanner Biff Tanner is offline
Junior Member
 
Join Date: May 2011
Posts: 6
Default

Unfortuantely its not a plugin issue to the best of my knowledge, it was noted a while ago that it was a core issue that happened on all emulators.

I did give the glide plugin a try hoping that it could have been that but the same problem still occurs.
I should say that this is a problem that is on all 3/4 player multiplayer games on conkers not just the beach level as originally stated.
Reply With Quote
  #5  
Old 11th May 2011, 06:09 PM
ExtremeDude2's Avatar
ExtremeDude2 ExtremeDude2 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Apr 2010
Location: USA
Posts: 3,112
Default

hmm... is this a gfx problem or a input problem
Reply With Quote
  #6  
Old 11th May 2011, 09:19 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

Well I know I sure didn't see a note of this in the official GameFAQ or RDB.

Try Mupen64 0.5.1 for Windows to see if that happens to have any internal core support for this.

Otherwise if you can upload a saved state to quick jump to the point in game so that other people can test it would make testing and any fixing easier.
Reply With Quote
  #7  
Old 12th May 2011, 12:21 AM
ExtremeDude2's Avatar
ExtremeDude2 ExtremeDude2 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Apr 2010
Location: USA
Posts: 3,112
Default

Quote:
Originally Posted by Iconoclast View Post
Try Mupen64 0.5.1 for Windows to see if that happens to have any internal core support for this.
Or 1964?
Reply With Quote
  #8  
Old 13th May 2011, 06:27 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

oh lol, well while I'm waiting for the free download without having to register, you're sure that this isn't a bug that happens on the original N64 hardware? Because a lot of games surprisingly can and do have bugs like this.
Reply With Quote
  #9  
Old 14th May 2011, 10:04 AM
Biff Tanner Biff Tanner is offline
Junior Member
 
Join Date: May 2011
Posts: 6
Default

I can confirm this is something that doesn't happen on the actual N64 version as I have had many games of this 4 player and its something I never saw.

At first I thought it might have been a input plugin issue with the c buttons as I thought they might control the camera panning but they actually deal with strafing so it seems like it would be an core emulator issue I would think.
Reply With Quote
  #10  
Old 14th May 2011, 03:34 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

Thanks for providing the saved state.

It isn't an issue with controller input plugins, even though I have tested 3 of those as well. Camera movement signals might be able to be controlled by it, but the signals themselves are defined in the ROM. It would be somewhere in the main emulator like you had said or maybe an RSP instruction I guess.

It either is a native camera problem that happens on the original hardware or an instance of unsupported code in both Project64 1.6 and Project64 1.7. For now I'll presume what you're saying is true that it does not happen on the original hardware and have these notes hooked in the alpha forum so that anyone there can look at the saved state--maybe find an implementation in the beta that fixes this problem if it truly isn't native to the hardware.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 11:53 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.