Go Back   Project64 Forums > Public Version > Project 64 - v2.x - Issues

Reply
 
Thread Tools Display Modes
  #1  
Old 10th December 2018, 09:24 PM
Chocolateapot Chocolateapot is offline
Junior Member
 
Join Date: Nov 2018
Posts: 3
Default Goldeneye 64 - Multiplayer portraits not rendering correctly

Hi all!

First off, a big thanks to the Project64 community for all the work everyone's put in, it's been wonderful to revisit my childhood and crack out some old classics on my laptop

Now, to the issue at hand. I've searched around these forums quite a bit (also Google generally) and I apologise if this has been answered before, but I'm experiencing some issues with the portraits rending in Goldeneye 64 multiplayer using Jabo's Direct 3D8 1.7.0.57-ver5 graphics plugin. They sort of look... squashed/stretched? I've attached a picture of this.

Now, I've seen from my searches, that Jabo's plugin is closed source, so I realise that the problem is likely unfixable, but I wondered if I've done something wrong in the set up (i.e. not checked a particular box in the settings etc) or if anyone else is experiencing this? Another thing I have noticed (which I'm pretty sure is related) is that in the watch pause menu, there are graphical glitches when scrolling up an down to select weapons. So, as the multiplayer selection is a scrolling menu of sorts which causes Jabo's plugin some grief, I wondered if there is a connection... I've also attached a picture of this.

These issues occur in windowed mode and fullscreen, checking and unchecking the 'stretch' option, at 640x480 resolution and switching between integrated graphics and dedicated graphics on the laptop.

I just wondered if there was a known fix for this, the plugin is great and of course this is just a minor issue, it's just that it would be lovely to have the game running as close to the original as possible

Thanks in advance for your help!
Attached Images
File Type: jpg GE multiplayer screenshot.jpg (51.4 KB, 3 views)
File Type: jpg GE watch menu.jpg (28.6 KB, 2 views)
Reply With Quote
  #2  
Old 11th December 2018, 01:17 PM
ExtremeDude2's Avatar
ExtremeDude2 ExtremeDude2 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Apr 2010
Location: USA
Posts: 3,116
Default

Have you tried glide64 gfx plugin?
__________________
Quote:
Originally Posted by dsx! View Post
are you american or something
Reply With Quote
  #3  
Old 11th December 2018, 10:39 PM
Chocolateapot Chocolateapot is offline
Junior Member
 
Join Date: Nov 2018
Posts: 3
Default

Thanks very much for your reply!

I'd tried out Glide64 before and tested it again just now. While it seems to play quite nicely in single player, unfortunately the audio becomes quite choppy in multiplayer when two players are running around in the same room. I'm using Azimer's audio plugin and even tried switching back to the stock Jabo audio but of course that made things even worse. I also tried switching between my integrated graphics and dedicated Geforce 710m, but this didn't seem to work (as a side note, bizarrely Jabo's runs far more smoothly on integrated gfx). I also set counter factor to 1 and tried running it in 640x480, alas, this didn't yield much improvement.

Also, can you play on Glide64 in widescreen? I only seem to be able to run it in 4:3 ratio with black bars either side.

I'm guessing this glitch on Jabo's gfx plugin is unfixable then?
Reply With Quote
  #4  
Old 13th December 2018, 01:01 AM
ExtremeDude2's Avatar
ExtremeDude2 ExtremeDude2 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Apr 2010
Location: USA
Posts: 3,116
Default

Any beta builds yeah, maybe you could try jabo 1.6
__________________
Quote:
Originally Posted by dsx! View Post
are you american or something
Reply With Quote
  #5  
Old 14th December 2018, 08:55 PM
Chocolateapot Chocolateapot is offline
Junior Member
 
Join Date: Nov 2018
Posts: 3
Default

Thanks for your suggestion!

I just tried Jabo's 1.6 gfx plugin, but it still has the same stretched portrait issue as the latest version. I'm surprised more people haven't reported the issue...

On a side note, does anyone know what causes the graphical glitches upon firing in Goldeneye in Jabo's Direct 3D8 1.7.0.57-ver5? It sort of makes the muzzle flash look square? I've noticed sometimes just going into windowed mode and back to fullscreen fixes it for a short while, but then it comes back. On one of the threads on this forum someone said the way to fix it was to check 'protect memory' and that fixes it. But from my experience, having it checked or unchecked makes no difference.

Does anyone know of a way to fix this? Is there a setting on top of 'protect memory' that you need to check to get rid of the glitch?

I've attached a picture of it.
Attached Images
File Type: jpg Gunfire glitch.jpg (48.7 KB, 3 views)
Reply With Quote
  #6  
Old 15th December 2018, 01:57 PM
ExtremeDude2's Avatar
ExtremeDude2 ExtremeDude2 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Apr 2010
Location: USA
Posts: 3,116
Default

Sounds like it must me a system or config issue, know idea what tho.
__________________
Quote:
Originally Posted by dsx! View Post
are you american or something
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 06:02 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.