Go Back   Project64 Forums > General Discussion > Open Discussion

Closed Thread
 
Thread Tools Display Modes
  #521  
Old 21st May 2014, 04:43 AM
the_randomizer's Avatar
the_randomizer the_randomizer is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Sep 2008
Location: USA
Posts: 1,136
Default

Quote:
Originally Posted by not a pj64 nut hugger View Post
lol emulators
Who the hell are you? Another random wanker?
__________________
My rig:
CPU: Intel Core i7 4470 3.4 GHz to 3.9 GHz
Video card:: MSI nVidia GTX 970 4 GB GDDR5
OS: Windows 7 Professional 64-bit
RAM: 16 GB DDR3 SDRAM 10600
HDD: 2 x Western Digital 1 TB HDDs
Monitor: 23" Asus Full HD LED

Oh, and Snes9x > Zsnes in every way

Last edited by the_randomizer; 21st May 2014 at 04:46 AM.
  #522  
Old 21st May 2014, 05:47 AM
ExtremeDude2's Avatar
ExtremeDude2 ExtremeDude2 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Apr 2010
Location: USA
Posts: 3,116
Default

ur mum
__________________
Quote:
Originally Posted by dsx! View Post
are you american or something
  #523  
Old 21st May 2014, 08:56 AM
the_randomizer's Avatar
the_randomizer the_randomizer is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Sep 2008
Location: USA
Posts: 1,136
Default

Quote:
Originally Posted by ExtremeDude2 View Post
ur mum
No wait, the guy's just another brain-dead twat who thinks he's funny. Carry on.
__________________
My rig:
CPU: Intel Core i7 4470 3.4 GHz to 3.9 GHz
Video card:: MSI nVidia GTX 970 4 GB GDDR5
OS: Windows 7 Professional 64-bit
RAM: 16 GB DDR3 SDRAM 10600
HDD: 2 x Western Digital 1 TB HDDs
Monitor: 23" Asus Full HD LED

Oh, and Snes9x > Zsnes in every way
  #524  
Old 21st May 2014, 09:01 AM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

I don't really care if dsx wants to keep posting here, but nintendo man, you gotta learn when to let dead threads die. Nobody in their right mind is going to talk about audio-related matters with you in a thread like this; if you want attention on that try asking elsewhere.
  #525  
Old 21st May 2014, 10:39 AM
the_randomizer's Avatar
the_randomizer the_randomizer is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Sep 2008
Location: USA
Posts: 1,136
Default

*Removed post for various reasons and so on* This thread is dead.
__________________
My rig:
CPU: Intel Core i7 4470 3.4 GHz to 3.9 GHz
Video card:: MSI nVidia GTX 970 4 GB GDDR5
OS: Windows 7 Professional 64-bit
RAM: 16 GB DDR3 SDRAM 10600
HDD: 2 x Western Digital 1 TB HDDs
Monitor: 23" Asus Full HD LED

Oh, and Snes9x > Zsnes in every way

Last edited by the_randomizer; 21st May 2014 at 10:48 AM.
  #526  
Old 21st May 2014, 10:47 AM
RPGMaster's Avatar
RPGMaster RPGMaster is offline
Alpha Tester
Project Supporter
Super Moderator
 
Join Date: Dec 2013
Posts: 2,008
Default

HatCat is saying that "not a pj64 nut hugger" is dsx lol..
  #527  
Old 21st May 2014, 10:48 AM
the_randomizer's Avatar
the_randomizer the_randomizer is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Sep 2008
Location: USA
Posts: 1,136
Default

Quote:
Originally Posted by RPGMaster View Post
HatCat is saying that "not a pj64 nut hugger" is dsx lol..
Dammit, yeah, disregard what I sent ya earlier. I don't know much about DSX but he sounds like a run of the mill twat.
__________________
My rig:
CPU: Intel Core i7 4470 3.4 GHz to 3.9 GHz
Video card:: MSI nVidia GTX 970 4 GB GDDR5
OS: Windows 7 Professional 64-bit
RAM: 16 GB DDR3 SDRAM 10600
HDD: 2 x Western Digital 1 TB HDDs
Monitor: 23" Asus Full HD LED

Oh, and Snes9x > Zsnes in every way
  #528  
Old 21st May 2014, 01:14 PM
run of the mill twat run of the mill twat is offline
Member
 
Join Date: Apr 2014
Posts: 38
Default

Quote:
Originally Posted by the_randomizer View Post
I don't know much about DSX but he sounds like a run of the mill twat.
why do you think that :P
  #529  
Old 5th June 2014, 04:51 AM
Wally123's Avatar
Wally123 Wally123 is offline
Senior Member
 
Join Date: Jul 2013
Location: Freedonia
Posts: 159
Lightbulb

Quote:
Originally Posted by shunyuan View Post
---------------------------------
HLE audio plugin v1.8.2u1
---------------------------------
HLE audio plugin is written by Shunyuan with features:

* Zilmar's audio plugin spec #1.2 for pj64-2.0, spec #1.1 for other emulators
* XAudio2, DirectSound8 and No Sound driver support.
* XAudio2 upmix to 5.1 ~ 7.1
* prebuffer stream audio
* HLE interface
* LLE interface
* audio thread to update sound buffer
* tested with pj64 1.6, pj64 1.7, pj64 2.x,
1964 svn r146, 1964_ultrafast 3.0, and mupen64 5.1.
* auto sync game to audio
* dynamic plugin interface
* Lua interface to tweak per game settings


Special thanks:

Zilmar for the great Project64 emulator and his plugin system design.

nintendo1889 for testing and push me to improve the audio quality of this plugin every time.

CXD4 for his LLE RSP module, source of rsp_interface here.

--------
Note:
--------
From 2013/04/23 to 2013/05/17

I have implemented all the features that I need, so there won't be a new release in short time.
Thanks for people that help me to develop and debug this plugin.


------------
Lua script to tweak per game settings
---------------

view the Lua script here:

------------
Bug Report
------------

Please post your bug report with following information:

(1) OS & System spec
Windows 7 - 32 bit, 4 GB RAM

(2) emulator spec
Project64 2.1

(3) Plugin version
HleAudio 1.7.1

(4) Game and setting
RR64 (USA)
Sound Driver=XAudio2
Playback Rate=48000
Fixed Audio Timing=0
Sync To Audio=0
VI Refresh Rate=2200
AI couter per byte=500

(5) bug description
audio speep-up (too fast)
....

(6) Did this bug exist in previous version of HleAudio?


(7) Audio Record (optional, but very useful)
download link

--------
Then I will try to fix the bug if possible.


--------
History:
--------

v1.8.2u1
* fixed sometimes mupen64 and 1964 failed to initialize XAudio2 driver.
* Lua script fixed World Driver Championship no audio

v1.8.2
* Fixed Excitebike 64 sound crackling
(Counter Factor=1, Fixed Audio Timing=0, Sync using Audio=0)
* add new settings for Lua script

v1.8.1
* Fixed syntax errors for Lua script
* Fixed official pj64 1.6; can't use the Lua script to tweak per game settings.
(no more need for the pj64 1.6 HleAudio Fixed version)
* Fixed missing audio for Top Gear Rally

v1.8
* Open Lua interface implemented to tweak per game settings
(official pj64 1.6 doesn't support this feature because it won't call the audio plugin 'RomOpen' function, use the pj64 1.6 HleAudio Fixed version instead)

v1.7.1u9
* Fixed audio slow down for A Bug's Life.
* Add DirectSound hardware acceleration option in the UI
(default is off, for Vista and Win7 you need ALchemy, 3D SoundBack or Xear3D EX to take advantage of this feature)

v1.7.1u8
* Fixed Super Smash Bros sound delay for PJ64 2.x
* Fixed Super Smash Bros sound crackling for PJ64 1.6

v1.7.1u7
* Fixed Paper Mario sound crackling
(Counter Factor=1, VI refresh rate=2200, AI count Per byte=500,Fixed Audio Timing=0, Sync using Audio=0)

v1.7.1u6
* work around implemented for the project64 SP DMA read error

v1.7.1u5
* added UI to select output device
(useful if you have multiple sound cards or install DSP plugin such as a DFX audio enhancer)

v1.7.1u4
* playback rate support up to 192 KHz
* playback bits support up to 24 bits (now support 16 ~ 24 bit playback)
* Fixed no audio bug for Top Gear Rally (USA)
(AI Count Per Byte=500, Fixed Audio Timing=1, Sync To Audio=0)

v1.7.1u3
* Fixed no audio for Killer Instinct Gold (USA) 1.2

v1.7.1u2
* support for XAudio2 upmix (surround)
(tested with SRS Audio SandBox)

v1.7.1u1
* Fixed XAudio2 crash for pj64 1.7.0.50b23
* Fixed audio speed up issue reported by nintendo1889
* Fixed pj64 1.7.0.50b23 compatibility error reported by Goldlink11

v1.7.1
* Fixed no audio after restore game state
* Fixed audo speed up of Mystical Ninja Starring Goemon
* Fixed cannot change sound driver after end emulation
* Fixed compatibility issue of pj64 1.7.x

v1.7
* dynamic interface for project64 2.x and other emulators, now HleAudio will provide an interface from 1.2 to pj64-2.0,
and provide interface 1.1 to other emulators.
* added XAudio2 driver support
* added No Sound driver support
* removed the redundent initialization and checking from HLE emulation

v1.6.2
* improved the audio quality when "Fixed Audio Timing" and "Sync to Audio" options off
* improved the frame rate of N64 games that use 32 KHz audio
* released the source code for the rsp_interface

v1.6.1
* added OSD to show the plugin's internal data in real time
(need RivaTuner Statistics Server to display OSD)
* implemented auto sync game to audio feature for other emulators. Now N64 games with 32 KHz audio
such as Zelda OOT, Bomberman 64, F-Zero X should sound better without crackling on 1964, mupen64 and pj64 1.6.

v1.6
* changed interface to Zilmar's Common Audio plugin spec, version #1.2,
because currently only project64 2.x CPU core supports "Sync using Audio" feature
* integrated with Project64's setting manager.

v1.5
* integrated with project64 2.0 "Fixed Audio Timing" & "Sync using Audio" options,
now Bomberman 64, Zelda OOT, Resident Evil 2 sound crackling should Fixed when
these two options are enabled
* Fixed the bug where no was audio playing when loading more than one rom
* Fixed the noises when the plugin dialog was loaded
* Fixed the sound crackling for RR64

v1.4
* Fixed the slow down caused by streaming audio flow control (Bomberman64 back to 60 fps)
* Fixed audio plugin crashes caused by intenal multi thread errors

v1.3
* enhanced code to handle audio data underrun and overrun, Fixed the sound crackling of Zelda OOT and F-Zero X.

v1.2
* tweak for 1964 a little bit
* add UI for DirectSound settings

v1.1
* Fixed the the sound crackling of Mario64 (sound blocks 1024x4 are too small)
* added code to round the sound frequency to 32027 => 32000, 22057 => 22050 (thank CXD4's suggestion)
* added code to show debug messages when unknown system types are detected

v1.0
* the first release.

----------
Preview:
----------
Mystical Ninja Starring Goemon
San Francisco Rush 2049
Zelda OOT
Bomberman 64
Resident Evil 2
Ridge Racer 64

-----------------
my other plugins:
-----------------
ShunyuanDI: Shunyuan's DirectInput8 plugin
SoftGraphic: graphics plugin use mess rdp software rendering
GfxWrapper: to use Jabo's Direct3D8 v1.7.0.57-ver5 with Project64 1.6

Be sure to use the RSP Plugin Version 1.7.0.9 for the rather excellent DSP plugin to work ;-)
__________________
"I find television very educating. Every time somebody turns on the set, I go into the other room and read a book."

~Groucho Marx
  #530  
Old 5th August 2014, 05:27 PM
Zapfy Zapfy is offline
Junior Member
 
Join Date: Jun 2013
Posts: 6
Default

Hi. Not sure if anyone still looks here but I have a problem. Sometimes, the audio will be de-synced from the video until I enter a loading zone. For example I'll start up SM64, and the audio will be off until I enter the castle, where it will be fine. This happens on other games as well. Anyone got any advice? Thanks.
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 04:03 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.