Go Back   Project64 Forums > Public Version > Project 64 - v2.x - Issues

Reply
 
Thread Tools Display Modes
  #1  
Old 30th July 2009, 05:13 AM
Moohaumed's Avatar
Moohaumed Moohaumed is offline
Junior Member
 
Join Date: Jul 2009
Posts: 11
Thumbs down Controller Gamepad Adapter Joystick Buttons Xpadder JoytoKey

I noticed there are several people having problems with getting a controller to work properly, especially online, and the questions aren't being answered. The biggest issue is the analog sensitivity problem, which I found can be solved (in my case) two ways, but both have drawbacks.

1: Switch to N-range plugin. Drawback - No one uses this, so it makes it nearly impossible to play online.

2: Use a third party pad to keyboard application to route / map / assign controller buttons to keyboard buttons. I have found two programs on the web that perform this function.. JoytoKey and XPadder. Drawback - BOTH programs don't seem to detect any of the C buttons. ALL other buttons, including the analog / thumb / control stick sensitivity / tilt work flawlessly.

Please is there anyone out there that has a solution for this?
Reply With Quote
  #2  
Old 30th July 2009, 08:21 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

A third solution is to not use Project64k or Project64kve.
--KVE is still based off Project64k, which still is a hack (even if from taking the 1.4 source). The feature itself was hacked in, and other emulators supporting NetPlay are not known to have this controller issue.

i.e. people don't all have to use the same controller plug-in unless they use Project64k or its extensions.
Reply With Quote
  #3  
Old 31st July 2009, 03:58 AM
Moohaumed's Avatar
Moohaumed Moohaumed is offline
Junior Member
 
Join Date: Jul 2009
Posts: 11
Default

Any recommendations?
Reply With Quote
  #4  
Old 31st July 2009, 09:57 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

Of course an issue with not using Project64k or --kve is that everyone within the same game must use the same emulator, and well over 95% of people use Project64k.

When setting organized games, you should know other N64 emulators playing online are 1964/Mupen64/Nemu64.

Today Mupen64 is continued as Mupen64Plus for Linux, but there is an earlier attempt with a revolutionary implementation of NetPlay. This project was renamed from Mupen64k to Mupen64++, but most people like to get the emulator from here now that there is no primary resource for downloading it.
http://www.goldeneyeonline.com/
(See Step 1: Download the N64 Emulator.)
The synchronization issues with the hacks in Project64k, at least to this emulator, don't even register.

By contrast, Nemu64 was ended in 2003. Uh I believe zilmar got out his rocket launchers and bam went the blimp, no photographs of the event exist. Because time was put into a stable implementation of NetPlay based on a sudden finality of Nemu64, online play may or may not be better than that for Project64k. The issue is how slow it is; back then people still put up with slow speeds. You may also have to mess around with some of the default settings to optimize things.

1964 has recently been updated. If you want check it out check http://1964emu.emulation64.com/. Its introduction of NetPlay is between the time of Nemu64 and Project64k, both of which before Mupen64's discoveries. Of these four options for NetPlay 1964 is generally fastest; I can get a good 500+ VI/s with Virtual Chess 64 if I optimize everything for speed.

Because of the great uniquity (er uniqueness) in the implementation based on the functions of an individual emulator, I'm sure there will be issues setting up any of these options. If need be I am happy to test this out with you if we can plan a game, but quite a few reports do have solutions.

Last edited by HatCat; 31st July 2009 at 10:00 PM.
Reply With Quote
  #5  
Old 5th August 2009, 01:45 AM
Moohaumed's Avatar
Moohaumed Moohaumed is offline
Junior Member
 
Join Date: Jul 2009
Posts: 11
Default

I'll look into those and give a couple a try the next chance I get. It's nice of you to offer setting up the test match, I will likely take you up on that as it's impossible to get anyone to stay in one place and communicate for too long. I really appreciate all your help you're a great asset to this forum.
Reply With Quote
  #6  
Old 5th August 2009, 01:58 AM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

Well it's not often this forum gets feedback.
I help out simply because I have time and, happening to have some experience, to make some positive difference. I have other involvements; I just don't want to die out from something that already began.

Even if everything is like dying these years or even if zilmar never came back, all the more reason to make use of all of this free time.

Let me know when you have that time, how some of those emulators go. It's been at least a year since I've played online through NetPlay.
Reply With Quote
  #7  
Old 2nd September 2009, 03:25 PM
Jabo's Avatar
Jabo Jabo is offline
Core Team
Alpha Tester
Project Supporter
Project64 Team
 
Join Date: Aug 2005
Posts: 183
Default

out of curiosity are these analog sensitivity issues with N64 USB adapters? or real USB gamepads? what is the model? what deadzones are people using? and what N64 range are people using? the N64 USB adapters sometimes are notoriously pieces of crap, Adaptoid I've heard is the best.
__________________
Project64 Developer
HP Laptop, Intel P7540 with GMA4500, Windows 7
Reply With Quote
  #8  
Old 2nd September 2009, 09:51 PM
squall_leonhart's Avatar
squall_leonhart squall_leonhart is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Mar 2007
Location: Sydney, Australia
Posts: 2,918
Default

its the drivers, not the adapters.
__________________

CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
Monitor:ROG PG279Q, BenQ BL2211, Sound:Creative XFI Titanium Fatal1ty Pro
SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX300 1000
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 03:03 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.