Go Back   Project64 Forums > Public Version > Project 64 - v1.6

 
 
Thread Tools Display Modes
  #1  
Old 16th January 2017, 12:10 AM
oiram oiram is offline
Junior Member
 
Join Date: Jan 2017
Posts: 8
Default Mario Party glitch, and controller joystick range?

Hi, we started a new game at Mario Party (the first), and there's glitches: half of screen flashing in the mini-game Desert Dash, and a blue screen in the Bank that keep the bought items. I tried with both Jabot video plugin, and with Glide64 'Napalm WX" WIP Date: Feb 27 2010

Maybe there's a config or a different plugin that works fine i didn't tried yet, any known working config for this game? I tried with Project 64 v.2.3 and there's no glitch with the plugin "Glide64 For PJ64: 2.1.0.210", but unfortunately it keep crashing when using save states (especially when trying to load) not sure if it is due to the plugin itself or the new version of PJ64. I was unable to try "Glide64 For PJ64: 2.1.0.210" on v.1.6 of PJ64, but since PJ64 v.2.3 seem unstable when using save states, that's why i'm looking for a working solution on v.1.6

Also, i have a question about the controllers, me and my friends were barely able to play the mini-game "Cast Aways", because the joystick act as if we were pressing completely on it. It makes it impossible to grab the items from the 2 first row (the closest), it is only possible to catch the items on the farthest row (the 3rd row). It's like the emulator was unable to detect that there's a "range" with the joystick. We use F310 from Logitech. Searching in the options of the controller, we was unable to find anything that works to fix it. Any way to fix this?

Thanks for helping!
  #2  
Old 16th January 2017, 12:24 AM
Frank74's Avatar
Frank74 Frank74 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Aug 2013
Location: UK
Posts: 800
Default

Here's a newer version of 2.3. Savestates should work fine with this version. I've included most of my plugins.

https://www.dropbox.com/s/aa06fxu66p...ect64.zip?dl=1

Try Jabo's DInput. Logitech controllers seem to prefer Jabo's. Remember to save the configuration after configuring.

Last edited by Frank74; 16th January 2017 at 12:28 AM.
  #3  
Old 16th January 2017, 01:22 AM
oiram oiram is offline
Junior Member
 
Join Date: Jan 2017
Posts: 8
Default

Thanks for this version. There's no glitch and joystick works (hopefully it should also work with the controller i plan to buy; a Tomee USB N64).

There's only 1 thing that doesn't work; when i press F5 to save, it says:
Error
Unknown memory action
Emulation stopped
  #4  
Old 16th January 2017, 01:37 AM
Frank74's Avatar
Frank74 Frank74 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Aug 2013
Location: UK
Posts: 800
Default

Quote:
Originally Posted by oiram View Post
There's only 1 thing that doesn't work; when i press F5 to save, it says:
Error
Unknown memory action
Emulation stopped
Strange...

I've just tried Mario Party 1. Used all default settings and plugins, except changed GFX to Glide64 for PJ64. F5 works fine here. Pressed F5 two dozen times at least, in different parts of the game.

What plugins are you using?
  #5  
Old 16th January 2017, 01:44 AM
oiram oiram is offline
Junior Member
 
Join Date: Jan 2017
Posts: 8
Default

I don't know if it is related to it, but before i could do anything to plugins, it was said xinput1_3.dll was missing, so i had to download it. But once i had this dll with Project64.exe, i could change the plugin to use Jabo for input.
These are the plugins i use:
Video: Glide64 For PJ64: 2.1.2.188
Audio: Jabo's DirectSound 1.7.0.7
Input: Jabo's DirectInput7 1.6.1
RSP Plugin 1.7.3.188
  #6  
Old 16th January 2017, 01:59 AM
Frank74's Avatar
Frank74 Frank74 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Aug 2013
Location: UK
Posts: 800
Default

Quote:
Originally Posted by oiram View Post
I don't know if it is related to it, but before i could do anything to plugins, it was said xinput1_3.dll was missing, so i had to download it. But once i had this dll with Project64.exe, i could change the plugin to use Jabo for input.
These are the plugins i use:
Video: Glide64 For PJ64: 2.1.2.188
Audio: Jabo's DirectSound 1.7.0.7
Input: Jabo's DirectInput7 1.6.1
RSP Plugin 1.7.3.188
Probably due to NRage plugins in plugin folder. They need XInput from directx9.
Best to delete that xinput1_3.dll, and download and install the official directx9 redist here:
https://www.microsoft.com/en-gb/down...s.aspx?id=8109 95.6 MB.

You're probably getting a conflict using that xinput dll on its own, without the rest of directx9 installed.

Common problem with Windows 8 and 10. I'm on Windows 8.1.

Using same plugins as you, F5 works fine here.

Last edited by Frank74; 16th January 2017 at 02:09 AM.
  #7  
Old 16th January 2017, 02:26 AM
oiram oiram is offline
Junior Member
 
Join Date: Jan 2017
Posts: 8
Default

I'm using XP. I installed directX, but it seems my computer already had it installed. It only extracted some .zip files in a folder. PJ64 was still asking for that dll. But if i use the Jabo plugin for input on my PJ64 v.2.3 version (2.3.0.210). F5 works fine with this version, only the emulator itself is a little instable, especially when using F7 to load save states, sometime it crash.
  #8  
Old 16th January 2017, 02:42 AM
Frank74's Avatar
Frank74 Frank74 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Aug 2013
Location: UK
Posts: 800
Default

Quote:
Originally Posted by oiram View Post
I'm using XP. I installed directX, but it seems my computer already had it installed. It only extracted some .zip files in a folder. PJ64 was still asking for that dll. But if i use the Jabo plugin for input on my PJ64 v.2.3 version (2.3.0.210). F5 works fine with this version, only the emulator itself is a little instable, especially when using F7 to load save states, sometime it crash.
The build I posted is built with Visual Studio 2015. It has a problem with compressed savestates on XP (because of change from using zip to 7zip). I've just re-built it on Visual Studio 2008. Compressed savestates will now work fine on XP with this version. F5 and F7 will work now, with no crashes or instability.

https://www.dropbox.com/s/91t9akcilw...t64XP.zip?dl=1

You can just extract this to your Project64 (2.3.0.210) folder, overwrite all files.

Last edited by Frank74; 16th January 2017 at 02:55 AM.
  #9  
Old 16th January 2017, 03:10 AM
oiram oiram is offline
Junior Member
 
Join Date: Jan 2017
Posts: 8
Default

It works, i was able to save and load. Thank you so much for all your help! it is really appreciate. I think this version should not crash when i will use F7, it is a more update version of PJ64. Can't wait to play again with my friends to Mario Party now ^^
  #10  
Old 23rd January 2017, 07:35 PM
oiram oiram is offline
Junior Member
 
Join Date: Jan 2017
Posts: 8
Default

I have feedback after playing Mario Party with friends. It works fine but there's few glitches i would like to report (i don't know where to report bugs and i don't know if they are known bugs):

- In the mini-game 'Coin Block Blitz' the floor change color (it turn darker) every time someone take a coin from these blocks. That makes the floor to flash as we try to pick coins as fast as possible. It's not really a big bug, but i wanted to report this bug for a friend that is epileptic.

- At some rare occasion, suddenly the emulator freeze (sound stop and picture is freeze), and there's nothing to do but to close the emulator and open it again. This happened with other games too. At one occasion, i had this freezing bug, and doing ctrl+alt+del i could see PJ64 taking about 500 000ko of memory. Usually it takes not even 100 000ko. Maybe it is due to my computer being old but i don't really know, i don't really have knowledge about this but anyway i have AMD athlon X2 64 ATI radeon. To be more safe, i use quick save more frequently.

Other than that, we were able to have fun playing Mario Party and to use controller joystick.
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 04:52 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.