Go Back   Project64 Forums > Public Version > Project 64 - v2.x - Issues

Reply
 
Thread Tools Display Modes
  #1  
Old 4th February 2020, 10:56 PM
Matroshka Matroshka is offline
Junior Member
 
Join Date: Feb 2020
Posts: 2
Default Multiple issues with XBox One S controller [Win10 x64][2.3.2.202][N-Rage 2.5.2.202]

I've tried using the Xbox One S controller in wired mode and I've ran into a number of issues. Firstly, for some reason in X-input mode the C-buttons can only be assigned to d-pad or one of the analogs. I tried putting them on shoulder buttons and the assignments would return to "none" the next time I would open the plugin config. I wanted to make a custom mapping for OOT, but no luck so far.

Another issue I ran into is the rumble pak - there's no way to select the Xbox controller as the Force Feedback device even with X-input enabled. Do I still need custom drivers for the rumble emulation to work with Xbox controllers in the latest N-rage?

I attached screenshots of my settings.
Attached Images
File Type: jpg Annotation 2020-02-04 234749.jpg (19.3 KB, 9 views)
File Type: jpg Annotation 2020-02-04 234858.jpg (19.1 KB, 6 views)
File Type: png Annotation 2020-02-04 234837.png (18.8 KB, 4 views)
File Type: jpg Annotation 2020-02-04 234811.jpg (18.9 KB, 6 views)
Reply With Quote
  #2  
Old 5th February 2020, 01:31 PM
ExtremeDude2's Avatar
ExtremeDude2 ExtremeDude2 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Apr 2010
Location: USA
Posts: 3,094
Default

The rumble either needs custom drivers or it should "just work" (disable raw). As for being unable to bind the c-buttons sounds like a bug and good luck getting someone to fix it (I'll look in to it later, but I doubt I'll be able to do anything).
__________________
Quote:
Originally Posted by dsx! View Post
are you american or something
Reply With Quote
  #3  
Old 5th February 2020, 11:05 PM
ExtremeDude2's Avatar
ExtremeDude2 ExtremeDude2 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Apr 2010
Location: USA
Posts: 3,094
Default

So I've confirmed it IS saving to a file, but I guess it isn't reading it back?

I've found the code for loading from the file and it looks fine, however the C buttons seem to not have a default set like the rest of the buttons do so maybe that's the problem?

So I just tested it and it is also loading the file and works as configured when playing a game, so you really should be able to still put the c-button on whatever you want. This is still a bit of a bug tho so I'm going to see if I can fix it.

https://github.com/project64/project...Controller.cpp
__________________
Quote:
Originally Posted by dsx! View Post
are you american or something

Last edited by ExtremeDude2; 6th February 2020 at 01:43 PM.
Reply With Quote
  #4  
Old 6th February 2020, 10:42 PM
ExtremeDude2's Avatar
ExtremeDude2 ExtremeDude2 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Apr 2010
Location: USA
Posts: 3,094
Default

Turns out this has already been fixed (you'll need to compile the newest version of the plugin, but since I've already done that anyway if you ask here I'll send it to you):

https://github.com/project64/project64/pull/1626
__________________
Quote:
Originally Posted by dsx! View Post
are you american or something
Reply With Quote
  #5  
Old 6th February 2020, 11:04 PM
Matroshka Matroshka is offline
Junior Member
 
Join Date: Feb 2020
Posts: 2
Default

Thanks for help, I'll test if the rumble works with raw disabled.

EDIT: Ok, I built the latest dlls and it seems that now C-button mapping for axes/dpad doesn't show in UI. Individual buttons are fixed. And the input works, it just doesn't show in UI, as you said, so it's minor.

As for rumble, I booted up SF64 and it works - the correct setting for Xinput seems to be raw data enabled and output device set to none. With raw disabled there's no force feedback.

Last edited by Matroshka; 8th February 2020 at 09:30 PM. Reason: update
Reply With Quote
  #6  
Old 11th April 2020, 02:34 AM
firebomber firebomber is offline
Junior Member
 
Join Date: Apr 2020
Posts: 2
Default

[quote=ExtremeDude2;77774]Turns out this has already been fixed (you'll need to compile the newest version of the plugin, but since I've already done that anyway if you ask here I'll send it to you):


would be so kind as to send in a compiled file. Thank you
Reply With Quote
  #7  
Old 14th April 2020, 12:53 AM
ExtremeDude2's Avatar
ExtremeDude2 ExtremeDude2 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Apr 2010
Location: USA
Posts: 3,094
Default

[quote=firebomber;78242]
Quote:
Originally Posted by ExtremeDude2 View Post
Turns out this has already been fixed (you'll need to compile the newest version of the plugin, but since I've already done that anyway if you ask here I'll send it to you):


would be so kind as to send in a compiled file. Thank you
oh geez, let me see if I can find it now (I think this is it):
Attached Files
File Type: zip New Compressed (zipped) Folder.zip (140.6 KB, 6 views)
__________________
Quote:
Originally Posted by dsx! View Post
are you american or something
Reply With Quote
  #8  
Old 19th July 2020, 03:03 PM
firebomber firebomber is offline
Junior Member
 
Join Date: Apr 2020
Posts: 2
Default

[quote=ExtremeDude2;78255]
Quote:
Originally Posted by firebomber View Post

oh geez, let me see if I can find it now (I think this is it):
Hi, I appreciate your help. It's working great. Thank you very much.

Last edited by firebomber; 19th July 2020 at 03:11 PM. Reason: It works very well, my bad configuration.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 10:43 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.