#1  
Old 18th July 2013, 04:16 PM
DarkTheThief DarkTheThief is offline
Junior Member
 
Join Date: Jul 2013
Posts: 7
Default John Romero's Daikatana

Hey all. I've been trying to play Daikatana on Project64, and I can't get it to work. It always gives me an error that says "Fatal Error: Stopping Emulation". I honestly cannot figure out what the problem is. Here's my plugin setup if it helps:

Video: Glide64 for PJ64: 2.0.0.1
Audio: Jabo's DiectSound 1.7.0.7
Input: Jabo's DirctInput 1.7.0.12
RSP: RSP Plugin 1.7.0.9

If more information is needed, just let me know. Thanks in advance!
Reply With Quote
  #2  
Old 18th July 2013, 04:25 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

Is that really the entire error message?

Did you try to change the CPU core style to Interpreter and disable 32-bit core in the Edit Game Settings off the game in the ROM browser (visible when you disable Hide Advanced Settings)?
Reply With Quote
  #3  
Old 18th July 2013, 04:58 PM
DarkTheThief DarkTheThief is offline
Junior Member
 
Join Date: Jul 2013
Posts: 7
Default

Quote:
Originally Posted by FatCat View Post
Is that really the entire error message?

Did you try to change the CPU core style to Interpreter and disable 32-bit core in the Edit Game Settings off the game in the ROM browser (visible when you disable Hide Advanced Settings)?
Yep. That's the entire error message. I'll try that suggestion and get back to you in a little bit.

EDIT: That made it work, but it runs really slow, despite being listed as compatible.

Last edited by DarkTheThief; 18th July 2013 at 05:02 PM. Reason: Results
Reply With Quote
  #4  
Old 18th July 2013, 05:10 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

Then you can try setting it back from interpreter to recompiler, and play with those self-modifying code checkboxes under the Recompiler section of the config to see if there is a faster way to get it to not crash.

Or maybe just unchecking 32-bit core was what did it?
Reply With Quote
  #5  
Old 18th July 2013, 09:17 PM
DarkTheThief DarkTheThief is offline
Junior Member
 
Join Date: Jul 2013
Posts: 7
Default

Quote:
Originally Posted by FatCat View Post
Then you can try setting it back from interpreter to recompiler, and play with those self-modifying code checkboxes under the Recompiler section of the config to see if there is a faster way to get it to not crash.

Or maybe just unchecking 32-bit core was what did it?
That wasn't it, but I changed it all back, and turned off Advanced Block Link, and it worked, but now the Framerate is all over the place.
Reply With Quote
  #6  
Old 18th July 2013, 09:28 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

It's something to do with fixed audio timing or one of those other audio-related settings.

Otherwise you can limit the speed with F4 or "Sync Game to Audio" in Jabo's DirectSound.
Reply With Quote
  #7  
Old 18th July 2013, 09:33 PM
DarkTheThief DarkTheThief is offline
Junior Member
 
Join Date: Jul 2013
Posts: 7
Default

We'll see what happens when I try that. Thank you. Your help (and patience with me) is much appreciated.
Reply With Quote
  #8  
Old 2nd December 2013, 12:19 AM
furryfangs's Avatar
furryfangs furryfangs is offline
Project Supporter
Member
 
Join Date: Sep 2009
Posts: 85
Default

Right click Daikatana bring up the in games menu then open config next change the recompiler to interpreter then change the function lookup method to virtual lookup table, the fps should be around 60-70 frames per second

Edit:when you get to the main menu&in-game it should cut back down to 50-60 frames per second.
__________________
Windows 7 Home Premium NVIDIA GeForce GTS 450 1TB HDD Intel Core i3-2100 10gb RAM NVIDIA High Definition Audio.

Last edited by furryfangs; 2nd December 2013 at 12:23 AM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 10:41 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.