#1  
Old 21st April 2014, 07:00 PM
MRK64 MRK64 is offline
Junior Member
 
Join Date: Oct 2013
Posts: 4
Default Games running too fast.

I have an issue in a lot of games, where they run too fast. Last game I tried with this issue is Perfect Dark. It just runs at a very fast speed even though the emulator is synced to audio and FPS Limiter is enabled.

What's up with that? The game runs normally in 1.6.
__________________
I5 3570K - Asrock Z77 Extreme 4 - 8Gb DDR3 Corsair Vengeance - Gigabyte GTX560Ti 448
Reply With Quote
  #2  
Old 21st April 2014, 09:13 PM
retroben's Avatar
retroben retroben is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Jul 2013
Posts: 687
Default

Maybe it is the VI Refresh Rate setting in Edit Game Settings.
Just enable advanced settings and right click the game to find that settings option and change the refresh to a somewhat lower value.
Or you could have the speed set higher than normal on the +/- keys.
If so,hit the minus key until you get to 60VI/s.
It might go uneven and you will need to use plus and minus until it hits exactly 60VI/s for the proper speed or 50VI/s if you are running a PAL/European version of the game.
Reply With Quote
  #3  
Old 21st April 2014, 10:36 PM
Frank74's Avatar
Frank74 Frank74 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Aug 2013
Location: UK
Posts: 828
Default

I have Vi Refresh Rate set at 1475 for Perfect Dark.

You should always uncheck Fixed Audio Timing as well. For all games.
Reply With Quote
  #4  
Old 22nd April 2014, 09:47 PM
MRK64 MRK64 is offline
Junior Member
 
Join Date: Oct 2013
Posts: 4
Default

With VI refresh at 1475 and unchecked Fixed Audio Timing it seems to work normally now.

By the way, is it normal for this game to have such horrible framerate drops? I don't remember it being so bad on the N64, but I haven't played it in ages. I remember Goldeneye very often slowed down noticeably but not really PD.
__________________
I5 3570K - Asrock Z77 Extreme 4 - 8Gb DDR3 Corsair Vengeance - Gigabyte GTX560Ti 448

Last edited by MRK64; 22nd April 2014 at 11:08 PM.
Reply With Quote
  #5  
Old 2nd May 2014, 03:58 AM
Kiihhu Kiihhu is offline
Junior Member
 
Join Date: May 2014
Posts: 2
Default

Quote:
Originally Posted by MRK64 View Post
With VI refresh at 1475 and unchecked Fixed Audio Timing it seems to work normally now.

By the way, is it normal for this game to have such horrible framerate drops? I don't remember it being so bad on the N64, but I haven't played it in ages. I remember Goldeneye very often slowed down noticeably but not really PD.
Thank you retroben and Frank74 for the info, setting the VI refresh rate to 1475 fixed the game speed, although I have no idea why. Is this a value that you simply find by trial and error or can you make an educated guess what value to try?

And MRK64, the answer is yes... Perfect Dark indeed had terrible frame rate drops, much worse than GoldenEye did... Perfect Dark is difficult already, but the frame rate drops make some levels really, really hard as it is difficult to hit anyone with changing game speed (try Air Base - Espionage mission to see what I mean). I had this same problem with the original console in the days I was very accustomed to the controls (but I still did complete the game on Perfect Agent difficulty, except for the WAR!!! mission).

I am no emulator expert, but as far as I know the frame rate drops are the result of imitating a low performance console such as N64: it slowed down because it couldn't handle everything going on, and imitating such slow console makes the game also slow down in modern fast PCs. In the back of my mind I have been hoping that it would be possible to emulate N64 without its slowdowns and I was hoping that with luck Project 2.1 would have this possibility, so I upgraded from Project 1.6 to 2.1 today, just an hour ago. As PD was working too fast I was hopeful it could have been fixed, but now that the speed is normal also the slowdowns are there.

After a quick testing it seems like Perfect Dark ran better on 1.6 than it does on 2.1, there are a lot more graphics glitches, such as the game is now running in the upper half of my computer screen and the lower half being just black... and also some problems with sky textures that aren't there on 1.6.
Reply With Quote
  #6  
Old 3rd May 2014, 06:31 AM
Kiihhu Kiihhu is offline
Junior Member
 
Join Date: May 2014
Posts: 2
Exclamation

This post may be a little off the original topic, but I just wanna tell that I found solutions to a couple of problems I complained of yesterday, and I find it my duty to share any useful hints to other Perfect Dark fans using Project64.

1. The slowdown problem (FPS drop). It indeed is fixable in Project64 2.1! Changing the Counter Factor from 2 (default) to 1 fixed the slowdown issue completely! No slowing down at any point so far! Made the game so much easier and enjoyable, I actually passed many missions on Perfect agent difficulty that I yesterday found nearly unbeatable (at least with auto aim off). Can't wait to play multiplayer with my friends now! I love 2.1 now!!!

2. Halved screen problem. The game was running in the upper half of my computer screen and the lower half was just black. The problem was the Jabo's Direct3D8 1.7.0.57-ver5 graphics plugin. Changing to Jabo's Direct3D8 1.6 solved the problem.

I didn't come up with these solutions by myself, I think I saw some suggestions on these very forums and from google and tried them out, not quite sure anymore, but I wanted to spread the word.

Last edited by Kiihhu; 3rd May 2014 at 06:34 AM.
Reply With Quote
  #7  
Old 3rd May 2014, 07:59 AM
Frank74's Avatar
Frank74 Frank74 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Aug 2013
Location: UK
Posts: 828
Default

You should update to 1.6.1 Jabo. Many fixes for Perfect Dark.

h##p://jabosoft.com/articles/114
Reply With Quote
  #8  
Old 4th May 2014, 06:02 AM
retroben's Avatar
retroben retroben is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Jul 2013
Posts: 687
Default

The 1.6.1 plugin is flawless with a LOT of games with no lag on self rendering!
In some random topic,I attached the 1.6.1 plugin from my pre-patched copy of PJ64 1.6 for those who want it immediately. (no viruses)

I wish the 1.6.1 plugin had an open source for porting it to android as well as PJ64 being ported since all existing emulators for android always exit the game after a short time. :angry:

There is a feature in Super N64 called frame limiter that smooths out the framerate of skippy games like Banjo-Tooie.
Can someone try to add that to a PJ64 2.1 mod for the games that don't have a no frameskip code or any other solution?
Where the hell is all of the PJ64 modifications?! :angry:
The only one I know of is fruit edition on smwcentral.

Believe it or not,I am posting this on my Amazon Fire TV with Opera Browser.
Reply With Quote
  #9  
Old 31st May 2014, 10:37 PM
Toph_Bei_Fong Toph_Bei_Fong is offline
Junior Member
 
Join Date: May 2014
Posts: 9
Default

I'm having this same issue with 2.1. Perfect Dark just runs too fast and I cannot find any of the options you guys are talking about.

please help
Reply With Quote
  #10  
Old 31st May 2014, 11:02 PM
Toph_Bei_Fong Toph_Bei_Fong is offline
Junior Member
 
Join Date: May 2014
Posts: 9
Default

I found the settings ad changed everything but nothing works. It's still fast. I'll go back to 1.6, but I have an issue with Perfect Dark on 1.6. Every time I finish a mission, the emulator freezes. When I restart the emulator, my mission progress is saved but it's annoying to have to do this all the time. I was using a i5 3570K, but I recently switched to an i7 3770K.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 10:14 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.