#1  
Old 18th July 2009, 11:46 PM
Shimon Shimon is offline
Junior Member
 
Join Date: Jul 2009
Posts: 5
Default Annoying performance Issue

Hey

When i first got project64 (1.6) i never thought about tweaking the settings. so i did it using the help section and i got it more or less perfect i.e. looked great and had no issues or very slight ones. Then after laptop got wiped by accident i tried to get project to the same level as before but i havnt been able to, which is very annoying. I dont see why it wont work well, my laptop is modern and can play games such as Worms 3D/Sonic Adventure on thier highest settings.

My graphics card is a NVIDIA GeForce 7150M/ nForce 630M and i use the
Jabo's Direct3D8 1.6 plugin.


Anyone know anything to help?/best project settings for my laptop?
  #2  
Old 19th July 2009, 02:57 AM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

If you see issues show a screenshot if you can.
Otherwise if you have no issues settings are fine.
  #3  
Old 19th July 2009, 03:06 AM
Shimon Shimon is offline
Junior Member
 
Join Date: Jul 2009
Posts: 5
Default

its not so much major issues but things like slow-down at certain parts. i.e on Conkers Bad Fur Day, when i jump into water the game will lag quite badly and i can assume so for other similar parts. In Start Fox 64 when destroying enemys the game will slow down a bit. Im trying to find a way to get the best balance of quality/performance as i had done before.
  #4  
Old 19th July 2009, 03:13 AM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

That could be tension in memory updating process, but maybe switching to Jabo's Direct3D6 1.5.2 helps?

If not we can go through some advanced settings.
  #5  
Old 19th July 2009, 06:14 PM
Shimon Shimon is offline
Junior Member
 
Join Date: Jul 2009
Posts: 5
Default

i tried the other graphics plugin but im sure it was the one i am using now.
The advance settings is a good idea i think, might have tinkerd there before the laptop wipe, just dont remember. so what should i do?
  #6  
Old 21st July 2009, 01:22 AM
Shimon Shimon is offline
Junior Member
 
Join Date: Jul 2009
Posts: 5
Default

I thought this might help with my issue, so here are the settings for project that im using.


NVIDIA GeForce 7150M/ nForce 630M

Windowed Resolution - 1380x768
Full Screen Resolution - 1280x800 16-bit 60Hz
Full Screen Sync - Triple Buffer Vsync

Anisotropic Filtering - 16x (maxed out)
Full-Scene Antialiasing - 4x (maxed out)



Super2xsal textures/texter filter are unmarked
and i havnt changed the core Settings

agian, the problem is laggy slowdown at various points
  #7  
Old 21st July 2009, 10:23 AM
squall_leonhart's Avatar
squall_leonhart squall_leonhart is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Mar 2007
Location: Sydney, Australia
Posts: 2,918
Default

use 32bit, otherwise you are hitting a 16 > 32bit driver overhead.

onboard chips are poor at AA as well, so use 2 or none.
__________________

CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
Monitor:ROG PG279Q, BenQ BL2211, Sound:Creative XFI Titanium Fatal1ty Pro
SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX300 1000
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
  #8  
Old 21st July 2009, 06:33 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

I would just disable the anti-aliasing.
The windowed resolution is another general tensity factor. For leisure play, I use either 640x480 or 320x240.
  #9  
Old 21st July 2009, 10:05 PM
Shimon Shimon is offline
Junior Member
 
Join Date: Jul 2009
Posts: 5
Default

I finally managed to get the balance back that i wanted. i noticed the game was running much better and when i looked at the settings, i had turned off the Advance Block Linking which has ended things like bad lag when jumping in water, slow down in star fox etc. I still have the AA on full/high resoultion but that doesnt seem to cause problems now.

thanks for the advice though.
  #10  
Old 21st July 2009, 10:57 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,236
Default

Thanks too that's a good note.
Though I remember Smiff's note on the, generalities, the user manual for Project64 did summarize the advanced block linking control as a "speed vs. smoothness" trade-off.

"On is usually (often significantly) faster than Off but may be less smooth. This depends on the game. Afew games run particularly badly with this On, or may require this to be On or Off, which is why the RDB sometimes does set this control."
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 11:44 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.