#1  
Old 28th June 2013, 06:36 PM
FierceDeityMask's Avatar
FierceDeityMask FierceDeityMask is offline
Junior Member
 
Join Date: Jun 2013
Location: United Kingdom.
Posts: 9
Smile Majoras Mask: Lens Of Truth (Issue)

Hello everyone. New here, below I have listed my PC specifications.

===========================
Toshiba Satellite P850 31L (Laptop)
Intel Core I7 3630QM 2.4GHZ (3.4GHZ Turbo)
4 Cores, 8 Threads, 6MB Cache, Graphics Support
NVIDIA Geforce GT 640M (Set to PJ64, major difference!)
64 Bit Operating System On Windows 8 Basic
8GB RAM DDR3 (1600MHZ) & (625MHZ GC + 2GB Memory)
===========================

Currently using the latest edition of Project 64 (2.1.0.1) and emulating my favorite game almost flawlessly using an Xbox 360 Controller. I've had to tweak a few settings for it to work properly.

>Options > Configure Audio Plugin > Sync Game To Audio.
>Options > Settings > "Config: Game" > Uncheck Fixed Audio Timing.
>Options > Settings > "Config: Game" > Uncheck Sync Using Audio.
>Options > Settings > "Config: Game" > VI Refresh Rate: 1500.

All this was necessary to achieve a consistent / steady frame rate, due to a bug the VI was changed from 2200 to 1500 because timers in the game were 1.5x faster which made some challenges impossible.

Other than that, all settings are software default for simplicity. My NVIDIA Control Panel was configured to force this game to use the GC and I found all graphical glitches fixed (textures mainly).

OK, sorry for all that information but I feel it's necessary.

My problem is:

When playing the game, the Lens Of Truth shows invisible items as it should. It however, seems to mistake some objects like torches, ice (visible interact-able / moving items) and stray fairies (hidden behind walls) as "invisible". It's hard to explain: So I included a few images.

1) Fairy not seen behind wall, also cutting off bow.


2) This ICE is visible, but the lens of truth disagrees.


3) Same with torches, as you can see here.


It's not really that much of a problem, more of an inconvenience because without prior knowledge of the game, it could potentially increase difficulty of the game and make it impossible without assistance.

Wondering if anybody has had similar problems, thanks.

OH! and yes. I've changed the video plugins (made more problems) and used the Intel Chipset and Microsoft Basic Display Driver (I think that's processor graphics) but it had the same effect.
Reply With Quote
  #2  
Old 28th June 2013, 06:59 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,242
Default

Did you try Glide64?

If so you might need to use a low-level graphics plugin like z64gl to get it to work correctly. Last I checked the Lens of Truth effect was difficult to get working, but software rendering made it pretty easy on the plugins supporting it. Too bad that's slow.
Reply With Quote
  #3  
Old 28th June 2013, 07:47 PM
FierceDeityMask's Avatar
FierceDeityMask FierceDeityMask is offline
Junior Member
 
Join Date: Jun 2013
Location: United Kingdom.
Posts: 9
Default

Quote:
Originally Posted by FatCat View Post
Did you try Glide64?

If so you might need to use a low-level graphics plugin like z64gl to get it to work correctly. Last I checked the Lens of Truth effect was difficult to get working, but software rendering made it pretty easy on the plugins supporting it. Too bad that's slow.
Thanks FatCat for the reply. I have just used Glide64 2.0.0.1 and no difference was apparent. I am interested in this plugin "z64gl". Software rendering could be a good alternative due to a good amount of resources on my PC. Do you happen to know where I could download this plugin? Thanks.
Reply With Quote
  #4  
Old 28th June 2013, 08:45 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,242
Default

Actually you know what, scratch that.

Try this plugin instead.
http://forum.pj64-emu.com/showthread.php?t=3739

It's not LLE like z64gl, so it should eliminate the concern of switching RSP plugins from the pj64 one if you haven't done that already.

It is very slow, however. Don't say I didn't warn you.
Still, it should almost certainly fix the depth buffer issue with the Lens of Truth.
Reply With Quote
  #5  
Old 29th June 2013, 02:30 AM
FierceDeityMask's Avatar
FierceDeityMask FierceDeityMask is offline
Junior Member
 
Join Date: Jun 2013
Location: United Kingdom.
Posts: 9
Default

Quote:
Originally Posted by FatCat View Post
Actually you know what, scratch that.

Try this plugin instead.
"scrapped to post"

It's not LLE like z64gl, so it should eliminate the concern of switching RSP plugins from the pj64 one if you haven't done that already.

It is very slow, however. Don't say I didn't warn you.
Still, it should almost certainly fix the depth buffer issue with the Lens of Truth.
Very good information!! Thanks! I've just tried that plugin and all problems with the Lens Of Truth have seized. But this unfortunately (even after tweaks) is for trade of speed and graphics quality You did warn me though



I was hoping you underestimated my laptop power, but clearly this still isn't enough to be 100% stable (even 3.4GHZ turbo). It seems to range from on average 94%-100% with 85% shifts walking through doors with frequent audio jitter. Using the Lens Of Truth shifts it 75%-80%. Must be very demanding. I've read that thread and I see that the plugin uses software rendering and relies heavily on just the CPU to process the graphics.

This interests me because you've fixed the problem none the less, and thanks!! This plugin has great potential, also helped me.

So If I'm OK with asking one last question, does this mean my Hardware doesn't support the ability to buffer certain objects? Or is merely a question of the ROM / PJ64's Hardware support? Thanks in advance.
Reply With Quote
  #6  
Old 29th June 2013, 02:51 AM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,242
Default

I am impressed you are getting that level of performance, but then again I was never a hardware person.

I'm not sure why Glide64 isn't supporting it.
I thought it used to...maybe a later version broke it.
Or maybe settings in the INI were modified. "Enable depth buffer emulation" and FB "write back every frame" might be worth toying with.

Or Jabo's Direct3D 1.7+ with software rendering checked and/or "Copy framebuffer to RDRAM" might fix it.

Past that, I guess you're stuck with this plugin, or a LLE gfx plugin.
Reply With Quote
  #7  
Old 12th September 2013, 08:49 AM
5h0rty 5h0rty is offline
Junior Member
 
Join Date: Sep 2013
Posts: 2
Default

these settings did the trick for me. it fixed the timing issue and the lense of truth issue







no performance problems so far


EDIT: sorry, i still have the same problems in the same room with the fairy and the ice

Last edited by 5h0rty; 12th September 2013 at 10:23 AM.
Reply With Quote
  #8  
Old 12th September 2013, 12:34 PM
ExtremeDude2's Avatar
ExtremeDude2 ExtremeDude2 is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Apr 2010
Location: USA
Posts: 2,327
Default

afaik glide doesn't work with the lense of truth because of the wrapper, now if you can find a voodoo card it would work amazingly XD
__________________
Quote:
Originally Posted by dsx! View Post
are you american or something
Reply With Quote
  #9  
Old 13th November 2013, 01:45 AM
Aegis Runestone's Avatar
Aegis Runestone Aegis Runestone is offline
Junior Member
 
Join Date: Nov 2013
Location: Utah
Posts: 27
Default Thank you!

I know this is an old thread, but these settings saved MM for me. I was having trouble where the graphical plugin I had chosen had the lens of Truth working, but I couldn't see holes. Or the other would have the lens not working, but I could see holes.

This setup, I can see both and everything looks good! Thank you so much!

I have to get some of the Goron stuff over again, but I think it'll be fine.
Reply With Quote
  #10  
Old 26th December 2014, 10:22 AM
catfish3371 catfish3371 is offline
Junior Member
 
Join Date: Dec 2014
Posts: 1
Default

Use frame buffer objects = win. Fixed all of my problems
Reply With Quote
Reply

Tags
issue, lens, majora, mask, zelda

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 03:31 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.