#1  
Old 11th October 2010, 06:41 AM
zilmar zilmar is offline
Core Team
Alpha Tester
Project Supporter
Administrator
 
Join Date: Jun 2005
Posts: 988
Default Project64 1.7.0.11

Upgrade current alpha to allow beta users access.

conatins:
  #2  
Old 11th October 2010, 02:56 PM
Wiwwe Wiwwe is offline
Project Supporter
Junior Member
 
Join Date: Aug 2010
Location: Finland
Posts: 15
Default

Great! Finally support for per rom settings
__________________
PC: Asus P8Z68-V PRO | Intel Core i5-2500 3.3 GHz | Kingston HyperX Genesis DDR3 8GB 1600MHz | Asus ENGTX570 DirectCU II
Consoles: Nintendo 64 | Nintendo GameCube | Nintendo Nintendo Wii | Microsoft Xbox 360
  #3  
Old 11th October 2010, 03:54 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,255
Default

Haven't seen this kind of thing before but with these versions Gauntlet Legends starts up fine with the re-compiler but not the interpreter.
  #4  
Old 11th October 2010, 07:27 PM
zilmar zilmar is offline
Core Team
Alpha Tester
Project Supporter
Administrator
 
Join Date: Jun 2005
Posts: 988
Default

Quote:
Originally Posted by rswedlow View Post
Haven't seen this kind of thing before but with these versions Gauntlet Legends starts up fine with the re-compiler but not the interpreter.
Interpter of the r4k or the RSP .. with the RSP it goes in a perm loop waiting for a response from r4k engine which it will not get since it is not multithreaded.
  #5  
Old 11th October 2010, 08:43 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,255
Default

oh right sorry, the r4k interpreter I meant.

Now, the RSP interpreter works just fine with Gauntlet Legends. Actually I've been having it on while completing a game save using the beta version but using the RSP re-compiler on the 1.6 version. Only issue is if I start the game using the RSP interpreter on 1.7 but then switch to the re-compiler, there is an endless streak of errors similar to this.



The [r4k] interpreter, though, is what I meant from before. Project64 1.6 starts Gauntlet Legends with the r4k interpreter or the re-compiler, but I've never succeeded in getting the r4k interpreter to initialize the game on the recent alpha. I haven't checked this on all the legacy beta versions.
  #6  
Old 11th October 2010, 11:12 PM
dkannegi dkannegi is offline
Project Supporter
Junior Member
 
Join Date: Dec 2006
Posts: 7
Default

What is the purpose behind the the V/I refresh rate setting? Its default is 1500.

The changelog refers to here:
http://forum.pj64-emu.com/showpost.p...7&postcount=18

But the link does not work (access denied - alpha testing forum?).
  #7  
Old 11th October 2010, 11:22 PM
1337's Avatar
1337 1337 is offline
Project Supporter
Senior Member
 
Join Date: Aug 2010
Location: Texas
Posts: 313
Default

Love the settings UI.....
  #8  
Old 1st February 2011, 01:31 AM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,255
Default Re: Project64 1.7.0.11

I don't see why not just look at the code differences between b47 and b48 because --47 was the one to fix the re-compiler-specific crashing on games like Jet Force Gemini so for stability in the re-compiler to have a few alphas up my self or someone else can test them to verify. Last I checked though the method was to add speed optimizations in a recent alpha.

Too bad this isn't the alpha forum, but it's better than a neutral news thread no one can post in without forgetting it had a topic.
Closed Thread

Tags
release
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 09:05 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.