Go Back   Project64 Forums > Public Version > Project 64 - v1.6

 
 
Thread Tools Display Modes
  #1  
Old 20th October 2009, 10:19 AM
alx3400 alx3400 is offline
Junior Member
 
Join Date: Oct 2009
Posts: 3
Default Zelda Ocarina of time crashes

Hello,

I am at the point where you have to get the water out of the fountain by playing the song of storms. During the sequence where the water sinks down, the game just stops, music keeps on playing and there is nothing you can do anymore.

I already tried another rom, but the same crash keeps happening.

Hope you got an idea
  #2  
Old 20th October 2009, 01:09 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,148
Default

Actually this has been a reported issue, but it was back in time before support was around to verify it.

So I know what you mean, but it would be beneficial to both of us if you upload a save state of the area you're in, ready to play (or like finish) the Song of Storms to get the cinema and then the crash.

You can write save states through Project64 by hitting F5; then the PJ.ZIP file named after the game is stored in "$Project64\Save".

Upload this somehow, like filesend.net or attachments system here with the forum should work fine.
  #3  
Old 20th October 2009, 01:23 PM
alx3400 alx3400 is offline
Junior Member
 
Join Date: Oct 2009
Posts: 3
Default

Alright, here it is. I hope this is what you wanted. I played the song of storms and that movie piece started. Then i pressed F5 some seconds before it crashes.
Attached Files
File Type: zip THE LEGEND OF ZELDA.pj.zip (1.55 MB, 170 views)
  #4  
Old 20th October 2009, 04:32 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,148
Default

It seems you are using the 1.0 PAL version, just in case others want to check this.

For some reason, I didn't get the crash.
I'm going to send a save state back to you by recreating the file from your scene, so see if it still crashes for you.
Download this to where your Save folder is, (You may rename your old one as a backup if you still need it or something.) and you can just hit F7 to load it.

Attachment.
Attached Files
File Type: zip THE LEGEND OF ZELDA.pj.zip (1.55 MB, 281 views)
  #5  
Old 20th October 2009, 04:53 PM
alx3400 alx3400 is offline
Junior Member
 
Join Date: Oct 2009
Posts: 3
Default

It really worked with that file. Your computer must have some kind of healing power

Thanks a lot for the help and I will be back at you of something like it happens again.
  #6  
Old 20th October 2009, 05:35 PM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,148
Default

Sure surprised me...it's a shame I didn't get a chance to see it for myself so that I could trace the cause through some configurations.

Sometimes though, some of the controls are saved into memory with a save state, so there might have been some complication that reset what you had when I loaded it before I made that change permanent. An RDB update might have resolved the issue.

Anyway yeah tell us if anything like that happens again.
  #7  
Old 24th November 2009, 12:14 AM
xRapidDavex xRapidDavex is offline
Junior Member
 
Join Date: Nov 2009
Posts: 2
Default Ocarina of Time Song of Storms Crash

I'm having the exact same issue using project64 v1.6 with default settings. The save I'm uploading is kid link at the shadow temple graveyard. Just run to the windmill and play the song of storms for the crash to happen.
Attached Files
File Type: zip THE LEGEND OF ZELDA.pj.zip (1.54 MB, 84 views)
  #8  
Old 24th November 2009, 04:32 AM
xRapidDavex xRapidDavex is offline
Junior Member
 
Join Date: Nov 2009
Posts: 2
Default

Ok, so I tried a couple of different things at once and I'm not sure which one fixed the issue.

First, I loaded my profile like normal and then realized I needed to use F7 to restore my quick save (pressed F5 after playing nocturne of shadow). When I loaded my profile I was kid link in my old Kokiri Forest hut (no clue why I started there since I did a hard save in the Temple of Time).

Then I decided to swap out whatever I was carrying to some new things. My final setup was Ocarina left C, Deku Sticks bottom C, Slingshot Right C.

Since both times the game crashed was at night, I decided to play the Sun's song to make it day and this time when I played the Song of Storms it didn't crash.

My best guess is that loading a quicksave is what fixes the issue since that is the only thing I have in common with the guy who posted above me. However, I have no clue if that's right. Hopefully this works for anyone else researching this issue.
  #9  
Old 24th November 2009, 07:43 AM
HatCat's Avatar
HatCat HatCat is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Feb 2007
Location: In my hat.
Posts: 16,148
Default

xRapidDavex, you are right.

There may be some sort of machine-dependent reoptimization going on here, but for certain, playing the Sun's Song is the in-game procedure that fixes this.

In the case of the save state you have sent, the crash happened at night. The GameFAQ notes user reports of this being during the day instead; either way whatever was going on, the Sun's Song clears it.

I have an automatic fix for you, too. This looks like another case of self-modifying code at work, and I found that "Change Memory & Cache" (and not "Check Memory Advance") defaults to fix this issue.

So does this help you.
  1. From program settings "Options/Settings...", in the main options disable "Hide Advanced Settings" if it is not already disabled; save changes.
  2. If you have Project64 set to organize installed games in a browser, right-click the label where you see it for Zelda Ocarina of Time, and choose "Edit Game Settings".
  3. Changing the "self-modifying code method" setting to either "Change Memory & Cache" or "Protect Memory" should help stop the hanging here, the later option being more stable but slow and not always needed.
As for what I thought before, well I wasn't sure what to think; like I said something reoptimized itself or something when I regenerated the save state on my end. (Maybe the original tester had a different interference causing the internal hang.)

It happened for me a bit with your save state as well at first, except immediately with yours on the first try I witnessed the report come true for the first time. After I completely changed the game's configuration preset to as stable as possible, I found that there was some change in settings that could fix this, but the next time I loaded your save state after turning everything back to what I had before, I couldn't get the hang to happen again. I re-installed your original state that I had derived from and reproduced it again, so that was the end of that.
  #10  
Old 24th November 2009, 09:11 AM
squall_leonhart's Avatar
squall_leonhart squall_leonhart is offline
Alpha Tester
Project Supporter
Senior Member
 
Join Date: Mar 2007
Location: Sydney, Australia
Posts: 2,885
Default

Quote:
First, I loaded my profile like normal and then realized I needed to use F7 to restore my quick save (pressed F5 after playing nocturne of shadow). When I loaded my profile I was kid link in my old Kokiri Forest hut (no clue why I started there since I did a hard save in the Temple of Time).
only adult link starts in the temple of time.
__________________
Xfire Profile | VBA-M | XBCD 0.2.7

CPU:Intel i7 920 @ 3.8(D0), Mainboard:Asus Rampage II Gene, Memory:12GB Corsair Vengeance 1600
Video:EVGA Geforce GTX 680+ 4GB, Sound:Creative XFI Titanium Fatal1ty Pro, Monitor:BenQ G2400WD
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Guardian 921RB, PSU:Corsair 620HX, OS:Windows 7 SP1
 

Tags
zalda ocarina time crash

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 04:53 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.